Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th June 2012, 18:57
DKLeader DKLeader is offline
Senior Member
 
Join Date: Sep 2010
Location: Ishoej, Denmark
Posts: 115
Thanks: 7
Thanked 0 Times in 0 Posts
Default Multiserver setup mail() problem

Hi,

I am running vers 3.0.4.5 in a multiserver setup on Debian.

When users install i.e. WEBSpell or PHPFusion mail() does not work.

I have checked with different logs on the servers to see if I could find a reason for this.

The solutions I have found searching google only gave hints for single server but not when running on a multiserver setup.

Anyone got a hint to what to do / change?
__________________
VoiceMe
Communications


Hosted at :
SuperWeb.dk
a part of VoiceMe
Reply With Quote
Sponsored Links
  #2  
Old 18th June 2012, 09:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,077
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

Ensure that you installed at least a minimal webserver like postfix or exim listening on localhost on the server so that php can send emails.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th June 2012, 22:44
DKLeader DKLeader is offline
Senior Member
 
Join Date: Sep 2010
Location: Ishoej, Denmark
Posts: 115
Thanks: 7
Thanked 0 Times in 0 Posts
Default

I do have postfix running on the webserver.
Code:
web:/etc/postfix# /etc/init.d/postfix check
web:/etc/postfix#
If I do a restart :
Code:
web:/etc/postfix# /etc/init.d/postfix restart
Stopping Postfix Mail Transport Agent: postfix.
Starting Postfix Mail Transport Agent: postfix.
web:/etc/postfix#
From ps aux | grep postfix
Code:
root      3132  0.0  0.0   8368   756 ?        Ss   Mar16   0:00 /usr/sbin/saslauthd -a shadow -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root      3133  0.0  0.0   8368   476 ?        S    Mar16   0:00 /usr/sbin/saslauthd -a shadow -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root      3135  0.0  0.0   8368   360 ?        S    Mar16   0:00 /usr/sbin/saslauthd -a shadow -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root      3137  0.0  0.0   8368   360 ?        S    Mar16   0:00 /usr/sbin/saslauthd -a shadow -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root      3139  0.0  0.0   8368   360 ?        S    Mar16   0:00 /usr/sbin/saslauthd -a shadow -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root     25157  0.0  0.0   5628  1848 ?        Ss   21:48   0:00 /usr/lib/postfix/master
postfix  25158  0.0  0.0   5640  1816 ?        S    21:48   0:00 pickup -l -t fifo -u -c
postfix  25159  0.0  0.0   8028  2360 ?        S    21:48   0:00 qmgr -l -t fifo -u
postfix  25188  0.0  0.0   6008  2628 ?        S    21:49   0:00 tlsmgr -l -t unix -u -c
__________________
VoiceMe
Communications


Hosted at :
SuperWeb.dk
a part of VoiceMe
Reply With Quote
  #4  
Old 19th June 2012, 23:45
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Are there any errors in the web server's mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 30th June 2012, 21:02
DKLeader DKLeader is offline
Senior Member
 
Join Date: Sep 2010
Location: Ishoej, Denmark
Posts: 115
Thanks: 7
Thanked 0 Times in 0 Posts
Default

As I see it it seems that everything is ok but the e-mails are never delivered. I have noticed that an error related to amavis.
From the mail.log :
Code:
Jun 30 20:36:40 web postfix/pickup[17448]: 9BB7E3EC4A0: uid=33 from=<www-data>
Jun 30 20:36:40 web postfix/cleanup[17682]: 9BB7E3EC4A0: message-id=<20120630183640.9BB7E3EC4A0@web.superweb.dk>
Jun 30 20:36:40 web postfix/qmgr[26057]: 9BB7E3EC4A0: from=<www-data@SuperWebServer10.superweb.dk>, size=467, nrcpt=1 (queue active)
Jun 30 20:36:40 web amavis[18021]: (18021-09) NOTICE: reconnecting in response to: err=2006, HY000, DBD::mysql::st execute failed: MySQL server has gone away at (eval 86) line 166, <GEN117> line 3.
Jun 30 20:36:41 web postfix/smtpd[17687]: connect from localhost[127.0.0.1]
Jun 30 20:36:41 web postfix/smtpd[17687]: D651B3EC049: client=localhost[127.0.0.1]
Jun 30 20:36:41 web postfix/cleanup[17682]: D651B3EC049: message-id=<20120630183640.9BB7E3EC4A0@web.superweb.dk>
Jun 30 20:36:41 web postfix/qmgr[26057]: D651B3EC049: from=<www-data@SuperWebServer10.superweb.dk>, size=913, nrcpt=1 (queue active)
Jun 30 20:36:41 web postfix/smtpd[17687]: disconnect from localhost[127.0.0.1]
Jun 30 20:36:41 web amavis[18021]: (18021-09) Passed CLEAN, <www-data@SuperWebServer10.superweb.dk> -> <jg@voiceme.dk>, Message-ID: <20120630183640.9BB7E3EC4A0@web.superweb.dk>, mail_id: l1veNvoXY$
Jun 30 20:36:41 web postfix/smtp[17684]: 9BB7E3EC4A0: to=<jg@voiceme.dk>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.3, delays=0.08/0.02/0/1.2, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=18021-09, fr$
Jun 30 20:36:41 web postfix/qmgr[26057]: 9BB7E3EC4A0: removed
Jun 30 20:36:41 web postfix/pipe[17688]: D651B3EC049: to=<jg@voiceme.dk>, relay=maildrop, delay=0.1, delays=0.03/0.02/0/0.05, dsn=2.0.0, status=sent (delivered via maildrop service)
Jun 30 20:36:41 web postfix/qmgr[26057]: D651B3EC049: removed
Quote:
Originally Posted by falko View Post
Are there any errors in the web server's mail log?
__________________
VoiceMe
Communications


Hosted at :
SuperWeb.dk
a part of VoiceMe
Reply With Quote
  #6  
Old 3rd July 2012, 16:13
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Jun 30 20:36:40 web postfix/qmgr[26057]: 9BB7E3EC4A0: from=<www-data@SuperWebServer10.superweb.dk>, size=467, nrcpt=1 (queue active)
Jun 30 20:36:40 web amavis[18021]: (18021-09) NOTICE: reconnecting in response to: err=2006, HY000, DBD::mysql::st execute failed: MySQL server has gone away at (eval 86) line 166, <GEN117> line 3.
Seems as if there's a problem with your MySQL server. Did you check your syslog for MySQL error? MySQL problems can also originate from not having enough RAM or a high system load.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
debian, mail, multiserver

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Email Working ISPConfig3 Squirrelmail and Courier etc Ian Wilson Installation/Configuration 17 19th June 2013 22:58
installing squirrelmail on Debian with ispconfig3 saco721 Installation/Configuration 18 1st April 2011 17:57
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
ISPconfig 3 some users cannot send email to outside Rockblade Installation/Configuration 7 29th April 2010 01:40
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50


All times are GMT +2. The time now is 14:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.