Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th June 2012, 13:49
Whistler Whistler is offline
Junior Member
 
Join Date: Oct 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Default page for https

Where can I configure the default page for "https" connection?
For default "http" connection apache correctly points to /var/www/index.html, but for https://server_IP it points to one of the existed "https:// sites.
Please help

I'm using ISPConfig 3.0.4.5
Reply With Quote
Sponsored Links
  #2  
Old 14th June 2012, 16:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Try this (if you use Debian/Ubuntu):

Code:
a2ensite default-ssl
Restart Apache afterwards:
Code:
/etc/init.d/apache2 restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 14th June 2012, 16:48
Whistler Whistler is offline
Junior Member
 
Join Date: Oct 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanx for reply, but didn't help.

There is appeared a new file "default-ssl" in /etc/apache2/sites-enabled/ with default path to /var/www/ but still https://Server_IP point to one of the existed "https" sites.
Reply With Quote
  #4  
Old 14th June 2012, 16:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,169
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

SSL is a IP based protocol, so you should not have more then one ssl sites on that IP address. The default ssl page is only displayed for IP addresses were no site exists for.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 14th June 2012, 17:26
Whistler Whistler is offline
Junior Member
 
Join Date: Oct 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Strange, but if I type http://Server_IP, apache shows the default page not existed site, but why it's not applicable to https ?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 82815 Video Card & Ubuntu 8.10 harvey527 Kernel Questions 8 5th November 2010 14:51
User creating shoevring Developers' Forum 7 25th July 2010 10:17
amavis: (!!)WARN: all primary virus scanners failed, considering ba jariasca Installation/Configuration 13 20th April 2010 17:34
Admin Program for Virtual Users and Domains Postfix courier etc...(Ubuntu 8.04)? the1rob HOWTO-Related Questions 11 4th August 2009 04:54
Exim MTA dazblade Server Operation 4 16th July 2007 18:42


All times are GMT +2. The time now is 12:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.