Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th May 2012, 02:14
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
Default Quota - CentOS - Xen VPS... configure /etc/fstab ?

Hello..

I'm just setting up a CentOS 6.2 VPS as per http://www.howtoforge.com/perfect-se...ispconfig-3-p3 .

I'm up to step 8 - Quota
I need a little assistance with editing /etc/fstab as my setup is a bit different from the tutorial.
I'm using CentOS 6.2 64bit,
The VPS host says they use Xen virtualization...

For starters this is what /etc/fstab looks like as default.
Can someone assist with how to configure for my Xen VPS..?

Code:
#
# /etc/fstab
# Created by anaconda on Tue Apr 10 19:11:20 2012
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/xvda       /               ext3    noatime,errors=remount-ro       0 1
/dev/xvdb       none            swap    sw                              0 0
/proc           /proc           proc    defaults                        0 0
tmpfs           /dev/shm        tmpfs   nodev,nosuid,noexec             0 0
devpts          /dev/pts        devpts  gid=5,mode=620                  0 0
sysfs           /sys            sysfs   defaults                        0 0
Reply With Quote
Sponsored Links
  #2  
Old 6th May 2012, 12:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Your fstab should look as follows:

Code:
#
# /etc/fstab
# Created by anaconda on Tue Apr 10 19:11:20 2012
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/xvda       /               ext3    noatime,errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0       0 1
/dev/xvdb       none            swap    sw                              0 0
/proc           /proc           proc    defaults                        0 0
tmpfs           /dev/shm        tmpfs   nodev,nosuid,noexec             0 0
devpts          /dev/pts        devpts  gid=5,mode=620                  0 0
sysfs           /sys            sysfs   defaults                        0 0
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th May 2012, 22:38
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
Default quotacheck: Cannot find filesystem...

I've adjusted /etc/fstab... as above... now the following output;

Code:
[root@li396-140 ~]# mount -o remount /
[root@li396-140 ~]# quotacheck -avugm
quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.
Reply With Quote
  #4  
Old 7th May 2012, 12:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's your quota version? According to http://www.webhostingtalk.com/showthread.php?t=1009974, you could have the wrong version.

You can also try this solution: http://www.howtoforge.com/forums/sho...4&postcount=15
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd July 2014, 13:13
Nap Nap is offline
Senior Member
 
Join Date: Oct 2006
Posts: 150
Thanks: 10
Thanked 2 Times in 2 Posts
Default

I am having the same problem concerning /dev/root on Ubuntu 14.04LTS on my VPS. It worked fine when I did a trial install in a VirtualBox machine under Windows.

Creating the symlink ( /dev/xvda in my case) helped. But when I rebooted, the problem came back..

Is there a way of creating the link so it persists across boots (or have it created in a startup file)?

SOLVED I put "ln -s /dev/xvda /dev/root" into /etc/rc.local before the "exit 0" statement.

Cheers,
Nap
__________________
My VPS system:
(Ubuntu 14.04 LTS, Kernel 3.15.4-x86_64, Apache 2.4.7, MySQL 5.5.38, PHP 5.5.9, ISPConfig 3.0.5.4p1, Webmin, PureFTP & Quota, phpMyAdmin, postfix, dovecot, clamav, spamassassin, awstats, fail2ban, Jailkit, bind9, vlogger, webalizer)

Last edited by Nap; 23rd July 2014 at 13:42.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cron issue in Debian 6 Nolan Installation/Configuration 6 18th April 2011 17:36
Problems connecting my HTC Desire outgoing mail client to Postfix and ISP Config 2 j.smith1981 Server Operation 6 12th July 2010 20:07
Companion Script #2 for The Perfect Server - Fedora 13 x86_64 [ISPConfig 3]" MrCompTech Tips/Tricks/Mods 0 10th July 2010 06:11
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 17:22
Error in connecting to vpn server anoopprasad Installation/Configuration 5 16th June 2008 19:18


All times are GMT +2. The time now is 02:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.