Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th March 2012, 20:17
Giuseppe Giuseppe is offline
Junior Member
 
Join Date: Jul 2011
Posts: 21
Thanks: 0
Thanked 1 Time in 1 Post
Default mailman & ispconfig 3.0.4.3 installation problem

Hi all,
i have some problem when install mailman on already existent ispconfig 3.0.4.3 installation.
I hope someone can help me.
My environment is:
Debian squeeze 6.0.4
ispconfig 3.0.4.3
ispconfig is installed on cp.mydomain.it on port 80

I had ispconfig already installed without mailman installation, but now i need mailman so i have do the follow:
apt-get install mailman
newlist mailman
added alias about mailman list in /etc/aliases
newaliases
/etc/init.d/postfix restart
/etc/init.d/mailman start
php -q update.php reconfiguring services

BUT:
after that up done when i go to http://cp.mydomain.it/mailman/listinfo i have:
not found The requested URL /mailman/listinfo was not found on this server.
if i go to: http://cp.zyzhsp.it/cgi-bin/mailman/listinfo i have:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Please help me!
Thank you for your collaboration.

Giuseppe
Reply With Quote
Sponsored Links
  #2  
Old 27th March 2012, 07:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,333 Times in 4,184 Posts
Default

Is cp.mydomain.it a website? If yes, is suexec enabled for the site?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th March 2012, 08:39
Giuseppe Giuseppe is offline
Junior Member
 
Join Date: Jul 2011
Posts: 21
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi Till,
thank you for your help,
yes cp.mydomain.it is a website and exactly the website where my ispconfig control panel work and yes suexec is active on this website.
I have linked /etc/mailman/apache.conf to /etc/apache2/conf.d/mailman.conf exactly as is it in mailman directory and without active the virtual host comment out in it. Is it correct?
Thank you very much.

Giuseppe
Reply With Quote
  #4  
Old 28th March 2012, 12:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Please disable suExec and try again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 28th March 2012, 12:52
Giuseppe Giuseppe is offline
Junior Member
 
Join Date: Jul 2011
Posts: 21
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thank you very much, solved
Reply With Quote
  #6  
Old 5th April 2012, 00:19
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
Default

I have a similar issue after installing mailman, i'm getting url not found on both (admin and listinfo).

When i run

Code:
php -q update.php reconfiguring services
there is this:

Code:
Traceback (most recent call last):
  File "/usr/lib/mailman/bin/mailmanctl", line 106, in <module>
    from Mailman import mm_cfg
  File "/var/lib/mailman/Mailman/mm_cfg.py", line 76, in <module>
    DEFAULT_SERVER_LANGUAGE = en
NameError: name 'en' is not defined
Restarting Mailman master qrunner: mailmanctl
I have no suExec on the site and i'm on debian 6.

Thank you in advance.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Version 1.3 of the ISPConfig 3 Manual is finally available! falko General 44 2nd December 2011 12:04
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
Installation problem - WARNING: Could not unpack ISPConfig system?!? darko Installation/Configuration 3 19th July 2009 18:43
Problem with my ISPconfig installation Purposite Installation/Configuration 2 13th June 2009 18:54
ISPconfig Virtual Hosts + Perfect setup Problem ? orasis Installation/Configuration 5 16th March 2007 10:46


All times are GMT +2. The time now is 01:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.