#1  
Old 19th February 2012, 11:52
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 426
Thanks: 33
Thanked 54 Times in 37 Posts
Send a message via Skype™ to SamTzu
Unhappy Awstat problems

Awstat keeps annoying with it's SPAM email to www-data mailbox (that nobody reads.) www-mailbox fills fast to it's 50Mb default limit and stops accepting any more messages.

These are the usual messages...

Quote:
Error: SiteDomain parameter not defined in your config/domain file. You must edit
it for using this version of AWStats.
Setup ('/etc/awstats/awstats.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory).
Quote:
Create/Update database for config "/etc/awstats/awstats.domain.com.conf" by AWStats
version 6.95 (build 1.943)
>From data in log file "/var/log/ispconfig/httpd/domain.com/yesterday-access.log"...
Error: Couldn't open server log file "/var/log/ispconfig/httpd/domain.com/yesterday-access.log"
: No such file or directory
Setup ('/etc/awstats/awstats.domain.com.conf' file, web server or permissions) may
be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory).
Error: SiteDomain parameter not defined in your config/domain file. You must edit
it for using this version of AWStats.
Setup ('/etc/awstats/awstats.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory).
Fixing these are burdensome when there are hundreds of domains per server.
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent

Reply With Quote
Sponsored Links
  #2  
Old 20th February 2012, 09:30
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,450
Thanks: 813
Thanked 5,218 Times in 4,090 Posts
Default

Please check that the timezone defined in the file /usr/local/ispconfig/server/lib/config.inc.php matches the timezone of your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 22nd February 2012, 06:53
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 426
Thanks: 33
Thanked 54 Times in 37 Posts
Send a message via Skype™ to SamTzu
Default

You might be on to something.
ISPConfig is set for UTC but the server is set for Helsinki.
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent

Reply With Quote
Reply

Bookmarks

Tags
awstats

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing LAMP - MySQL and PHP5 JosBR Server Operation 5 19th December 2009 21:00
Courierr Errors were encountered while processing AsDsL General 1 30th November 2009 08:03
E: Sub-process /usr/bin/dpkg returned an error code (1) ergti Installation/Configuration 1 16th August 2009 12:36
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11
Empty Recycle Bin jon335 General 40 6th May 2006 11:56


All times are GMT +2. The time now is 11:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.