Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th January 2012, 01:41
MaxPower MaxPower is offline
Junior Member
 
Join Date: Jan 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Apache now runs as 'apache' user after PHP upgrade

Hi all,

I was wondering if someone knows what's up.

I have ISP Config 2 running on my server and all has been well until today. I needed to upgrade PHP from 5.1 to 5.3.

I removed the php-* packages, and installed the equivalent php53-* packages.

I've noticed since then, that PHP seems to be writing files to the server with the 'apache' user context.

I'd love to know how I can fix this. I'm running CentOS 5.6 (upgraded from 5.5).

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 28th January 2012, 12:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

If you use mod_php, this depends on the user and group that Apache is running as. I think apache is the correct user for CentOS.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 13th February 2012, 17:45
MaxPower MaxPower is offline
Junior Member
 
Join Date: Jan 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry for not coming back sooner.

Yes, apache is the correct user, but not when using ISPConfig.

Each apache/http domain would write files under its own user:group context (ie. web1_admin:web1).

Since updating PHP this has stopped. I've modified the permissions on the domains to apache, but it's far from ideal and not great security.

Anyone have any suggestions how I can get this behaviour back?
Reply With Quote
  #4  
Old 13th February 2012, 17:52
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,170
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

Pleasecheck that you use "php-fcgi" as php mode and that suexec is enabled in the website settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
apache, centos 5.6, permissions, php

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with ISPConfig Mail and Squirrelmail m.xander Installation/Configuration 109 3rd February 2012 00:15
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
Slightly Confused (DNS & Server Help) JohnnyBGoode Installation/Configuration 26 14th August 2007 09:54


All times are GMT +2. The time now is 12:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.