Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th January 2012, 15:54
WouterDS WouterDS is offline
Junior Member
 
Join Date: Jan 2012
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default Nginx Debian Squeeze "No input file specified."

Ok so I've been trying the past 6 hours to install nginx, php & mysql on my debian squeeze vps but with no luck.

I did this before on ubuntu, also with da guide from this site and got everything up and running in minutes so I'm not sure what's the problem here.

Anyway, my problem now:

Some files work, others don't.
So I created 3 files with the following permissions and the only file that can be parsed is info.php. I know this is a permission issue but I don't know how to fix it.

Also, I would like access with other users except root & www-data to the www folder (it's located in /home/wouterds/www in my configuration).


Please feel free to try it yourself: http://paradox-productions.net/

Permissions:


Sorry for the weird post and my bad English but I'm really stressed at the moment it still doesn't work and it's so easy to do.

Thanks in advance,
WouterDS

Last edited by WouterDS; 25th January 2012 at 16:00.
Reply With Quote
Sponsored Links
  #2  
Old 25th January 2012, 16:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Do you talk about the nginx guides from Falko timme or the perfects etup ispconfig 3 / nginx for Ubuntu? If yes, then the nginx version in Debian squeeze is too old for the setup described there. If you want to use debian, you will have to use debian testing.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 25th January 2012, 16:36
WouterDS WouterDS is offline
Junior Member
 
Join Date: Jan 2012
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hello, thank you for your reply.

I used this guide, thought I mentioned it in the post but apparently I didn't.

http://www.howtoforge.com/installing...debian-squeeze
Reply With Quote
  #4  
Old 25th January 2012, 16:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Ahh ok, that one should work on squeeze of course, its a different setup then the one used on the perfect setup guides.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 25th January 2012, 17:00
WouterDS WouterDS is offline
Junior Member
 
Join Date: Jan 2012
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default

So have you any idea how to fix it?
I have reinstalled different OS's on this VPS the past 3 days and I'm really going nuts if I have to reinstall everything again .
Reply With Quote
  #6  
Old 25th January 2012, 17:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

maybe falko gan help you with that. I use apache on my servers and not nginx.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
debian, nginx, no input file specified, squeeze, vps

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't finish install due a problem Sam9999 Installation/Configuration 7 17th September 2010 23:33
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 22:13
libWand.so.10 error Taxick Installation/Configuration 8 3rd May 2009 02:27
drbd error -115 anandx Installation/Configuration 15 26th April 2009 20:16
jamed up my table borders?? Boon-Dog-Danny Installation/Configuration 5 23rd September 2006 17:12


All times are GMT +2. The time now is 11:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.