Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th January 2012, 00:39
PhoNull PhoNull is offline
Junior Member
 
Join Date: Mar 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Enable FXP pure-ftp ispconfig3-debian

Hi,

I have been searching for a solution to enable fxp for pure-ftpd on a ispconfig3 debian server.

I tried to add AllowFXPUser=yes to /etc/default/pure-ftpd-common but I still get a site to site transfer failed!
Reply With Quote
Sponsored Links
  #2  
Old 25th January 2012, 21:14
PhoNull PhoNull is offline
Junior Member
 
Join Date: Mar 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Bump, Falko, till ? could you please give me the command to enable fxp .. I have looked everywhere.
Reply With Quote
  #3  
Old 25th January 2012, 22:56
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

In pure-ftpd, I think the command is allowuserfxp and not the one you are using.

Regards
Reply With Quote
  #4  
Old 26th January 2012, 00:02
PhoNull PhoNull is offline
Junior Member
 
Join Date: Mar 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ty for the reply but the same crap.

Site to Site Transfer Failed! (Attempting alternative method)
Reply With Quote
  #5  
Old 26th January 2012, 03:37
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Try this:

echo "yes" > /etc/pure-ftpd/conf/AllowUserFXP

Restart pure-ftpd




----

first line will create AllowUserFXP file, inside of that file, it will writte yes. When restarting pure-ftpd, you should see there a -w parameter. If you see it, FXP is enabled and your problem is other... (maybe some other settings allowing connection from/to in your server, because FXP is highly insecure? you should read pure-ftp doc).

Regards
Reply With Quote
  #6  
Old 26th January 2012, 07:08
PhoNull PhoNull is offline
Junior Member
 
Join Date: Mar 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks for the help. Yeah I did that command .. it seems to be a firewall issue with the passive ports.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
pure ftp dont work cyprus Installation/Configuration 15 4th November 2011 17:34
Debian 6.0 ftp loses host & aborts - ispconfig3 conductive HOWTO-Related Questions 18 7th October 2011 02:52
ISPConfig3 FTP problem karazy-k Server Operation 6 3rd September 2009 17:03
setup fails on debian 3.1 dtrumbower Installation/Configuration 7 7th March 2006 14:42
FTP 101 the basics koegies Installation/Configuration 7 17th November 2005 16:55


All times are GMT +2. The time now is 07:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.