Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th January 2012, 23:13
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default Mail server, Yahoo, Gmail as Spam

Hello all,

Please I need a little help with a little problem...

Aside of hotmail, every mail sent by my mail server was arriving ok to inbox in gmail and yahoo. A client used our servers to send spam for two days... we kick it from our hosting, but right now, every mail send by my server is going directly to spam...

Do you know how can I give advise to yahoo and gmail about the situation, clarify that it has been fixed, and get all mails again to inbox?

If there is no solution to this, maybe I will have to use a different IP...

Thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 18th January 2012, 11:45
bassie bassie is offline
Junior Member
 
Join Date: Jan 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

You are probably blacklisted. You can check here

Changing you IP is a bit extreme...
You could change your IP, keep in mind also to change reverse DNS record.
Reply With Quote
  #3  
Old 18th January 2012, 13:43
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Thanks, but I am not blacklisted in any place. The problem is that my mails are marked by google as spam, this was not happening before this user activity. I want to know where can I check my rep with google, or where can I send a form giving advise that the situation has been stoped.

Thanks!
Reply With Quote
  #4  
Old 19th January 2012, 15:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by erosbk View Post
I want to know where can I check my rep with google, or where can I send a form giving advise that the situation has been stoped.
Please check your mail log. The big companies send back a URL in the error code that gets logged in the mail log, and when oyu visit this URL you can normally fill out a form and request to be removed from their internal blacklist.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following 2 Users Say Thank You to falko For This Useful Post:
audreyibsilverman (30th September 2013), erosbk (3rd February 2012)
  #5  
Old 3rd February 2012, 18:40
emdok emdok is offline
Junior Member
 
Join Date: Feb 2009
Posts: 18
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by erosbk View Post
Thanks, but I am not blacklisted in any place. The problem is that my mails are marked by google as spam, this was not happening before this user activity. I want to know where can I check my rep with google, or where can I send a form giving advise that the situation has been stoped.

Thanks!
Pretty sure you're blacklisted somewhere
Be sure you're entering the right IP or FQDN from your mail server.

You'll need to do as falko has posted.
Reply With Quote
The Following User Says Thank You to emdok For This Useful Post:
erosbk (3rd February 2012)
  #6  
Old 3rd February 2012, 21:27
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Thanks both of you, I checked everywhere (aside of mxtoolbox) for blacklists and all my IPs are clean.

A client was using email server to send mails to google groups and others list, with a LOT of rejected mailboxs (I received lots of rejected address, really lots, 2000+ per hour)... I didn't find any message in logs, and with yahoo right now mails are starting to arrive at inbox... cannot say the same for gmail, I still arrive to spam after this, before I was arriving always to inbox...

But well, I think that in a while it will be fixed without intervention of my side... if someone has more ideas please post here.

Regards and thanks again for your help and future advises!
Reply With Quote
  #7  
Old 13th February 2012, 13:10
bassie bassie is offline
Junior Member
 
Join Date: Jan 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did your check your SPF record?
Reply With Quote
  #8  
Old 23rd September 2014, 12:29
recin recin is offline
Member
 
Join Date: Apr 2012
Posts: 43
Thanks: 4
Thanked 6 Times in 6 Posts
Default

Quote:
Originally Posted by erosbk View Post
Hello all,

Aside of hotmail, every mail sent by my mail server was arriving ok to inbox in gmail and yahoo. A client used our servers to send spam for two days... we kick it from our hosting, but right now, every mail send by my server is going directly to spam...

Do you know how can I give advise to yahoo and gmail about the situation, clarify that it has been fixed, and get all mails again to inbox?

If there is no solution to this, maybe I will have to use a different IP...
I have exactly the same problem.

Mails sended from my mail server were arriving OK to gmail inbox (even with no SPF nor DKIM records).

One account was sending spam for 2 days. We solved it but since then (1 month ago) our mails always arrive at gmail spam folder.
My senderscore was about 90, it go down to 50 and now is 75.
  • According to mxtoolbox im not on any blacklist
  • Reverse DNS are OK
  • SPF record OK (now, I didn't have it before)
  • DKIM record OK (now, I didn't have it before)
  • DMARC record OK (now, I didn't have it before)
  • I fill this form to gmail but i have no response
This is the header of a mail that goes to gmail spam (I changed mail accounts and IP for privacy reasons). It seems everything is OK:
Quote:
Delivered-To: account@gmail.com
Received: by 10.170.92.131 with SMTP id j125csp386538yka;
Tue, 23 Sep 2014 03:20:21 -0700 (PDT)
X-Received: by 10.180.104.7 with SMTP id ga7mr2190323wib.36.1411467620593;
Tue, 23 Sep 2014 03:20:20 -0700 (PDT)
Return-Path: <account@mydomain.es>
Received: from nicerterrae.c.ovd.interhost.com (nicerterrae.c.ovd.interhost.com. [1.2.3.4])
by mx.google.com with ESMTP id dy10si1746921wib.89.2014.09.23.03.20.19
for <account@gmail.com>;
Tue, 23 Sep 2014 03:20:20 -0700 (PDT)
Received-SPF: pass (google.com: domain of account@mydomain.es designates 1.2.3.4 as permitted sender) client-ip=1.2.3.4;
Authentication-Results: mx.google.com;
spf=pass (google.com: domain of account@mydomain.es designates 1.2.3.4 as permitted sender) smtp.mail=account@mydomain.es;
dkim=pass header.i=@mydomain.es;
dmarc=pass (p=NONE dis=NONE) header.from=mydomain.es
Received: from localhost (localhost [127.0.0.1])
by nicerterrae.c.ovd.interhost.com (Postfix) with ESMTP id 351B362452
for <account@gmail.com>; Tue, 23 Sep 2014 12:20:19 +0200 (CEST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=mydomain.es; h=
content-transfer-encoding:content-type:content-type:mime-version
:user-agent:from:from:subject:subject:date:date:message-id; s=
default; t=1411467618; x=1413282018; bh=kXPKBqt5rfzQUy21ux8y+Bf7
6AknnTLJH4iyXIjtd/0=; b=Wzr2IufsFk7bgBsqw++zbA1s9acD5VNdx+pihXwr
uWI+yCwjwrUvXdrZhewkukTgygvGKf2aVFtbcDFIkZapZk3y5o i0L4lUIx3e0RIx
ixosDGA2z/9Wxy8dF3mlJxeyKCsONzTG65RujlbjClc8gpC/ItM7qfEe0zoyWAxW
2M4=
X-Virus-Scanned: Debian amavisd-new at nicerterrae.c.ovd.interhost.com
Received: from nicerterrae.c.ovd.interhost.com ([127.0.0.1])
by localhost (nicerterrae.c.ovd.interhost.com [127.0.0.1]) (amavisd-new, port 10026)
with ESMTP id dh6wazpGxKYw for <account@gmail.com>;
Tue, 23 Sep 2014 12:20:18 +0200 (CEST)
Received: from mydomain.es (unknown [IPv6:::1])
by nicerterrae.c.ovd.interhost.com (Postfix) with ESMTP id 73B9E62450
for <account@gmail.com>; Tue, 23 Sep 2014 12:20:18 +0200 (CEST)
Received: from 93.156.201.130
(SquirrelMail authenticated user account@mydomain.es)
by mydomain.es with HTTP;
Tue, 23 Sep 2014 12:20:18 +0200
Message-ID: <afc02270a3c7a1356fa8d661299b3da8.squirrel@mydomai n.es>
Date: Tue, 23 Sep 2014 12:20:18 +0200
Subject: prueba desde webmail
From: account@mydomain.es
To: account@gmail.com
User-Agent: SquirrelMail/1.4.22
MIME-Version: 1.0
Content-Type: text/plain;charset=iso-8859-1
X-Priority: 3 (Normal)
Importance: Normal
Content-Transfer-Encoding: quoted-printable

prueba 2
What else can i do?
Reply With Quote
  #9  
Old 14th October 2014, 10:01
recin recin is offline
Member
 
Join Date: Apr 2012
Posts: 43
Thanks: 4
Thanked 6 Times in 6 Posts
Default

Finally gmail stop marking my mails as spam.
This happened exactly 1 month after the spam attack, when my senderscore goes from 80 to 99 (as it was before).

Here is a screenshot:


So in this case the only solution seems to be wait.

Meanwhile I tried postmark. They give you the option to send 25000 mails from they servers for free. You can configure your mail client (outlook, thunderbird...) to do that (there are other options but I didn't try them)

Last edited by recin; 14th October 2014 at 10:04.
Reply With Quote
  #10  
Old 14th October 2014, 10:03
recin recin is offline
Member
 
Join Date: Apr 2012
Posts: 43
Thanks: 4
Thanked 6 Times in 6 Posts
Default

Finally gmail stop marking my mails as spam.
This happened exactly 1 month after the spam attack, when my senderscore goes from 80 to 99 (as it was before).

Here is a screenshot:

So in this case the only solution seems to be wait.

Meanwhile I tried postmark. They give you the option to send 25000 mails from they servers for free. You can configure your mail client (outlook, thunderbird...) to do that (there are other options but I didn't try them)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix/courier/Centos 6 cant send email to external email servers maxtorzito Installation/Configuration 14 7th October 2011 10:56
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
amavis & ispconfig 3 yalex2000 Installation/Configuration 20 18th February 2010 17:02


All times are GMT +2. The time now is 00:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.