Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th December 2011, 16:03
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Question Mail: new accounts having authentication problems

I've not tweaked my ISPConfg setup for a while because everything has been working beautifully.

Until today

I've set up a new domain and added the mail domain and added two mailboxes.

The web domain works fine (theerfore DNS is good)
But the email boxes cannot be reached - they fail authorization.

All other domains/mailboxes are working correctly.

I've upgraded my ISPConfig to 3.0.4.1. Hasn't helped.
Dovecot version is 1.2.17
Centos version 5.7(final)

Permissions in /var/vmail/ all look correct.

Where do I go from here?

Last edited by mike_p; 16th December 2011 at 16:29.
Reply With Quote
Sponsored Links
  #2  
Old 16th December 2011, 16:08
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Default

additional info: mail log reports
permission denied + the vmail users dir
and
missing +x perm
but the permissions ARE correct.
sieve: failed to stat user's sieve script:
Reply With Quote
  #3  
Old 17th December 2011, 16:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

What's the output of ls -la /var/mail/? Is SELinux disabled?

Can you post the exact error messages from your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 19th December 2011, 10:56
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Default

Ok seems to be solved.

After the mail authentication problems, i found DNS on my various websites started to fail. To test the sites I set up dns in my local hosts file and found the sites were okay. Then I noticed some odd things gong on with MySQL. Further testing found "describe <tables>" command came back with a SQL error saying unable to write to /tmp/#sql...

So I checked permissions on /tmp = 755
Changed permissions on /tmp to 777 and all problems solved.

Is 777 correct for tmp folder?
If so what changed it?
If not, what else could have changed to require this?

Last edited by mike_p; 19th December 2011 at 11:10. Reason: typos
Reply With Quote
  #5  
Old 20th December 2011, 12:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by mike_p View Post
Is 777 correct for tmp folder?
Yes, that's how it should be.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 20th December 2011, 13:17
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Default

Thanks for the confirmation Falko.

Last night, it was reset again to 700!

This has a variety of effects on services. Quite apart from the services that use the tmp directory directly, MySQL uses it for some operations, so any service that uses MySQL can show odd behaviour.

On monday some DNS requests were going astray.

This morning I found mail was stacking up in the mailqueue.
After reseting the tmp folder to 777, I then flushed the mailqueue and everything is back to normal.

Any ideas how or why the /tmp folder permissions are getting reset?
Reply With Quote
  #7  
Old 13th January 2012, 09:00
rolix rolix is offline
Junior Member
 
Join Date: Jan 2012
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have same problem when creating new mailbox
/tmp has 777

when i execute
chmod -R +x /var/vmail
i can login in the mailbox

here is my logfile:
Jan 13 08:48:50 ISPMAIL1 dovecot: deliver(rr@rr.at): chdir(/var/vmail/rr.at/rr) failed: Permission denied
Jan 13 08:48:50 ISPMAIL1 dovecot: deliver(rr@rr.at): sieve: stat(/var/vmail/rr.at/rr/.sieve) failed: Permission denied (using global script path in stead)
Jan 13 08:48:50 ISPMAIL1 dovecot: deliver(rr@rr.at): stat(/var/vmail/rr.at/rr/Maildir) failed: Permission denied
Jan 13 08:48:50 ISPMAIL1 dovecot: deliver(rr@rr.at): stat(/var/vmail/rr.at/rr/Maildir/tmp) failed: Permission denied (euid=5000(vmail) egid=5000(vmail) missing +x perm: /var/vmail/rr.at)
Jan 13 08:48:50 ISPMAIL1 dovecot: deliver(rr@rr.at): msgid=<20120112172902.50D33A1EAC@ISPMAIL1>: save failed to INBOX: Internal error occurred. Refer to server log for more information. [2012-01-13 08:48:50]
Reply With Quote
  #8  
Old 13th January 2012, 09:06
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,258 Times in 4,122 Posts
Default

Which ISPConfig version do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 13th January 2012, 09:14
rolix rolix is offline
Junior Member
 
Join Date: Jan 2012
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

latest ISPConfig Version: 3.0.4.2
Reply With Quote
  #10  
Old 13th January 2012, 09:21
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,258 Times in 4,122 Posts
Default

Ok, there are no known problems in that releasereagrding email. Please check under System > Server config > mail that the email user and group is set to vmail.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How cai remove amavis from postfix ? gabrix Server Operation 16 2nd October 2012 09:58
Sendig mail Error fisherofer Installation/Configuration 12 30th November 2011 07:56
Mailserver trouble: SASL authentication mjnet Installation/Configuration 6 22nd November 2011 13:20
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16


All times are GMT +2. The time now is 11:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.