#1  
Old 15th December 2011, 15:38
karuott karuott is offline
Junior Member
 
Join Date: Nov 2011
Posts: 17
Thanks: 2
Thanked 0 Times in 0 Posts
Default AWStats error.

Hello.

I'm having problem with awstats. It doesn't create /stats/awsindex.html file.
And because of that i'll get 404 error page.
Is there any solution to fix that problem?

Reply With Quote
Sponsored Links
  #2  
Old 15th December 2011, 15:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,386 Times in 4,231 Posts
Default

Check that the paths to the awstats scipts in System > Server config match the paths on your system.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
karuott (15th December 2011)
  #3  
Old 16th December 2011, 03:18
florix.net florix.net is offline
Member
 
Join Date: Oct 2010
Posts: 42
Thanks: 4
Thanked 1 Time in 1 Post
Default

Do I have to install awstats first? Or is it installed with ISPConfig?

I did locate awstats, but could not locate any file except

/usr/local/ispconfig/server/conf/awstats_index.php.master


I did yum install awstats, it installed aw, geoip, and perl-Geo-IP. Hope it will work now.

Do I have to make any changes in httpd conf files?


Richard
Reply With Quote
  #4  
Old 16th December 2011, 09:09
karuott karuott is offline
Junior Member
 
Join Date: Nov 2011
Posts: 17
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Weird. I changed paths but still it doesn't create that html file. In stats folder I have index.php and .htaccess. Awstats doesn't create any log files and there isn't any errors in apache errorlogs. I'm really stuck here

Ok. I found the problem awstat.site.conf searched awstats.conf but i had awstats.web.conf instead.

Last edited by karuott; 16th December 2011 at 11:29.
Reply With Quote
  #5  
Old 19th December 2011, 02:49
florix.net florix.net is offline
Member
 
Join Date: Oct 2010
Posts: 42
Thanks: 4
Thanked 1 Time in 1 Post
Default

HI ...

I am also having same problem.

All paths are set in server config, awstats installed using yum..

Any other change we have to do?

Please ... webalizer works fine, but it does not show all search results.

Richard
Reply With Quote
  #6  
Old 19th December 2011, 03:02
florix.net florix.net is offline
Member
 
Join Date: Oct 2010
Posts: 42
Thanks: 4
Thanked 1 Time in 1 Post
Default

I can see a file

/var/www/awstats/awstats122011.localhost.localdomain.txt

It has all data for all domains, how can I separate it for each domain?

Do I need to create conf files for each domain?

Richard
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 10.04 VS ISPConfig 2.2.37 Bicet Installation/Configuration 7 9th March 2011 15:58
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 13:21
setting-up-truecrypt-5.1a-on-debian-etch-gnome wiseman HOWTO-Related Questions 0 4th November 2009 00:18
Unbearably slow access speeds CombatGod Installation/Configuration 5 30th May 2006 16:31
Fresh Install on Debian cksrealm Installation/Configuration 12 22nd February 2006 16:14


All times are GMT +2. The time now is 08:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.