Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th December 2011, 04:24
HinterLan HinterLan is offline
Junior Member
 
Join Date: Dec 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Exim4 keeps forwarding emails instead of delivering them

We've set up an exim4 email server on a Debian6 system. It'll accept emails, and the forwards them upstream to our ISP, even when the emails are for the local system. How do I get it to stop doing this, and deliver the messages to its own mailboxes?
Reply With Quote
Sponsored Links
  #2  
Old 14th December 2011, 09:47
nbhadauria nbhadauria is offline
Member
 
Join Date: Aug 2010
Location: New Delhi, India
Posts: 79
Thanks: 1
Thanked 13 Times in 13 Posts
Send a message via Skype™ to nbhadauria
Default

check for following in exim.conf


domainlist local_domains = @ : localhost : localhost.localdomain
domainlist virtual_domains = dsearch;/var/spool/mail/conf/virtualdomains
__________________
Best
Nitin Bhadauria
Reply With Quote
  #3  
Old 14th December 2011, 10:07
HinterLan HinterLan is offline
Junior Member
 
Join Date: Dec 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here's the conf file generated by dpkg-reconfigure exim4-config.
I don't see anything for a domainlist.

dc_eximconfig_configtype='smarthost'
dc_other_hostnames='mail.network.net,smtp.network. net,network.net'
dc_local_interfaces='172.16.2.2 ; 172.20.2.2'
dc_readhost='network.net'
dc_relay_domains=''
dc_minimaldns='false'
dc_relay_nets='172.16.2.2/16;172.20.2.2/16'
dc_smarthost='smtp.outside.com'
CFILEMODE='644'
dc_use_split_config='false'
dc_hide_mailname='true'
dc_mailname_in_oh='true'
dc_localdelivery='maildir_home'


I'm also wondering if the problem is the MDA instead of the MTA.
Reply With Quote
  #4  
Old 14th December 2011, 10:18
nbhadauria nbhadauria is offline
Member
 
Join Date: Aug 2010
Location: New Delhi, India
Posts: 79
Thanks: 1
Thanked 13 Times in 13 Posts
Send a message via Skype™ to nbhadauria
Default

you have to check it use some command like ..

exim4 -C /etc/exim/exim_example.conf -d -bt user@example.com

search for your localhost entry ..

grep -iR "domainlist local_domains" /etc/exim4/
__________________
Best
Nitin Bhadauria
Reply With Quote
  #5  
Old 14th December 2011, 10:31
HinterLan HinterLan is offline
Junior Member
 
Join Date: Dec 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ran the command as you said and I got this:

Exim version 4.72 uid=0 gid=0 pid=3498 D=fbb95cfd
Berkeley DB: Berkeley DB 4.8.30: (April 9, 2010)
Support for: crypteq iconv() IPv6 PAM Perl Expand_dlfunc GnuTLS move_frozen_messages Content_Scanning DKIM Old_Demime
Lookups: lsearch wildlsearch nwildlsearch iplsearch cdb dbm dbmnz dnsdb dsearch ldap ldapdn ldapm mysql nis nis0 passwd pgsql sqlite
Authenticators: cram_md5 cyrus_sasl dovecot plaintext spa
Routers: accept dnslookup ipliteral iplookup manualroute queryprogram redirect
Transports: appendfile/maildir/mailstore/mbx autoreply lmtp pipe smtp
Fixed never_users: 0
Size of off_t: 8
GnuTLS compile-time version: 2.8.6
GnuTLS runtime version: 2.8.6
changed uid/gid: forcing real = effective
uid=0 gid=0 pid=3498
auxiliary group list: <none>
LOG: PANIC DIE
Exim configuration error in line 19 of /etc/exim4/update-exim4.conf.conf:
main option "dc_eximconfig_configtype" unknown
search_tidyup called
>>>>>>>>>>>>>>>> Exim pid=3498 terminating with rc=1 >>>>>>>>>>>>>>>>

That doesn't look good.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Broken Exim4 barney.parker Installation/Configuration 2 2nd March 2010 21:06
Emails not delivered via btinternet.com despite 250 ok dirdel dwb Server Operation 0 4th January 2010 14:17
PostFix can receive but can not send emails cjsdfw Server Operation 10 8th December 2009 08:11
ISPC2 How to do spam check BEFORE forwarding emails ? radim_h Tips/Tricks/Mods 1 18th March 2009 07:51
Not Delivering Emails with attachments dtrotter Installation/Configuration 7 26th August 2006 14:10


All times are GMT +2. The time now is 22:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.