#1  
Old 30th November 2011, 16:21
Ripeed Ripeed is offline
Member
 
Join Date: Oct 2011
Posts: 85
Thanks: 11
Thanked 1 Time in 1 Post
Red face webmail.domain.tld dont work :(

Hi, I have working domain.tld/webmail. But when I do the step 20.2 Squirrel mail in this tutor. And I want webmail.domain.tld that dont work.

If I remove # from:
<VirtualHost 1.2.3.4:80> <- i put there my IP
DocumentRoot /usr/share/squirrelmail
ServerName webmail.example.com <-there i put my domain
</VirtualHost>

Then every site on my server goes on http://domain.tld/webmail/src/login.php
If I try webmail.domain.tld -> goes on http://domain.tld/webmail/src/login.php
If I try www.domain.tld -> goes on http://domain.tld/webmail/src/login.php

I doing something wrong PLS help.

Thanks for reply.
Reply With Quote
The Following User Says Thank You to Ripeed For This Useful Post:
djkoelkast (3rd January 2012)
Sponsored Links
  #2  
Old 30th November 2011, 18:24
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 39
Thanked 90 Times in 68 Posts
Default

You need:

1) Create subdomain in ispconfig pointing to your webmail
2) Add a dns entry for this subdomain

Cheers!
Reply With Quote
  #3  
Old 30th November 2011, 19:25
Ripeed Ripeed is offline
Member
 
Join Date: Oct 2011
Posts: 85
Thanks: 11
Thanked 1 Time in 1 Post
Default

Thanks, but I create the subdomain. And I set the A DNS for it. And still dont work. The same... every site domain.tld on server goes on the squirrelmail exept the subdomain.domain.tld there is the default web. Any other ideas?

meaby I dont understant... What you think with "create subdomain that will pointing to your webmail" I will pointing with CNAME to domain.tld/webmail?

Last edited by Ripeed; 30th November 2011 at 19:32.
Reply With Quote
  #4  
Old 30th November 2011, 20:01
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 39
Thanked 90 Times in 68 Posts
Default

Quote:
Originally Posted by Ripeed View Post
meaby I dont understant... What you think with "create subdomain that will pointing to your webmail" I will pointing with CNAME to domain.tld/webmail?

Example (in Subdomain for website Tab):

Host: webmail
Domain: yourdomain.tld
Redirect type: R,L
Redirect path: http://yourdomain.tld:8080/webmail/

Be careful with the / at the end.
Reply With Quote
  #5  
Old 1st December 2011, 08:30
Ripeed Ripeed is offline
Member
 
Join Date: Oct 2011
Posts: 85
Thanks: 11
Thanked 1 Time in 1 Post
Default

OK, now i have it. But if I open webmail.domain.tld then it redirect me to domain.tld/webmail/src/login.php

It is posible have it like this:
I open webmail.domain.tld and it will stay as this webmail.domain.tld/src/login.php?

It must work like this

I dont know why it not work in configuration of squrrelmail:

vi /etc/apache2/conf.d/squirrelmail.conf

<VirtualHost 1.2.3.4:80>
DocumentRoot /usr/share/squirrelmail
ServerName webmail.example.com
</VirtualHost>

If i use this way, then every domain on my server pointing to /usr/share/squirrelmail
Reply With Quote
  #6  
Old 2nd December 2011, 17:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Host: webmail
Domain: yourdomain.tld
Redirect type: R,L
Redirect path: http://yourdomain.tld:8080/webmail/
Did you try the other flags?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting PHP to work with Cherokee maineac Installation/Configuration 3 2nd November 2010 05:31
How to config Proftpd to work with passive mode in ISPConfig 2.2.35 X-admin Installation/Configuration 0 6th June 2010 18:52
Email alias and forward do not work in ISPConfig 3 alecksievici Installation/Configuration 2 11th May 2010 15:12
Pure domain DNS doesn't work SyRenity Installation/Configuration 7 12th December 2006 12:12
Cant get any messenger program to work SimplyMepis 6.0 gtoman Technical 1 13th November 2006 15:26


All times are GMT +2. The time now is 07:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.