#1  
Old 28th October 2011, 06:52
Machtyn Machtyn is offline
Junior Member
 
Join Date: Oct 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix can't find user

I followed the guide here: Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (CentOS 6.0 x86_64) and everything seems to be working properly.

I set up an account admin at jawlawky.com

I sent a test email using mailx and then attempted to login. Unfortunately, everytime I try to login using either the raw telnet connection or the SquirrelMail web access, I have trouble. Finding that the imap was having trouble changing directory (chdir admin/admin/: No such file or directory) and knowing that the server is supposed to create the directory, I check my /var/log/maillog file. What I see is (with the timestamp and servername removed):
Code:
clamd[27102]: SelfCheck: Database status OK.
postfix/pickup[3196]: 7496138C8: uid=0 from=<root>
postfix/cleanup[3220]: 7496138C8: message-id=<20111028033047.7496138C8@alvinadams.jawlawky.com>
postfix/qmgr[27200]: 7496138C8: from=<root@alvinadams.jawlawky.com>, size=450, nrcpt=1 (queue active)
postfix/smtpd[3231]: connect from unknown[127.0.0.1]
postfix/smtpd[3231]: 4721B38CB: client=unknown[127.0.0.1]
postfix/cleanup[3220]: 4721B38CB: message-id=<20111028033047.7496138C8@alvinadams.jawlawky.com>
postfix/qmgr[27200]: 4721B38CB: from=<root@alvinadams.jawlawky.com>, size=898, nrcpt=1 (queue active)
amavis[32378]: (32378-01) Passed CLEAN, <root@alvinadams.jawlawky.com> -> <admin@jawlawky.com>, Message-ID: <20111028033047.7496138C8@alvinadams.jawlawky.com>, mail_id: SUT6LVtW2Fdb, Hits: 0.799, size: 450, queued_as: 4721B38CB, 5814 ms
postfix/smtp[3224]: 7496138C8: to=<admin@jawlawky.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=5.9, delays=0.03/0/0.01/5.8, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=32378-01, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 4721B38CB)
postfix/qmgr[27200]: 7496138C8: removed
postfix/virtual[3238]: 4721B38CB: to=<admin@jawlawky.com>, relay=virtual, delay=0.04, delays=0.01/0.02/0/0.01, dsn=5.1.1, status=bounced (unknown user: "admin@jawlawky.com")
postfix/cleanup[3220]: 50BC438CC: message-id=<20111028033053.50BC438CC@alvinadams.jawlawky.com>
postfix/qmgr[27200]: 50BC438CC: from=<>, size=2846, nrcpt=1 (queue active)
postfix/bounce[3240]: 4721B38CB: sender non-delivery notification: 50BC438CC
postfix/qmgr[27200]: 4721B38CB: removed
postfix/cleanup[3220]: 5444138C8: message-id=<20111028033053.50BC438CC@alvinadams.jawlawky.com>
postfix/qmgr[27200]: 5444138C8: from=<>, size=2992, nrcpt=1 (queue active)
postfix/local[3242]: 50BC438CC: to=<root@alvinadams.jawlawky.com>, relay=local, delay=0.02, delays=0.01/0.01/0/0.01, dsn=2.0.0, status=sent (forwarded as 5444138C8)
postfix/qmgr[27200]: 50BC438CC: removed
postfix/virtual[3238]: 5444138C8: to=<admin@jawlawky.com>, orig_to=<root@alvinadams.jawlawky.com>, relay=virtual, delay=0.01, delays=0.01/0/0/0.01, dsn=5.1.1, status=bounced (unknown user: "admin@jawlawky.com")
postfix/qmgr[27200]: 5444138C8: removed
Okay, so I've got something wrong with my database entries (I think). Oh, by the way, the FQDN is alvinadams.jawlawky.com - if that's important.

Here are my entries:
Code:
mysql> SELECT email, quota FROM users;
+-------+--------+
| email | quota  |
+-------+--------+
| admin | 262144 |
+-------+--------+
1 row in set (0.00 sec)

mysql> SELECT * FROM domains;
+--------------+
| domain       |
+--------------+
| jawlawky.com |
+--------------+
1 row in set (0.00 sec)
What am I missing? What else do I need to check? Does there happen to be a connection error with a component?

Thank you very much.

Last edited by Machtyn; 28th October 2011 at 06:58.
Reply With Quote
Sponsored Links
  #2  
Old 29th October 2011, 11:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Can you post your main.cf?

Is admin listed in /etc/passwd?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th October 2011, 15:04
Machtyn Machtyn is offline
Junior Member
 
Join Date: Oct 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default passwd and main.cf

Code:
[machtyn@alvinadams ~]$ sudo cat /etc/passwd | grep admin
[machtyn@alvinadams ~]$
Find the main.cf attached. I am wanting to use virtual users for this server. (End goal is to have SOGo installed.)
Attached Files
File Type: txt main.cf.txt (28.6 KB, 71 views)
Reply With Quote
  #4  
Old 30th October 2011, 11:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Looks ok. What are the outputs of
Code:
hostname
and
Code:
hostname -f
? What's in /etc/hosts?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 30th October 2011, 14:46
Machtyn Machtyn is offline
Junior Member
 
Join Date: Oct 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
[machtyn@alvinadams ~]$ hostname
alvinadams.jawlawky.com
[machtyn@alvinadams ~]$ hostname -f
alvinadams.jawlawky.com
[machtyn@alvinadams ~]$ cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
[machtyn@alvinadams ~]$
I updated the /etc/hosts file to include the ip address for my computer and its hostname and hostname.domainname.

I decided to try and send again using "mailx admin@jawlawky.com" and this is what I got in the maillog:
Code:
 clamd[27102]: SelfCheck: Database status OK.
postfix/pickup[9282]: CF7D838CB: uid=500 from=<machtyn>
postfix/cleanup[9455]: CF7D838CB: message-id=<20111030132107.CF7D838CB@alvinadams.jawlawky.com>
postfix/qmgr[27200]: CF7D838CB: from=<machtyn@alvinadams.jawlawky.com>, size=446, nrcpt=1 (queue active)
amavis[32378]: (32378-02) NOTICE: reconnecting in response to: err=2006, HY000, DBD::mysql::st execute failed: MySQL server has gone away at (eval 100) line 166, <GEN33> line 4.
postfix/smtpd[9466]: connect from unknown[127.0.0.1]
postfix/smtpd[9466]: 9E08438C8: client=unknown[127.0.0.1]
postfix/cleanup[9455]: 9E08438C8: message-id=<20111030132107.CF7D838CB@alvinadams.jawlawky.com>
postfix/qmgr[27200]: 9E08438C8: from=<machtyn@alvinadams.jawlawky.com>, size=894, nrcpt=1 (queue active)
postfix/smtpd[9466]: disconnect from unknown[127.0.0.1]
amavis[32378]: (32378-02) Passed CLEAN, <machtyn@alvinadams.jawlawky.com> -> <admin@jawlawky.com>, Message-ID: <20111030132107.CF7D838CB@alvinadams.jawlawky.com>, mail_id: KSGJDun9pOrX, Hits: 0.799, size: 446, queued_as: 9E08438C8, 5802 ms
postfix/smtp[9460]: CF7D838CB: to=<admin@jawlawky.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=5.8, delays=0.03/0/0/5.8, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=32378-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 9E08438C8)
postfix/qmgr[27200]: CF7D838CB: removed
postfix/virtual[9473]: 9E08438C8: to=<admin@jawlawky.com>, relay=virtual, delay=0.05, delays=0.02/0.02/0/0.01, dsn=5.1.1, status=bounced (unknown user: "admin@jawlawky.com")
postfix/cleanup[9455]: A912F38CC: message-id=<20111030132113.A912F38CC@alvinadams.jawlawky.com>
postfix/qmgr[27200]: A912F38CC: from=<>, size=2845, nrcpt=1 (queue active)
postfix/bounce[9475]: 9E08438C8: sender non-delivery notification: A912F38CC
postfix/qmgr[27200]: 9E08438C8: removed
postfix/local[9477]: A912F38CC: to=<machtyn@alvinadams.jawlawky.com>, relay=local, delay=0.02, delays=0.01/0.01/0/0.01, dsn=2.0.0, status=sent (delivered to mailbox)
postfix/qmgr[27200]: A912F38CC: removed
[machtyn@alvinadams ~]$ sudo ls /home/vmail/
You have new mail in /var/spool/mail/machtyn
What I found curious is that the system notified me I got mail. That hadn't happened before. But then, I was running in sudu -i mode previously when I did this.

Finally, I did find this thread: http://www.howtoforge.com/forums/showthread.php?t=32663 that has a similar error as the one I've listed above. I'll try using its suggestions and get back here. Namely, putting mysql to listening on all ifaces and modifying the master.cf file for the maildrop option.

If there is something else, feel free to let me know. Thanks!

Last edited by Machtyn; 30th October 2011 at 14:52.
Reply With Quote
  #6  
Old 30th October 2011, 14:59
Machtyn Machtyn is offline
Junior Member
 
Join Date: Oct 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

also, for what it's worth, here is my master.cf file before i try to edit using those suggestions.
Attached Files
File Type: txt master.cf.txt (5.8 KB, 74 views)
Reply With Quote
Reply

Bookmarks

Tags
centos 6, courier, postfix - mail bounce

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
Cron issue in Debian 6 Nolan Installation/Configuration 6 18th April 2011 16:36
Postfix SMTP Auth to Dovecot Not Working -- HELP! Scratchpad Server Operation 6 12th April 2011 13:29
ftp authentication fails fooboo Installation/Configuration 34 26th March 2010 14:04
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47


All times are GMT +2. The time now is 12:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.