#1  
Old 16th September 2011, 20:41
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 426
Thanks: 33
Thanked 55 Times in 38 Posts
Send a message via Skype™ to SamTzu
Unhappy Email Routing

I built a mail-relay server behind a fire-wall and cant get it to relay mail back to internet.
It bounces the email immediately if the receiving external server is down.

Quote:
Sep 16 21:23:16 list-fi postfix/qmgr[796]: 67B1D52AA92: from=<sami@sender.com>, size=1993, nrcpt=1 (queue active)
Sep 16 21:23:16 list-fi postfix/smtpd[817]: disconnect from unknown[10.10.11.1]
Sep 16 21:23:17 list-fi postfix/smtpd[827]: connect from localhost.localdomain[127.0.0.1]
Sep 16 21:23:17 list-fi postfix/smtpd[827]: C1D5F52AA9F: client=localhost.localdomain[127.0.0.1]
Sep 16 21:23:17 list-fi postfix/cleanup[823]: C1D5F52AA9F: message-id=<ffe99b92-9de0-4f36-907b-45b9b26989f1@server17>
Sep 16 21:23:17 list-fi postfix/qmgr[796]: C1D5F52AA9F: from=<sami@sender.com>, size=2504, nrcpt=1 (queue active)
Sep 16 21:23:17 list-fi postfix/smtpd[827]: disconnect from localhost.localdomain[127.0.0.1]
Sep 16 21:23:17 list-fi amavis[32093]: (32093-03) Passed CLEAN, LOCAL [10.10.11.1] [79.133.108.180] <sami@sender.com> -> <info@receiver.com>, Message-ID: <ffe99b92-9de0-4f36-907b-45b9b26989f1@server17>, mail_id: i9u5Eq4uTaWF, Hits: 0.645, size: 1992, queued_as: C1D5F52AA9F, 1334 ms
Sep 16 21:23:17 list-fi postfix/smtp[824]: 67B1D52AA92: to=<info@receiver.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.4, delays=0.1/0.01/0/1.3, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=32093-03, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as C1D5F52AA9F)
Sep 16 21:23:17 list-fi postfix/qmgr[796]: 67B1D52AA92: removed
Sep 16 21:23:17 list-fi postfix/smtp[829]: connect to mail.receiver.com[79.133.125.179]:25: Connection refused
Sep 16 21:23:18 list-fi postfix/smtp[829]: C1D5F52AA9F: to=<info@receiver.com>, relay=none, delay=0.18, delays=0.05/0.01/0.11/0, dsn=4.4.1, status=deferred (connect to mail.reciver.com[79.133.125.179]:25: Connection refused)
Sep 16 21:23:18 list-fi postfix/qmgr[796]: C1D5F52AA9F: from=<sami@sender.com>, status=expired, returned to sender
I'm pretty sure these settings are correct.

Email Routing
- Domain = receiver.com
- Destination = mail.receiver.com
Email relay recipient
- info@receiver.com

What am I missing?
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent

Reply With Quote
Sponsored Links
  #2  
Old 17th September 2011, 11:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please check if your server is blacklisted: http://mxtoolbox.com/blacklists.aspx
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 17th September 2011, 13:12
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 426
Thanks: 33
Thanked 55 Times in 38 Posts
Send a message via Skype™ to SamTzu
Default

Nope, neither sender, relay or receiving are not blacklisted.
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent


Last edited by SamTzu; 17th September 2011 at 13:23.
Reply With Quote
  #4  
Old 18th September 2011, 10:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Do you have this problem for all recipients, or just for certain ones (same domain?)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 22nd September 2011, 18:09
OnePercentile OnePercentile is offline
Junior Member
 
Join Date: May 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb ISPConfig 3.0.3.3 Alias Email Domain Not rejecting bad users

I'm sorry if this is not in the right category:

In ISPConfig 3.0.3.3, Postfix is mishandling Alias Email Domain messages when user portion of email address is misspelled.

Example.

Alias Email Domain: A-domain -> B-domain

User: userA (mailbox in B-domain).

WORKING:
Send a message to userA@B-domain (gets to userA@B-domain)
Send a message to userA@A-domain (gets to userA@B-domain)
Send a message to userB@B-domain (gets rejected)

NOT WORKING:
Send a message to userB@A-domain (creates userB in the B-domain folder, but should be rejected because userB doesn't exist @B-domain. Over time I have tons of Maildir folders with mistyped users@alias-domains that have to be cleaned up..

Will continue to find possible mail drop issues that might be breaking in the mail user verify through alias domains..

Thank you

Last edited by OnePercentile; 22nd September 2011 at 18:10. Reason: Not sure if this is in the right forum category..
Reply With Quote
  #6  
Old 22nd September 2011, 18:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,177
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Thats a known problem with some imap daemons (please see bugtracker) and has been fixed already in svn.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
email, routing

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple Email Routing for the same domain alzuin Installation/Configuration 1 5th November 2010 14:37
Routing email rjsetford Server Operation 2 28th October 2010 15:17
Email Routing: Unsecure. dar_ek Developers' Forum 3 12th October 2010 20:00
Advanced Email Routing Nikola Installation/Configuration 10 23rd February 2010 09:12
hotmail rejects outgoing email nzimas Server Operation 3 1st May 2009 03:39


All times are GMT +2. The time now is 22:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.