#1  
Old 7th July 2006, 06:38
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 12 Times in 10 Posts
Default DNS not being created

Can someone tell me at what point does the master dns domain files get created?

I'm using FC4 with ispc 2.2.3 and created a reseller and then a client. Now created a test domain of blah.com to the clients and clicked the Create DNS and MX yet after the save it doesn't appear to create the DNS records.

I went into the properties of the Site and clicked on the co-domain and selected it. I noticed another set of "Create DNS/MX" which I ticked and saved that too.
Still no DNS created.

where else can it be to create master dns records?
Reply With Quote
Sponsored Links
  #2  
Old 7th July 2006, 10:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,266 Times in 4,129 Posts
Default

Is the DNS file written when you create it in the DNS manager?
Does other changes like email accounts or websites get written?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 7th July 2006, 11:34
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 12 Times in 10 Posts
Default

Looking at this (below), I assume the site works fine and if I put it in my own hosts file an entry for www.blah.com to point to the server. I can browse the "welcome" new site page.

ls -l /var/www/
total 24
drwxr-xr-x 2 root root 4096 Jan 17 22:37 cgi-bin
drwxr-xr-x 3 root root 4096 Jul 7 09:51 error
drwxr-xr-x 2 root root 4096 Jan 17 22:37 html
drwxr-xr-x 3 root root 4096 Jul 7 09:52 icons
drwxr-xr-x 2 root root 4096 Jul 7 10:28 sharedip
drwxr-xr-x 8 apache web1 4096 Jul 7 13:44 web1
lrwxrwxrwx 1 root root 13 Jul 7 13:44 www.blah.com -> /var/www/web1

Wow, I created an email and 2 minutes later the /etc/passwd account FINALLY was created..lol.. i saw this on my test machine at home but didn't expect it on a P4 3Ghz server.
Reply With Quote
  #4  
Old 8th July 2006, 11:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Do you see the zone file for the domain in /var/named/chroot/var/named/?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th July 2006, 14:22
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 12 Times in 10 Posts
Default

Hmm checking this out.

damn it. it's now working and there IS a /var/named/chroot folder where I was sure there wasn't one. I can see the chrooted folder now.. Argh!

sorry for the trouble.

Last edited by djtremors; 8th July 2006 at 14:39.
Reply With Quote
  #6  
Old 8th July 2006, 14:52
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 12 Times in 10 Posts
Default

FAR OUT!!

I really got to stop working on multiple servers.

The problem wasn't my home environment it was the machine at work. Grr (time for bed really).

There is no chroot folder. I don't think FC4 out of the box is setup in an chrooted environment.

[root@warlock install_ispconfig]# ls -l /var/named/
total 72
drwxrwx--- 2 named named 4096 May 18 2005 data
-rw-r--r-- 1 named named 198 Aug 26 2004 localdomain.zone
-rw-r--r-- 1 named named 195 Aug 26 2004 localhost.zone
-rw-r--r-- 1 named named 415 Aug 26 2004 named.broadcast
-rw-r--r-- 1 named named 2518 Aug 26 2004 named.ca
-rw-r--r-- 1 named named 432 Aug 26 2004 named.ip6.local
-rw-r--r-- 1 named named 433 Aug 26 2004 named.local
-rw-r--r-- 1 named named 416 Aug 26 2004 named.zero
drwxrwx--- 2 named named 4096 May 18 2005 slaves

the data/ and slaves/ folder are empty.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
maildir not created t_ras Installation/Configuration 3 1st July 2006 12:52
Maildir folders not created initially by Kmail rfburn Server Operation 2 16th June 2006 17:30
error accessing created site danny Installation/Configuration 1 31st December 2005 17:12
problem for accessing created sites ericli Server Operation 1 26th November 2005 09:47
DNS - call script to created named.conf entries on secondaries cstone Installation/Configuration 4 15th September 2005 01:16


All times are GMT +2. The time now is 16:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.