#1  
Old 27th August 2011, 23:46
xrat xrat is offline
Member
 
Join Date: Nov 2006
Location: Vienna, Austria
Posts: 56
Thanks: 68
Thanked 15 Times in 12 Posts
Exclamation $webname/.htpasswd not updated

I found that my users' .htpasswd files are not updated, e.g. after users change their passwords. This behavior was introduced with ISPconfig 2.2.37. Apparently, someone complained that .htpasswd files get overwritten every night. Indeed this happened due to a bug but the logic of its fix escapes me.

I understand that users might want to use .htpasswd to manually add users, but if I am not mistaken, $webname/.htpasswd was never intended to be used by users (as, unfortunately, it has been suggested in this forum even by ISPconfig maintainers). These .htpasswd files should reflect the current passwd/shadow files. I might even want to suggest to change the permissions from 664 to 644, i.e. do not allow the group to modify the file.

The current situation, that these files are not updated, clearly is unsatisfactory, to say the least. For a quick and dirty workaround to have the files updated, remove the ! from line 122 in /root/ispconfig/scripts/shell/webalizer.php and line 118 in /root/ispconfig/scripts/shell/awstats.php, i.e. (it's the same line in both files)
Code:
if(!@is_file($web_home."/".$webname."/.htpasswd")) {

Last edited by xrat; 28th August 2011 at 00:05. Reason: mentioned awstats.php, too
Reply With Quote
Sponsored Links
  #2  
Old 27th July 2012, 09:00
jbravo jbravo is offline
Member
 
Join Date: Nov 2007
Location: Poland
Posts: 81
Thanks: 12
Thanked 3 Times in 2 Posts
Default

Seems to me that this resolution does not work (2.2.38 in my case).
Does 2.2.40 resolve this problem?
__________________
--
GreetZ .:JbRaVo:.
ISPConfig 3.0.5.2 @ mail&web @ RHEL6.4,
ISPConfig 2.2.29@mailsrv & 2.2.38@websrv @ SLES10SP4
Reply With Quote
  #3  
Old 27th July 2012, 13:39
xrat xrat is offline
Member
 
Join Date: Nov 2006
Location: Vienna, Austria
Posts: 56
Thanks: 68
Thanked 15 Times in 12 Posts
Default

AFAIK there have been no changes on this side. I am running 2.2.40 and I have removed the ! as mentioned above. htpasswd files are updated.
Reply With Quote
  #4  
Old 27th July 2012, 14:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

ISPConfig 2 is end of life for for quite some time, so there will be no updates.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clamd.d not found setting up the Perfect Server (centos 6) deainfo.elisa Server Operation 10 9th December 2013 22:53
yum issues el-sid Installation/Configuration 4 10th August 2011 11:01
Mac4Lin ver.0.2 - Mac OS X Leopard Transformation pack infra_red_dude Desktop Operation 77 12th September 2010 22:21
Postfix problem vaio1 General 4 17th October 2007 10:27
Transaction error Perfect FC6 setup ACDII HOWTO-Related Questions 1 6th July 2007 14:56


All times are GMT +2. The time now is 13:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.