Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th August 2011, 22:51
wolfric wolfric is offline
Junior Member
 
Join Date: Aug 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default suphp from fastcgi causes 500 error

<code>
[Fri Aug 19 21:45:36 2011] [warn] [client 192.168.1.37] mod_fcgid: stderr: PHP Notice: Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 497, referer: http://192.168.1.35:8080/index.php
[Fri Aug 19 21:45:36 2011] [warn] [client 192.168.1.37] mod_fcgid: stderr: PHP Notice: Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 497, referer: http://192.168.1.35:8080/index.php
[Fri Aug 19 21:45:36 2011] [warn] [client 192.168.1.37] mod_fcgid: stderr: PHP Notice: Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 498, referer: http://192.168.1.35:8080/index.php
[Fri Aug 19 21:45:36 2011] [warn] [client 192.168.1.37] mod_fcgid: stderr: PHP Notice: Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 498, referer: http://192.168.1.35:8080/index.php
[Fri Aug 19 21:45:36 2011] [warn] [client 192.168.1.37] mod_fcgid: stderr: PHP Notice: Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 499, referer: http://192.168.1.35:8080/index.php
[Fri Aug 19 21:45:36 2011] [warn] [client 192.168.1.37] mod_fcgid: stderr: PHP Notice: Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 499, referer: http://192.168.1.35:8080/index.php
[Fri Aug 19 21:45:36 2011] [warn] [client 192.168.1.37] mod_fcgid: stderr: PHP Notice: Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 500, referer: http://192.168.1.35:8080/index.php
[Fri Aug 19 21:45:36 2011] [warn] [client 192.168.1.37] mod_fcgid: stderr: PHP Notice: Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 500, referer: http://192.168.1.35:8080/index.php
[Fri Aug 19 21:45:36 2011] [warn] [client 192.168.1.37] mod_fcgid: stderr: PHP Notice: Undefined index: on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140, referer: http://192.168.1.35:8080/index.php
[Fri Aug 19 21:45:36 2011] [warn] [client 192.168.1.37] mod_fcgid: stderr: PHP Notice: Undefined index: sitesn_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140, referer: http://192.168.1.35:8080/index.php
[Fri Aug 19 21:45:36 2011] [warn] [client 192.168.1.37] mod_fcgid: stderr: PHP Notice: Undefined index: sites:web_domainn_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140, referer: http://192.168.1.35:8080/index.php
[Fri Aug 19 21:45:36 2011] [warn] [client 192.168.1.37] mod_fcgid: stderr: PHP Notice: Undefined index: return_to_url in /usr/local/ispconfig/interface/lib/classes/tform_actions.inc.php on line 142, referer: http://192.168.1.35:8080/index.php
[Fri Aug 19 21:46:02 2011] [notice] caught SIGTERM, shutting down
[Fri Aug 19 21:46:03 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Fri Aug 19 21:46:03 2011] [notice] Digest: generating secret for digest authentication ...
[Fri Aug 19 21:46:03 2011] [notice] Digest: done
[Fri Aug 19 21:46:03 2011] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.16 OpenSSL/0.9.8o configured -- resuming normal operations


</code>

when i go to sites as admin user, go to fastcars.com (testing website i created), and change the php version from fastcgi to suphp, i get 500 errors and this in /var/log/apache/error.log. I've installed suphp and disabled php5 via a2dismod php5 and restarted apache.
Reply With Quote
Sponsored Links
  #2  
Old 20th August 2011, 15:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Are your PHP scripts owned by the correct suExec user and group?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th August 2011, 15:59
wolfric wolfric is offline
Junior Member
 
Join Date: Aug 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think so... web1:client1 right?

It's the same as it is when the default files are created.


-rwxr-xr-- 1 web1 client1 1865 Aug 19 21:54 index.php

note, when it's index.php it's a 500 error (even if no php resides in the file) but if it's index.html, it works fine.

It sounds like it can't contact suphp or something.
Reply With Quote
  #4  
Old 21st August 2011, 12:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Can you try
Code:
chmod 755 index.php
?

Did you check the web site's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 21st August 2011, 20:23
wolfric wolfric is offline
Junior Member
 
Join Date: Aug 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Tried 755 and 777 and even with 777 it still comes up with that error.
I've checked in /var/log/apache2/(access.log,error.log,suexec.log and other_vhosts_access.log)

The only thing that shows when i try access the page that's throwing the 500 error, is an access.log entry. I think the error in the first post i made was only when i attempted to change the php option in ispconfig.
Reply With Quote
  #6  
Old 21st August 2011, 20:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Can you post your /etc/suphp.conf?

Are permissions of all directories up to index.php correct?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help setting up domainpop with postfix kameelperdza Installation/Configuration 6 15th June 2009 07:49
cyrus-sasl won't install on my ubuntu9.04 kameelperdza Installation/Configuration 1 13th June 2009 10:28
installing Perl module GD - ran into problems Ovidiu Installation/Configuration 6 19th September 2006 09:32
Apache trouble wont restart Domain coroption main3 Installation/Configuration 1 16th September 2006 12:09
Fresh Install on Debian cksrealm Installation/Configuration 12 22nd February 2006 16:14


All times are GMT +2. The time now is 00:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.