#1  
Old 3rd August 2011, 16:55
Cracklefish Cracklefish is offline
Member
 
Join Date: Mar 2009
Posts: 95
Thanks: 8
Thanked 3 Times in 3 Posts
Default Saslauthd fails to start

Hi,

set-up is Perfect Server, ISPC3, OpenSuSE 11.1

All was working fine for a long time then I got a SMTP server log in failed message. On investigation I discovered that saslauthd was not running and would not start on boot or with etc/init.d/saslauthd start (error 7)

I have tried uninstalling and reinstalling saslauthd using yast to no avail.

All services, except saslauthd, start at boot up.

Apache, pop & webmail seem ok
Reply With Quote
Sponsored Links
  #2  
Old 3rd August 2011, 16:58
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 99 Times in 95 Posts
Default

try:

Code:
strace /etc/init.d/saslauthd start
Reply With Quote
  #3  
Old 3rd August 2011, 17:20
Cracklefish Cracklefish is offline
Member
 
Join Date: Mar 2009
Posts: 95
Thanks: 8
Thanked 3 Times in 3 Posts
Default

Hi Mark,

Thanks for the super prompt reply but I'm going to need some assistance. The output is many screens-full. More than I can read using Putty. I have local access to the server but I don't know how to capture it into a txt file or get that out of the machine.

regards
Rick
Reply With Quote
  #4  
Old 3rd August 2011, 17:24
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 99 Times in 95 Posts
Default

run:

Code:
strace -o saslauthd.txt /etc/init.d/saslauthd start
attach the file to your next reply and i'll have a look at it.
Reply With Quote
  #5  
Old 3rd August 2011, 18:07
Cracklefish Cracklefish is offline
Member
 
Join Date: Mar 2009
Posts: 95
Thanks: 8
Thanked 3 Times in 3 Posts
Default

Hi Mark,

I have attached a file.

Thanks for the help.

Rick
Attached Files
File Type: txt saslauthd.txt (29.3 KB, 94 views)
Reply With Quote
  #6  
Old 3rd August 2011, 21:10
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 99 Times in 95 Posts
Default

Hmm, can't make anything of that, just that it failes to start (i forgot to ask to run it with follow childprocs, but let's forget that)

You said you reinstalled saslauthd, didn't that overwrite some of your configuration settings?

Also, can you see anything related to the saslauthd process in your log files when you try to start it? If there's not enough info, you can set the debug level up, so you get more information in your log files. I'm not really a suse user, so i'm not sure where those sasl config files are but i guess somewhere in /etc/courier/
Reply With Quote
Reply

Bookmarks

Tags
saslauthd

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
monitrc configuration for Debian ISPConfig 3 server Hans Tips/Tricks/Mods 2 27th March 2011 23:22
Monitoring server Ubuntu wiss Installation/Configuration 7 20th November 2010 12:56
geronimo-jetty7-javaee5-2.2 fails to deploy war application vtapas Server Operation 0 3rd May 2010 13:35
Monit & Munin SamTzu HOWTO-Related Questions 1 4th May 2008 18:03
"Too many open files in system" problems Berry Installation/Configuration 3 10th November 2007 21:58


All times are GMT +2. The time now is 16:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.