#1  
Old 19th April 2011, 10:03
luigi luigi is offline
Junior Member
 
Join Date: Apr 2011
Location: France, Annecy
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
Default The Perfect SpamSnake 10.10

Hi everyone
I need your help for some problems with baruwa
I do not know where it comes from
I put some screen, and I hope you understand the problem

First I have No records returned in the section messages or lists
http://img813.imageshack.us/i/baruwa...he50mostr.jpg/

And when I click on System status I have this. The status is in red and i haven't MTA processe
http://img853.imageshack.us/i/prtscrcapturen.jpg/

I put a other screen, this is my mail.log


Uploaded with ImageShack.us

If you want a example of another file said me

An other question in the tutorial :
vi /usr/share/pyshared/baruwa/settings.py
Change the Quarantine hosturl to your liking:
QUARANTINE_REPORT_HOSTURL = 'http://baruwa-alpha.local'

I need to change http://baruwa-alpha.local by what? My server @ip ?

Thx for your help
Best Regards !

Last edited by luigi; 19th April 2011 at 10:09.
Reply With Quote
Sponsored Links
  #2  
Old 19th April 2011, 14:33
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Hey,

Make sure your .pm files in /opt/MailScanner/lib/MailScanner/CustomFunctions has the proper user/password/database information.

Make sure you have the following set in /opt/MailScanner/etc/MailScanner.conf

HTML Code:
MTA = postfix
Always Looked Up Last = &BaruwaSQL
Is Definitely Not Spam = &BaruwaWhitelist
Is Definitely Spam = &BaruwaBlacklist
Required SpamAssassin Score = &BaruwaLowScore
High SpamAssassin Score = &BaruwaHighScore
The URL should be the dns name of your spamsnake.
__________________
Home of the SpamSnake
Reply With Quote
  #3  
Old 19th April 2011, 15:08
luigi luigi is offline
Junior Member
 
Join Date: Apr 2011
Location: France, Annecy
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi Rocky !
Thank you for reply so quickly.

in /opt/MailScanner/etc/MailScanner.conf
some example of my configuration of MailScanner.conf
HTML Code:
# **** RULE: It must not contain any spaces! ****
%org-name% =castellanus-com

%org-long-name% = filter.castellanu.com
%web-site% = www.castellanus.com

Run As User = postfix
Run As Group =  www-data

MTA = postfix

Incoming Work User =
Incoming Work Group = clamav

Quarantine User = root
Quarantine Group = www-data

Always Looked Up Last = &BaruwaSQL
Is Definitely Not Spam = &BaruwaWhitelist
Is Definitely Spam = &BaruwaBlacklist
Required SpamAssassin Score = &BaruwaLowScore.
High SpamAssassin Score = &BaruwaHighScore
In my .pm files in /opt/MailScanner/lib/MailScanner/CustomFunctions I have this :
HTML Code:
my ($db_name) = 'baruwa';
my ($db_host) = 'localhost';
my ($db_user) = 'baruwa';
my ($db_pass) = 'password';
And when I trying to connect with the user baruwa on the mysql , all it's ok

So the URL should be http://filter.castellanus.com ?
Because for the baruwa's graphique interface, I have a acess only with @ip (http://192.168.131.251) not by http://filter.castellanus.com

Thxs
Reply With Quote
  #4  
Old 19th April 2011, 15:23
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Hey,

Looks good so far.

Just one prob:
%org-name% =castellanus-com <--incorrect
%org-name% = castellanus <--correct and can be castellanus if you like.

You can use the ip for the url.
__________________
Home of the SpamSnake
Reply With Quote
The Following User Says Thank You to Rocky For This Useful Post:
luigi (19th April 2011)
  #5  
Old 19th April 2011, 17:49
luigi luigi is offline
Junior Member
 
Join Date: Apr 2011
Location: France, Annecy
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hey,

I made the changes but it didn't work
I restart MaiScanner, even reboot my server but I still have the status red

If you have an idea where the problem might be?

Why baruwa don't find the MTA ?

in the file /etc/postfix/main.cf I have this :
HTML Code:
myhostname = filter.castellanus.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = castellanus.com
mydestination =
relayhost =
mynetworks = 127.0.0.0/8, 192.168.131.0/24

Last edited by luigi; 19th April 2011 at 17:57.
Reply With Quote
  #6  
Old 19th April 2011, 18:26
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

I'm not sure why it's not giving a status. Are you using an FQDN for the setup?

Is MailScanner delivering mails?
__________________
Home of the SpamSnake
Reply With Quote
Reply

Bookmarks

Tags
baruwa, the perfect spamsnake, ubuntu 10.10 spamsnake

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MailWatch Error: no rows retrieved from database sergio.arnaldo Server Operation 25 21st March 2011 06:05
The Perfect SpamSnake - Ubuntu Jeos 10.10 - Managing transport relay_domains etc mintydave HOWTO-Related Questions 19 20th January 2011 03:15
More Perfect SpamSnake 10.10 probs! colskinet HOWTO-Related Questions 7 19th December 2010 19:51
MailScanner trouble with DBD-MYSQL sergio.arnaldo Server Operation 11 26th August 2009 18:08
SpamSnake SpamAssassin not working? getrav HOWTO-Related Questions 5 23rd June 2008 23:02


All times are GMT +2. The time now is 12:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.