Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th March 2011, 22:59
007007 007007 is offline
Senior Member
 
Join Date: Jul 2010
Posts: 139
Thanks: 5
Thanked 0 Times in 0 Posts
Default error.log is full of notices mod_fcgid

Hi,

the error.log file located in /var/log/apache2 is filled with notices fcgid mod:

Code:
[Wed Mar 30 10:54:45 2011] [notice] mod_fcgid: call /var/www/site.com/web/forum/index.php with wrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter
[Wed Mar 30 10:56:33 2011] [notice] mod_fcgid: process 12783 going graceful shutdown, sending SIGTERM
[Wed Mar 30 10:56:39 2011] [notice] mod_fcgid: process /var/site.com/web/forum/index.php(12783) exit(lifetime expired), terminated by calling exit(), return code: 0
[Wed Mar 30 11:37:29 2011] [notice] mod_fcgid: process 25182 going graceful shutdown, sending SIGTERM
[Wed Mar 30 11:37:35 2011] [notice] mod_fcgid: process /var/www/site.com/web/forum/index.php(25182) exit(lifetime expired), terminated by calling exit(), return code: 0
[Wed Mar 30 11:41:35 2011] [notice] mod_fcgid: process 25466 going graceful shutdown, sending SIGTERM
thousand of lines!!

it is possible not to register these errors?

I turned off archiving of errors in the 3 php.ini but nothing changed, probably there is a specific configuration file for the module fcgid!

in apache2.conf, I have already made​​: LogLevel warn
(i have debian)

thank you for your help

EDIT: in php.ini i have

Code:
; Disable logging through FastCGI connection. PHP's default behavior is to enable
; this feature.
;fastcgi.logging = 0
I must replace it with this configuration?

Code:
; Disable logging through FastCGI connection. PHP's default behavior is to enable
; this feature.
fastcgi.logging = 0
EDIT2: nothing changed, always dozens notices in error.log

Code:
[Wed Mar 30 22:44:44 2011] [notice] mod_fcgid: call /var/www/site.com/web/forum/index.php with wrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter
[Wed Mar 30 22:44:44 2011] [notice] mod_fcgid: call /var/www/site.com/web/forum/index.php with wrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter
[Wed Mar 30 22:44:44 2011] [notice] mod_fcgid: call /var/www/site.com/web/forum/index.php with wrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter
[Wed Mar 30 22:44:44 2011] [notice] mod_fcgid: call /var/www/site.com/web/forum/index.php with wrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter
[Wed Mar 30 22:44:44 2011] [notice] mod_fcgid: call /var/www/site.com/web/forum/index.php with wrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter
[Wed Mar 30 22:44:44 2011] [notice] mod_fcgid: call /var/www/site.com/web/forum/index.php with wrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter
[Wed Mar 30 22:44:44 2011] [notice] mod_fcgid: call /var/www/site.com/web/forum/index.php with wrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter

Last edited by 007007; 30th March 2011 at 23:51.
Reply With Quote
Sponsored Links
  #2  
Old 4th April 2011, 21:30
007007 007007 is offline
Senior Member
 
Join Date: Jul 2010
Posts: 139
Thanks: 5
Thanked 0 Times in 0 Posts
Default

any solution please ?
Reply With Quote
  #3  
Old 5th April 2011, 16:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Take a look at the LogLevel directive: http://httpd.apache.org/docs/current....html#loglevel
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 10th April 2011, 13:07
007007 007007 is offline
Senior Member
 
Join Date: Jul 2010
Posts: 139
Thanks: 5
Thanked 0 Times in 0 Posts
Default

thx

i have LogLevel crit

but notices still exists!!!

any idea ?
Reply With Quote
  #5  
Old 11th April 2011, 10:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Did you restart Apache?

IS there maybe another LogLevel directive somewhere in your configuration (also check your .htaccess files)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 11th April 2011, 22:37
007007 007007 is offline
Senior Member
 
Join Date: Jul 2010
Posts: 139
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Did you restart Apache?

IS there maybe another LogLevel directive somewhere in your configuration (also check your .htaccess files)?
yes I did

Code:
/etc/init.d/apache2 restart
I really do not know, I use ispconfig vanilla (default)

I also noticed several thousands of lines like this:

Code:
Software caused connection abort: mod_fcgid: ap_pass_brigade failed in handle_request function
any possibility to completely disable fcgi logs please?

my server is super loaded!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mod_fcgid saves notices in error.log !! 007007 Installation/Configuration 8 4th August 2011 01:46
error.log files are empty autogun General 2 13th December 2010 17:05
Apache2 error.log problem Quissi Server Operation 2 18th September 2009 16:04
watchdog_task: NIC Link is Up 10 Mbps Full Duplex Chad Server Operation 0 8th October 2008 04:04
Update caused / to become full... Joffar Installation/Configuration 2 3rd March 2006 12:56


All times are GMT +2. The time now is 04:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.