#1  
Old 28th January 2011, 19:34
Breezer Breezer is offline
Junior Member
 
Join Date: Jan 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default Ftp

Hello, i am new in linux world, but i have followed the The Perfect Server - CentOS 5.5 x86_64 [ISPConfig 3], it seemed to me that everything installed fine, i followed the suggestions that were made even if the install wasn't working from the comments bellow... anyways I have an issue the the pureftpd and ispconfig 3.... using FileZilla, i am able to log in as root onto the server with ftp.... the minute i care a user on the ispconfig 3 for ftp... it does not work... it keeps saying authentication failed....

my though is that the directorys do not match for the username and passwords with pureftp/myphpadmin/ispconfig, am I on the right track? or way off please help

Thank you
Reply With Quote
Sponsored Links
  #2  
Old 28th January 2011, 19:47
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 38
Thanked 89 Times in 68 Posts
Default

root login is not allowed. Check /etc/ftpusers
Reply With Quote
  #3  
Old 28th January 2011, 19:55
Breezer Breezer is offline
Junior Member
 
Join Date: Jan 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry that directory does not exist...

the thing is i have tried logging in as root and it did work...

I can not create users in ISPConfig 3, they do not authenticate...

Last edited by Breezer; 28th January 2011 at 19:58.
Reply With Quote
  #4  
Old 29th January 2011, 16:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Did you try both active and passive transfers in your FTP client?
Is SELinux disabled?
Is this a physical server or a virtual machine?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 1st February 2011, 13:02
Breezer Breezer is offline
Junior Member
 
Join Date: Jan 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you try both active and passive transfers in your FTP client?

--> yes i have tried both (its give me authentication error)

Is SELinux disabled?

--> yes it is disabled

Is this a physical server or a virtual machine?

It is a physical server...


to me it seems like the ISPconfig 3 and the pureftd are looking a different directory for username and password....

I am not sure how to check if the are looking at the same files... Thanks
Reply With Quote
  #6  
Old 2nd February 2011, 14:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Do you have any error messages that you can post, e.g. from your FTP client and your server logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 9th February 2011, 18:53
lightning200mph lightning200mph is offline
Junior Member
 
Join Date: Feb 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This may have already been said but I didn't read all the post completely.
Your user name you are log in in with might be the problem, I also had this problem until I figured it out. So when you create a client lets say "Website1" then next step is the FTP-user "ftp1" under websites. So the log in name should be "website1ftp1" for the log in to work.

You will see [clientname]"username" on the ftp user name screen. So I put them together and it worked for me

Zach
Reply With Quote
  #8  
Old 9th February 2011, 19:07
Breezer Breezer is offline
Junior Member
 
Join Date: Jan 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No that is not the issue... I have already tried that and made sure that i am using the full name ie website1ftp1, and the right password... also tried the different transfer settings : default / active / passive and none of them work.
I get the same response all the time

Response: fzSftp started
Command: open "website1ftp1@555.555.555.555" 22
Command: Pass: ********
Error: Authentication failed.
Error: Critical error
Error: Could not connect to server

thats why it makes me think that the pureftpd is not looking at the same folder that the the ispconfig creates the usernames and passwords for ftp.
Reply With Quote
  #9  
Old 9th February 2011, 19:46
lightning200mph lightning200mph is offline
Junior Member
 
Join Date: Feb 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

did you try port 21?
Reply With Quote
  #10  
Old 9th February 2011, 19:52
Breezer Breezer is offline
Junior Member
 
Join Date: Jan 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just tried it and this is what im getting

Status: Connecting to 555.555.555.555:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 15:44. Server port: 21.
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER website1ftp1
Response: 331 User website1ftp1 OK. Password required
Command: PASS ********
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server

Last edited by Breezer; 9th February 2011 at 21:48.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow download from own FTP (vsftpd + proftpd) Overcrook Installation/Configuration 0 12th January 2010 21:41
Troubleshooting FTP bswinnerton Installation/Configuration 4 10th October 2008 19:34
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 21:12
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 19:38
Website users? ctroyp General 25 6th January 2006 18:02


All times are GMT +2. The time now is 16:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.