Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th January 2011, 01:09
MrCompTech MrCompTech is offline
Member
 
Join Date: Jul 2010
Posts: 92
Thanks: 1
Thanked 20 Times in 9 Posts
Default open_basedir restriction in effect. File() is not within the allowed path(s)

open_basedir restriction in effect. File() is not within the allowed path(s)

Using ISPConfig3, Fedora 13, Wordpress 3.0.4

Have severl Wordpress sites, all have this problem.
Have several Joomla sites with no problems.

Isn't there supposed to be a file listed in the error message in the parenthesis - 'Files()'?

This error causes the log files to grow 20KB to 50KB every time a page on the site is displayed including the website admin pages!

The settings for the website are:

DOMAIN:
CGI - unchecked
SSI - unchecked
SuEXEC - checked
Own Error-Documents - unchecked
Auto-Subdomain - none
SSL - unchecked
PHP - Fast-CGI
Active - Checked

OPTIONS:
Linux User - web34
Linus Group - client1
Allow Override - All
PHP open_base_dir -
/var/www/clients/client1/web34:
/var/www/clients/client1/web34/web:
/var/www/clients/client1/web34/tmp:
/var/www/25freemp3downloads.com:
/var/www/25freemp3downloads.com/web:
/srv/www/25freemp3downloads.com/web:
/usr/share/php5:
/tmp:
/usr/share/phpmyadmin

Apache directives - FcgidMaxRequestLen 5000000

While troublesghooting this issue I found the error.log file for this website to be 22741993435 bytes long! - Ouch!

To establish a baseline I:
disconnected the LAN from the Internet,
logged out of the wp admin
had no open browser windows to this web site

I then open one window to the site http://25freempsdownloads.com

And checked the log file. It grew by 54304 bytes! This is definitly an uh-oh!

In the logs the same basic error messages kept repeating over and over and over!
With only slightly differences that being the file name and the line number -

[Thu Jan 27 14:01:55 2011] [warn] [client 192.168.1.151]
mod_fcgid: stderr: PHP Warning: require():
open_basedir restriction in effect. File() is not within the allowed path(s):
(
/var/www/clients/client1/web34:
/var/www/clients/client1/web34/web:
/var/www/clients/client1/web34/tmp:
/var/www/25freemp3downloads.com:
/var/www/25freemp3downloads.com/web:
/srv/www/25freemp3downloads.com/web:
/usr/share/php5:
/tmp:
/usr/share/phpmyadmin
) in
/var/www/clients/client1/web34/web/wp-settings.php on line 19

On error lines a 'referrer' is listed as
http://25freemp3downloads.com/wp-con.../MenuMatic.css.

I changed the theme to the default Wordpress theme and the same error messages appeared in the log file and it increase by 98KB.

In this last error message it seems like it is saying that file being called on line 19 by the script wp-settings.php is not in the path.
Am I interpreting this error message correctly? It doesn't seem that this could be correct.

In this error message line 19 is -
require( ABSPATH . WPINC . '/load.php' );

Other lines that were referred to in the error messages are -
line 20 require( ABSPATH . WPINC . '/default-constants.php' );
line 21 require( ABSPATH . WPINC . '/version.php' );
line 66 require( ABSPATH . WPINC . '/compat.php' );
line 67 require( ABSPATH . WPINC . '/functions.php' );
line 68 require( ABSPATH . WPINC . '/classes.php' );

The pages come up and they don't seem to be missing anything.

I 'reset' the error.log file by 'echo > error.log'.
Is there any way to put a limit on how large the error log will grow?

To be sure the ownship was correct I ran:
chown -R web34:client1 /var/www/clients/client1/web34/web

Anybody have an idea has to what might be causing this?

Last edited by MrCompTech; 28th January 2011 at 03:39.
Reply With Quote
Sponsored Links
  #2  
Old 28th January 2011, 02:32
MrCompTech MrCompTech is offline
Member
 
Join Date: Jul 2010
Posts: 92
Thanks: 1
Thanked 20 Times in 9 Posts
Default

A little more investigation shows that it seems like every time a require() function is used an error is generated.
Reply With Quote
  #3  
Old 28th January 2011, 03:06
MrCompTech MrCompTech is offline
Member
 
Join Date: Jul 2010
Posts: 92
Thanks: 1
Thanked 20 Times in 9 Posts
Default

I noticed something else...

After resetting the web sites error.log file (echo > error.log) and
then restarting the web server (/etc/init.d/httpd restart)

Then the first time I visit the web page no errors show up in the log.
Starting with the second time the site is visited the log file increase by nearly 30KB every time a page is displayed.

[Thu Jan 27 20:07:16 2011] [warn] [client 192.168.1.151] mod_fcgid: stderr: PHP Warning: require(): open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web34/web:/var/www/clients/client1/web34/tmp:/var/www/25freemp3downloads.com/web:/srv/www/25freemp3downloads.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin) in /var/www/clients/client1/web34/web/wp-settings.php on line 127

This error occurs 58 times every time the main page is visited.
One message every time the require() function is used.

i.e. require( ABSPATH . 'wp-includes' . '/load.php' );

One really goofy thing with this is that no specific file is mentioned! 'File()', there's nothing in the parenthesis.
The site works so there's no problem with that. Admin panel works ok. It's just all these open_basedir errors every time the 'require()' function is used.

Last edited by MrCompTech; 28th January 2011 at 04:10.
Reply With Quote
  #4  
Old 28th January 2011, 03:56
MrCompTech MrCompTech is offline
Member
 
Join Date: Jul 2010
Posts: 92
Thanks: 1
Thanked 20 Times in 9 Posts
Default

So I could see the actual path that was being used I added:
Code:
echo ABSPATH . WPINC . '/load.php';
Just before a line that generates an error.

The open_basedir is :
/var/www/clients/client1/web34/web:
/var/www/clients/client1/web34/tmp:
/var/www/25freemp3downloads.com/web:
/srv/www/25freemp3downloads.com/web:
/usr/share/php5:
/tmp:/usr/share/phpmyadmin

The code that I added displayed the full path to the file at the top of the page :
Code:
/var/www/clients/client1/web34/web/wp-includes/load.php
The file load.php is in the open_basedir.

I can't figure out why I keep getting this open_basedir warning in the log files!

The log file was up to 6GB before I caught it.
There should be something to limit the size of the error.log file of the web site, but I don't know what it is. Anyone know?

It would be better to fix what ever is wrong so the errors don't occur, but if there's no alternative then I need to do something about the size of the error.log file.

Last edited by MrCompTech; 28th January 2011 at 04:02.
Reply With Quote
  #5  
Old 28th January 2011, 09:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Quote:
There should be something to limit the size of the error.log file of the web site, but I don't know what it is. Anyone know?
If you use a current ispconfig 3 version, then the error.log file gets rotated when it exceeds 10 MB.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 28th January 2011, 09:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Please ensure that all files and folders belong to the correct users by running:

chown -R web34:client1 /var/www/clients/client1/web34/web/*
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 28th January 2011, 19:30
MrCompTech MrCompTech is offline
Member
 
Join Date: Jul 2010
Posts: 92
Thanks: 1
Thanked 20 Times in 9 Posts
Default

Quote:
Originally Posted by till View Post
If you use a current ispconfig 3 version, then the error.log file gets rotated when it exceeds 10 MB.
Since the error.log file is not getting rotated I can only assume that I am not on the current version. I looked in the ISPConfig 3 interface for a version number but did not see one. So I'll need to upgrade, maybe this will fix the open_basedir issue as well.

Where is the ISPConfig 3 version number noted?

Last edited by MrCompTech; 28th January 2011 at 19:36.
Reply With Quote
  #8  
Old 2nd February 2011, 02:09
MrCompTech MrCompTech is offline
Member
 
Join Date: Jul 2010
Posts: 92
Thanks: 1
Thanked 20 Times in 9 Posts
Default

I have upgrade both ISPConfig 3 and my server. Now running Fedora Core 14 and still get multiple errors in the error.log file. Only difference is the name of the file and the line number within the file.

This seems to be some issue with open_basedir and thr PHP rquire function.

Code:
[Tue Feb 01 19:06:55 2011] [warn] [client 192.168.1.151] mod_fcgid: stderr: PHP Warning:  require(): open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web34/web:/var/www/clients/client1/web34/tmp:/var/www/25freemp3downloads.com/web:/var/www/25freemp3downloads.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin) in /var/www/clients/client1/web34/web/wp-includes/theme.php on line 1088
Anyone have any ideas?
Reply With Quote
  #9  
Old 25th October 2011, 16:36
ph4r05 ph4r05 is offline
Junior Member
 
Join Date: Oct 2011
Posts: 1
Thanks: 0
Thanked 3 Times in 1 Post
Default Solution

Hi,

I had the same problem after updating to PHP 5.3.8. Because I don't use suPHP, proposed solution was not right for me (I use httpd-itk).

After a 2 hours of debugging ang googling I had found that it was eAccelerator what caused this errors. After disabling eAccelerator PHP module everything was fine.

Because I need some PHP caching I replaced eAccelerator by APC. It works like a charm ;-)

I hope this will help...
Reply With Quote
The Following 3 Users Say Thank You to ph4r05 For This Useful Post:
falko (26th October 2011), gapa (16th November 2011), till (25th October 2011)
  #10  
Old 16th November 2011, 04:05
gapa gapa is offline
Junior Member
 
Join Date: Nov 2011
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I had identical problems, and was able to solve them exactly the same. Here is bug report regarding eAccelerator. https://eaccelerator.net/ticket/104
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 21:17
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 14:21
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 17:26
debian etch courier pop3 issue docean Installation/Configuration 6 20th March 2008 16:38
Chroot SSH + ISPConfig Norman Installation/Configuration 27 26th March 2007 04:40


All times are GMT +2. The time now is 13:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.