Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th January 2011, 19:46
carlosinfl carlosinfl is offline
Member
 
Join Date: Dec 2009
Location: Orlando, FL
Posts: 70
Thanks: 3
Thanked 4 Times in 4 Posts
Send a message via AIM to carlosinfl
Question Postfix Wont Send Email From Webmail Only

I've got two servers on my network:

- mail.iamghost.org [192.168.0.200 / 24]
- www.iamghost.org [192.168.0.201 / 24]

Now my Postfix server lets me send mail via SMTP just fine from Thunderbird on any machine that is in 'mynetworks' file:

Code:
[root@mail ~]# cat /etc/postfix/mynetworks 
127.0.0.0/8
192.168.0.0/24
The problem I'm having is that I've installed RoundCube on my web server listed above and I'm able to login and read all my messages perfectly via IMAP4. The problem is when I compose a new message and try to send via SMTP from webmail only. When I try and send, I get a SMTP error: SMTP Error (250) Authentication Failure. I can't understand what's causing this. When I 'tail' my Postfix log file, I don't see anything but an incoming connection and then an immediate disconnect. No details show why this is occurring. I then ran Postfix in debug mode to get more info and here's what I show:

Code:
Jan 11 13:29:32 mail dovecot: imap-login: Login: user=<carlos>, method=PLAIN, rip=192.168.0.201, lip=192.168.0.200, mpid=2190, TLS
Jan 11 13:29:32 mail postfix/smtpd[2191]: connect from www.iamghost.org[192.168.0.201]
Jan 11 13:29:32 mail postfix/smtpd[2191]: match_hostname: www.iamghost.org ~? 127.0.0.0/8
Jan 11 13:29:32 mail postfix/smtpd[2191]: match_hostaddr: 192.168.0.201 ~? 127.0.0.0/8
Jan 11 13:29:32 mail postfix/smtpd[2191]: match_hostname: www.iamghost.org ~? 192.168.0.0/24
Jan 11 13:29:32 mail postfix/smtpd[2191]: match_hostaddr: 192.168.0.201 ~? 192.168.0.0/24
Jan 11 13:29:32 mail postfix/smtpd[2191]: > www.iamghost.org[192.168.0.201]: 220 mail.iamghost.org ESMTP Postfix
Jan 11 13:29:32 mail postfix/smtpd[2191]: watchdog_pat: 0x1530c60
Jan 11 13:29:32 mail postfix/smtpd[2191]: < www.iamghost.org[192.168.0.201]: EHLO www.iamghost.org
Jan 11 13:29:32 mail postfix/smtpd[2191]: > www.iamghost.org[192.168.0.201]: 250-mail.iamghost.org
Jan 11 13:29:32 mail postfix/smtpd[2191]: > www.iamghost.org[192.168.0.201]: 250-PIPELINING
Jan 11 13:29:32 mail postfix/smtpd[2191]: > www.iamghost.org[192.168.0.201]: 250-SIZE 20480000
Jan 11 13:29:32 mail postfix/smtpd[2191]: > www.iamghost.org[192.168.0.201]: 250-VRFY
Jan 11 13:29:32 mail postfix/smtpd[2191]: match_list_match: www.iamghost.org: no match
Jan 11 13:29:32 mail postfix/smtpd[2191]: match_list_match: 192.168.0.201: no match
Jan 11 13:29:32 mail postfix/smtpd[2191]: > www.iamghost.org[192.168.0.201]: 250-ETRN
Jan 11 13:29:32 mail postfix/smtpd[2191]: > www.iamghost.org[192.168.0.201]: 250-ENHANCEDSTATUSCODES
Jan 11 13:29:32 mail postfix/smtpd[2191]: > www.iamghost.org[192.168.0.201]: 250-8BITMIME
Jan 11 13:29:32 mail postfix/smtpd[2191]: > www.iamghost.org[192.168.0.201]: 250 DSN
Jan 11 13:29:32 mail postfix/smtpd[2191]: watchdog_pat: 0x1530c60
Jan 11 13:29:32 mail postfix/smtpd[2191]: < www.iamghost.org[192.168.0.201]: RSET
Jan 11 13:29:32 mail postfix/smtpd[2191]: > www.iamghost.org[192.168.0.201]: 250 2.0.0 Ok
Jan 11 13:29:32 mail postfix/smtpd[2191]: watchdog_pat: 0x1530c60
Jan 11 13:29:32 mail postfix/smtpd[2191]: < www.iamghost.org[192.168.0.201]: QUIT
Jan 11 13:29:32 mail postfix/smtpd[2191]: > www.iamghost.org[192.168.0.201]: 221 2.0.0 Bye
Jan 11 13:29:32 mail postfix/smtpd[2191]: match_hostname: www.iamghost.org ~? 127.0.0.0/8
Jan 11 13:29:32 mail postfix/smtpd[2191]: match_hostaddr: 192.168.0.201 ~? 127.0.0.0/8
Jan 11 13:29:32 mail postfix/smtpd[2191]: match_hostname: www.iamghost.org ~? 192.168.0.0/24
Jan 11 13:29:32 mail postfix/smtpd[2191]: match_hostaddr: 192.168.0.201 ~? 192.168.0.0/24
Jan 11 13:29:32 mail postfix/smtpd[2191]: disconnect from www.iamghost.org[192.168.0.201]
Jan 11 13:29:32 mail dovecot: imap(carlos): Disconnected: Logged out bytes=12/341
Anyone know what is causing this error? I've completely disable (I think) TLS configuration from Postfix (not Dovecot) to verify what the issue maybe. Still get the same error with TLS disable. I can telnet into the server from any PC and send mail via Telnet:

Code:
[cmennens@tuna ~]$ telnet mail.iamghost.org 25
Trying 192.168.0.200...
Connected to mail.iamghost.org.
Escape character is '^]'.
220 mail.iamghost.org ESMTP Postfix
EHLO tuna.ideorlando.org
250-mail.iamghost.org
250-PIPELINING
250-SIZE 20480000
250-VRFY
250-ETRN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
mail from:carlos@iamghost.org
250 2.1.0 Ok
rcpt to:carlos.mennens@gmail.com
250 2.1.5 Ok
data
354 End data with <CR><LF>.<CR><LF>
Subject:Test Email Message
This is a test
.
250 2.0.0 Ok: queued as 4E7E7140522
quit
221 2.0.0 Bye
Connection closed by foreign host.
Any ideas on what this could be? It's driving me crazy and I'm exhausted myself trying to resolve this issue.
Reply With Quote
Sponsored Links
  #2  
Old 12th January 2011, 14:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

I guess it's a RoundCube setting (maybe an authentication setting somewhere?), but I'm no RoundCube expert, so this is just a guess.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 12th January 2011, 14:50
carlosinfl carlosinfl is offline
Member
 
Join Date: Dec 2009
Location: Orlando, FL
Posts: 70
Thanks: 3
Thanked 4 Times in 4 Posts
Send a message via AIM to carlosinfl
Default

Quote:
Originally Posted by falko View Post
I guess it's a RoundCube setting (maybe an authentication setting somewhere?), but I'm no RoundCube expert, so this is just a guess.
It appears to be either the EHLO/HELO that RC is annoucing because Postfix doesn't like it and is sending a RESET command following the HELO.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Catchall and Forwarding not working simmo General 6 22nd March 2014 00:54
CGI and FormMail Cracklefish Installation/Configuration 17 13th October 2009 13:40
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
how to configure postfix to send email out for a hosted domain nox171 Server Operation 24 13th July 2007 11:48


All times are GMT +2. The time now is 19:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.