Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th December 2010, 20:12
entertheraptor entertheraptor is offline
Member
 
Join Date: Dec 2010
Location: Melbourne, Australia
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to entertheraptor
Question mydomain.com/webmail access

OK, maybe if I post this as a new thread I might stand a better chance of getting a response.

I have set up a home based server following "The Perfect Server Ubuntu 10.10 [ISPConfig 3]" guide. Since then I installed Roundcube Webmail in /var/www/mail and after some initial instillation problems everything works fine. I can access my Roundcube Webmail locally through 192.168.x.x/mail and like I said all works fine.

What I want to do is access my Roundcube Webmail through the internet at "mydomain.com/mailbox" mydomain.com was set up with ISPConfig 3 so it's physical location on the server is /var/www/clients/client1/web1/web or /var/www/mydomain.com/web.

The first method that was suggested to me was to create a file /etc/apache2/conf.d/roundcube.conf with the following content,

Alias /mailbox /var/www/mail
<Directory /var/www/mail>
php_admin_value open_basedir /var/www/mail
AllowOverride All
Order allow,deny
Allow from all
</Directory>

Theory being that Roundcube could then be accessed from any domain on the server by appending /mailbox to the domain name. Using this method when I go to mydomain.com/mailbox I get "Internal Server Error 500".

I repaced this method with a symlink created in the mydomain.com/web directory using the command "ln -s /var/www/mail mydomain.com/web/mailbox" which appears to have created the symlink just fine and when I use the command "ls -l" in that directory the symlink appears to point to /var/www/mail but when I go to mydomain.com/mailbox I am again greeted with the "Error 500".

Help please.
Reply With Quote
Sponsored Links
  #2  
Old 27th December 2010, 13:17
entertheraptor entertheraptor is offline
Member
 
Join Date: Dec 2010
Location: Melbourne, Australia
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to entertheraptor
Default

OK, now things are really screwed up!

I went back to using the file /etc/apache2/conf.d/roundcube.conf as described above and was still getting the error 500. Whether it was a good idea or not I decided to change this file to point to the squirrelmail instillation instead to see if that worked figuring it may give me some indication as to whether the problem was with roundcube (or something associated) itself or with the roundcube.conf file.

When I changed the roundcube.conf file to point to the squirrelmail instillation what happened was when I went to "mydomain.com/mailbox" the browser (Chrome) downloaded the index.php file in the squirrelmail directory instead of opening it.

So I changed the roundcube.conf file back to it's original settings (pointing to /var/www/mail) expecting it to go back to throwing a 500 error and it still downloads the squirrelmail index.php.

This behavior has continued after refreshing the browser, restarting apache and even rebooting the server.

I'm now at a complete loss.

(Update)
I got past this (or something did, still not sure how) and now we are back to getting the error 500. I have searched through error logs and the only thing I could find was in /var/log/ispconfig/httpd/mydomain.com/error.log which reported as follows...

[Mon Dec 27 21:19:58 2010] [error] [client 192.168.1.2] SoftException in Application.cpp:221: File "/var/www/mail/index.php" is not in document root of Vhost "/var/www/mydomain.com/web"

...and that's all she wrote!

Some assistance with this issue would be greatly appreciated.

Last edited by entertheraptor; 27th December 2010 at 23:39. Reason: Update
Reply With Quote
Reply

Bookmarks

Tags
error 500, mail, roundcube, webmail

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmin upgrade lishaw1968 Installation/Configuration 15 26th August 2010 15:23
directories in /home/admispconfig/ispconfig renamed? Spudchat General 10 12th April 2007 19:37
ERROR: The PHP binary coming with ISPConfig does not work properly on your system W1SKCC Installation/Configuration 2 2nd February 2007 13:55
Installation Problem irpr Installation/Configuration 21 13th December 2006 11:55
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 18:26


All times are GMT +2. The time now is 09:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.