Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st June 2006, 01:13
michele michele is offline
Junior Member
 
Join Date: Jun 2006
Location: Ticino, Switzerland
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Postfix + Amavis + SpamAssassin + ClamAV

Hello,

I have read and followed the instructions in the HowTo "Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV)", but I have problems with SpamAssassin and ClamAV.
All incomming email aren't fetched by SpamAssassin and ClamAV.

Al configurations files are the same of the HowTo.
On the syslog, on restarting Amavis, I cann see this lines:

Code:
Jun 21 00:53:02 mtetamaro amavis[3452]: ANTI-VIRUS code      NOT loaded
Jun 21 00:53:02 mtetamaro amavis[3452]: ANTI-SPAM code       NOT loaded
Jun 21 00:53:02 mtetamaro amavis[3452]: ANTI-SPAM-SA code    NOT loaded
How can I resolve this problem? Are people with the same problems?

Thank you for any your effort.

Michele
Reply With Quote
Sponsored Links
  #2  
Old 21st June 2006, 18:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Does your /etc/amavis/amavisd.conf look like the one from the tutorial? Please have a look at the linebreaks, etc. There seems to be a problem when you copy that file with the Internet Explorer.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 21st June 2006, 18:18
michele michele is offline
Junior Member
 
Join Date: Jun 2006
Location: Ticino, Switzerland
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello Falko...

I have copied the same amavisd.conf file and correct it.
Today I have reinstalled but always with the same problem:
without AntiVirus and AntiSpam Check...

I don't know how to solve this problem...
All your HowTo has worked good for me... only this... doesn't...

Sorry for my english and thank you for your time and your help.

Michele
Reply With Quote
  #4  
Old 22nd June 2006, 00:02
michele michele is offline
Junior Member
 
Join Date: Jun 2006
Location: Ticino, Switzerland
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

Hello,

finally I have resolved my problem... after 4 day...
I have a Debian Sarge server and I have installed the last stable amavis-new
from debian repository.

On this debian version (amavisd-new-2.4.1 (20060508)), the amavisd.conf file is ignored. All configuration need to be made in the files in the "/etc/amavis/conf.d/" directory.
In the "/etc/amavis/conf.d/15-content_filter_mode" file, I have removed the # on the two lines @bypass_virus_checks_maps and @bypass_spam_checks_maps.

Now all work.
I need only to check in the 20-debian_defaults if all settings are good and properly configurated for my system.

The next time will be better to read the documentation well before beginning…

I hope this can help if anyone has the same problem.
(perhaps it is the case to point out it in the guide)

Regards,

Michele

Last edited by michele; 22nd June 2006 at 00:06.
Reply With Quote
  #5  
Old 1st July 2006, 14:36
j005u j005u is offline
Junior Member
 
Join Date: Jul 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

using testing here and i have the same problem. i moved the config.d and made a new one inserting the sample config file you gave. no go, virus checks are still disabled.

going to try with the default config.

edit:
adding the lines

@bypass_virus_checks_maps = (
\%bypass_virus_checks, \@bypass_virus_checks_acl, \$bypass_virus_checks_re);

@bypass_spam_checks_maps = (
\%bypass_spam_checks, \@bypass_spam_checks_acl, \$bypass_spam_checks_re);

enables virus checks on debian testing and guessing by the previous poster also on the latest sarge.

Last edited by j005u; 1st July 2006 at 14:41.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users + Domains With Postfix, Courier + MySQL (+SMTP-AUTH, SpamA, ClamAV) brianwc HOWTO-Related Questions 6 9th May 2007 02:44
spamassassin and Clamav gregh Installation/Configuration 3 17th June 2006 10:40
spamassassin and clamAV controlling tom Installation/Configuration 3 13th April 2006 08:07
Virtual Users + Domains With Postfix, Courier + MySQL (+SMTP-AUTH, SpamA, ClamAV) savkar HOWTO-Related Questions 30 22nd March 2006 13:47
clamav and spamassassin masterkain Installation/Configuration 2 23rd November 2005 14:12


All times are GMT +2. The time now is 17:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.