Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th November 2010, 19:36
dmgeurts dmgeurts is offline
Junior Member
 
Join Date: Nov 2005
Location: Netherlands
Posts: 26
Thanks: 2
Thanked 0 Times in 0 Posts
Default Unbind 443 from secondary ip address

Hi there,

Looked all over the place but a bit stumped and don't want to break anything. My server has two ip addresses and I need to run something other than apache2 on <ip2>:443 how do I ensure that apache only binds to <ip1>

Regards,
Djerk
Reply With Quote
Sponsored Links
  #2  
Old 11th November 2010, 20:16
dmgeurts dmgeurts is offline
Junior Member
 
Join Date: Nov 2005
Location: Netherlands
Posts: 26
Thanks: 2
Thanked 0 Times in 0 Posts
Default Please confirm if this will cause issues or not

Changed "Listen 443" to "Listen 1.2.3.4:443" in /etc/apache2/ports.conf

[I'm on Ubuntu 10.04 and ISPconfig 3.0.3]

Code:
<IfModule mod_ssl.c>
    # If you add NameVirtualHost *:443 here, you will also have to change
    # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
    # to <VirtualHost *:443>
    # Server Name Indication for SSL named virtual hosts is currently not
    # supported by MSIE on Windows XP.
Listen 1.2.3.4:443
</IfModule>

<IfModule mod_gnutls.c>
Listen 1.2.3.4:443
</IfModule>
Reply With Quote
  #3  
Old 12th November 2010, 16:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

That is ok.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
apache2, https

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix queue problem? murunix Server Operation 7 2nd May 2011 02:55
Being Spammed/Hacked/Probed not sure PLEASE HELP! kresser General 10 29th October 2010 18:25
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 13:47
Sending emails with custom FROM email address merisor Installation/Configuration 4 8th February 2010 17:27
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20


All times are GMT +2. The time now is 14:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.