Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd November 2010, 16:02
Freek1970 Freek1970 is offline
Junior Member
 
Join Date: Nov 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default No pureftpd and squirrelmail after installing ISPConfig 3.03 on Debian Lenny

Hello!

I tried to install ispconfig on Debian Lenny twice the first time I had some errors so I did the whole install again from start (network install Debian).
This second install went completely without errors, I followed the howtoforge exactly.
Thus I expected to end up with a running configuration.
However I end up with a not working server, it has problems with both pureftp and squirrelmail. The server runs on a hyper-v box but I think this is not a problem due to that the whole installation runs without problems.

Below a status of services:

Status of Services
Web-Server: Online
FTP-Server: Offline
SMTP-Server: Online
POP3-Server: Online
IMAP-Server: Online
myDNS-Server: Online
mySQL-Server: Online

pureftpd mysql does not run and I do not get it running too, I have tried to reinstall only pureftpd by apt-get install reinstall pure-ftpd-common pure-ftpd-mysql but it did not help.
Further when trying to log on to squirrelmail from the webmail it gives an error:
ERROR: Connection dropped by IMAP server.

dovecot and postfix give a lot errors in the mail log:
Code:
Nov 3 14:00:02 linuxwebserverwander postfix/smtpd[8012]: disconnect from localhost.localdomain[127.0.0.1]
Nov 3 14:05:01 linuxwebserverwander dovecot: pop3-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Nov 3 14:05:01 linuxwebserverwander dovecot: imap-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Nov 3 14:05:02 linuxwebserverwander postfix/smtpd[8089]: connect from localhost.localdomain[127.0.0.1]
Nov 3 14:05:02 linuxwebserverwander postfix/smtpd[8089]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Nov 3 14:05:02 linuxwebserverwander postfix/smtpd[8089]: disconnect from localhost.localdomain[127.0.0.1]
Nov 3 14:10:02 linuxwebserverwander dovecot: pop3-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Nov 3 14:10:02 linuxwebserverwander dovecot: imap-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Please help!

With Kind Regards,

Frederik
Reply With Quote
Sponsored Links
  #2  
Old 3rd November 2010, 23:20
Freek1970 Freek1970 is offline
Junior Member
 
Join Date: Nov 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi all,

I did find out more.
Removing the "TLS file" containing the "1" created with the command below made the pure-ftpd work for me.
echo 1 > /etc/pure-ftpd/conf/TLS

So pure-ftpd seems to work without the TLS, the deamon starts then and a ps-ef|grep ftp shows him, while it does not with TLS on my server.

I think further that there was nothing wrong with the squirrelmail, I tried to login with the administrator account and this works before installing ISPConfig3 but not after installing ISPConfig3. ISPConfig3 allows only email accounts that are created in ISPConfig3, I got squirrelmail working with an email account created in ISPConfig3.

I only wonder why the pure-ftpd does not work with TLS, would still like to know why, but for the purpose I use the server for (not connected on the web but in a safe environment) it works.

Frederik
Reply With Quote
  #3  
Old 4th November 2010, 18:25
Freek1970 Freek1970 is offline
Junior Member
 
Join Date: Nov 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Any help on pureftp with TLS?

W.K.Regards,

Frederik
Reply With Quote
  #4  
Old 4th November 2010, 18:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Just a guess, but maybe it is a problem with the resources (e.g. memory) allocated to your virtual machine.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 4th November 2010, 18:58
Freek1970 Freek1970 is offline
Junior Member
 
Join Date: Nov 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Falko,

Thank you for comming in.
The Hyper-V VM has 512 MB RAM and 20 GB diskspace.
I expected that 512 MB was enough (this server has not much load).
Maybe I'am wrong?

With Kind Regards,

Frederik
Reply With Quote
  #6  
Old 4th November 2010, 19:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

I'd install munin to find out if there are any problems with the resources: http://www.howtoforge.com/server-mon...n-debian-lenny
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3] husskii HOWTO-Related Questions 5 8th January 2010 14:44


All times are GMT +2. The time now is 02:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.