Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th October 2010, 09:55
evok evok is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default mail authentication failure - unknown user or password

Hi all,
I know this subject has been touched on before, but I cannot seem to find the correct solution for my problem.. I have install the perfect server fedora 13 with i386 (the article was for 64) and ispconfig 3.. All is working well except for I am getting authentication failures for all email accounts.. I have tried through squirrel mail, thunderbird pop3, imap, all fail.. Squirrelmail says unknown username or password incorrect.. telnet connects successfully.. I have looked and looked, and have not been able to find the issue.. Any help is appreciated..

Here is the output of
netstat -tap

Quote:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:ftp *:* LISTEN 1800/pure-ftpd (SER
tcp 0 0 *:ssh *:* LISTEN 1426/sshd
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 1106/cupsd
tcp 0 0 *:smtp *:* LISTEN 1760/master
tcp 0 0 *:imaps *:* LISTEN 2722/dovecot
tcp 0 0 *:pop3s *:* LISTEN 2722/dovecot
tcp 0 0 *:33059 *:* LISTEN 1033/rpc.statd
tcp 0 0 localhost.localdomain:10024 *:* LISTEN 1682/amavisd (maste
tcp 0 0 localhost.localdomain:10025 *:* LISTEN 1760/master
tcp 0 0 *:mysql *:* LISTEN 1651/mysqld
tcp 0 0 *:pop3 *:* LISTEN 2722/dovecot
tcp 0 0 *:imap *:* LISTEN 2722/dovecot
tcp 0 0 *:sunrpc *:* LISTEN 904/rpcbind
tcp 0 0 localhost.localdomain:49685 localhost.localdomain:http TIME_WAIT -
tcp 0 0 localhost.localdomain:42011 localhost.localdomain:smtp TIME_WAIT -
tcp 0 0 localhost.localdomain:35255 localhost.localdomain:ftp TIME_WAIT -
tcp 0 0 *:48404 *:* LISTEN 1033/rpc.statd
tcp 0 0 *:ftp *:* LISTEN 1800/pure-ftpd (SER
tcp 0 0 *:ssh *:* LISTEN 1426/sshd
tcp 0 0 tcfmail.dyndns.org:ipp *:* LISTEN 1106/cupsd
tcp 0 0 *:smtp *:* LISTEN 1760/master
tcp 0 0 *:https *:* LISTEN 2381/httpd
tcp 0 0 *:imaps *:* LISTEN 2722/dovecot
tcp 0 0 *:pop3s *:* LISTEN 2722/dovecot
tcp 0 0 *:pop3 *:* LISTEN 2722/dovecot
tcp 0 0 *:imap *:* LISTEN 2722/dovecot
tcp 0 0 *:sunrpc *:* LISTEN 904/rpcbind
tcp 0 0 *:webcache *:* LISTEN 2381/httpd
tcp 0 0 *:http *:* LISTEN 2381/httpd
tcp 0 0 *:tproxy *:* LISTEN 2381/httpd

here is my /etc/hosts file

Quote:
192.168.1.105 tcfmail.dyndns.org tcfmail # Added by NetworkManager
127.0.0.1 localhost.localdomain localhost
::1 tcfmail.dyndns.org tcfmail localhost6.localdomain6 localhost6
Reply With Quote
Sponsored Links
  #2  
Old 7th October 2010, 22:22
evok evok is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Also Here is the maillog output

Oct 7 14:13:44 tcfmail dovecot: auth(default): client in: AUTH#0111#011PLAIN#011service=imap#011secured#011l ip=127.0.0.1#011rip=127.0.0.1#011lport=143#011rpor t=49825#011resp=AGRlc2lnbkB0Y2ZjYXJlcy5uZXQAZG9udG xvb2s=
Oct 7 14:13:44 tcfmail dovecot: auth-worker(default): pam(user@tcfcares.net,127.0.0.1): lookup service=dovecot
Oct 7 14:13:44 tcfmail dovecot: auth-worker(default): pam(user@tcfcares.net,127.0.0.1): #1/1 style=1 msg=Password:
Oct 7 14:13:45 tcfmail dovecot: auth(default): new auth connection: pid=1005
Oct 7 14:13:46 tcfmail dovecot: auth-worker(default): pam(user@tcfcares.net,127.0.0.1): unknown user
Oct 7 14:13:48 tcfmail dovecot: auth(default): client out: FAIL#0111#011user=user@tcfcares.net
Oct 7 14:13:48 tcfmail dovecot: auth(default): client in: AUTH#0111#011PLAIN#011service=imap#011secured#011l ip=127.0.0.1#011rip=127.0.0.1#011lport=143#011rpor t=49826#011resp=AGRlc2lnbkB0Y2ZjYXJlcy5uZXQAZG9udG xvb2s=
Oct 7 14:13:48 tcfmail dovecot: auth-worker(default): pam(user@tcfcares.net,127.0.0.1): lookup service=dovecot
Oct 7 14:13:48 tcfmail dovecot: auth-worker(default): pam(user@tcfcares.net,127.0.0.1): #1/1 style=1 msg=Password:
Oct 7 14:13:48 tcfmail dovecot: auth(default): new auth connection: pid=1008
Oct 7 14:13:50 tcfmail dovecot: auth-worker(default): pam(user@tcfcares.net,127.0.0.1): unknown user
Oct 7 14:13:52 tcfmail dovecot: auth(default): client out: FAIL#0111#011user=user@tcfcares.net
Oct 7 14:13:53 tcfmail dovecot: imap-login: Aborted login (auth failed, 1 attempts): user=<user@tcfcares.net>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Oct 7 14:13:57 tcfmail dovecot: imap-login: Aborted login (auth failed, 1 attempts): user=<user@tcfcares.net>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Oct 7 14:15:02 tcfmail dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Oct 7 14:15:02 tcfmail dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Oct 7 14:15:02 tcfmail postfix/smtpd[1085]: connect from localhost.localdomain[127.0.0.1]
Oct 7 14:15:02 tcfmail postfix/smtpd[1085]: warning: SASL: Connect to private/auth failed: No such file or directory
Oct 7 14:15:02 tcfmail postfix/smtpd[1085]: fatal: no SASL authentication mechanisms
Oct 7 14:15:02 tcfmail dovecot: auth(default): new auth connection: pid=1100
Oct 7 14:15:02 tcfmail dovecot: auth(default): new auth connection: pid=1101
Oct 7 14:15:03 tcfmail postfix/master[1760]: warning: process /usr/libexec/postfix/smtpd pid 1085 exit status 1
Oct 7 14:15:03 tcfmail postfix/master[1760]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Oct 7 14:15:45 tcfmail dovecot: auth(default): client in: AUTH#0111#011PLAIN#011service=imap#011secured#011l ip=192.168.1.105#011rip=192.168.1.1#011lport=143#0 11rport=2762
Oct 7 14:15:45 tcfmail dovecot: auth(default): client out: CONT#0111#011
Oct 7 14:15:45 tcfmail dovecot: auth(default): client in: CONT#0111#011AGRlc2lnbgBkb250bG9vaw==
Oct 7 14:15:45 tcfmail dovecot: auth-worker(default): pam(user,192.168.1.1): lookup service=dovecot
Oct 7 14:15:45 tcfmail dovecot: auth-worker(default): pam(user,192.168.1.1): #1/1 style=1 msg=Password:
Oct 7 14:15:46 tcfmail dovecot: auth(default): new auth connection: pid=1105
Oct 7 14:15:47 tcfmail dovecot: auth-worker(default): pam(user,192.168.1.1): unknown user
Oct 7 14:15:49 tcfmail dovecot: auth(default): client out: FAIL#0111#011user=user
Oct 7 14:15:54 tcfmail dovecot: auth(default): client in: AUTH#0112#011PLAIN#011service=imap#011secured#011l ip=192.168.1.105#011rip=192.168.1.1#011lport=143#0 11rport=2762#011resp=AGRlc2lnbgBkb250bG9vaw==
Oct 7 14:15:54 tcfmail dovecot: auth-worker(default): pam(user,192.168.1.1): lookup service=dovecot
Oct 7 14:15:54 tcfmail dovecot: auth-worker(default): pam(user,192.168.1.1): #1/1 style=1 msg=Password:
Oct 7 14:15:56 tcfmail dovecot: auth-worker(default): pam(user,192.168.1.1): unknown user
Oct 7 14:15:58 tcfmail dovecot: auth(default): client out: FAIL#0112#011user=user
Oct 7 14:16:08 tcfmail dovecot: imap-login: Disconnected (auth failed, 2 attempts): user=<user>, method=PLAIN, rip=192.168.1.1, lip=192.168.1.105, TLS

Last edited by evok; 8th October 2010 at 09:15.
Reply With Quote
  #3  
Old 8th October 2010, 01:07
evok evok is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Here is the telnet output

It shows below, that the password is failing.. but I don't know enough linux to know why..

Code:
[root@tcfmail mydovecot]# telnet localhost pop3
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK Dovecot ready.
user user@tcfcares.net
+OK
pass password
-ERR Authentication failed.
Any help greatly appreciated..
Reply With Quote
  #4  
Old 8th October 2010, 05:43
evok evok is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default here is my maillog errors

I wish I knew what to do with these errors, even though I understand what they mean, I don't know where to go to fix them.. Here are my maillog files.. Sorry to keep posting more info but I am putting it up as I find it so that hopefully some kindly person will tell me how simple of a fix it is and I can get out from under this brain damage..

Code:
Oct  7 21:25:45 tcfmail dovecot: auth(default): client in: AUTH#0111#011PLAIN#011service=imap#011secured#011lip=192.168.1.105#011rip=192.168.1.1#011lport=143#011rport=3568
Oct  7 21:25:45 tcfmail dovecot: auth(default): client out: CONT#0111#011
Oct  7 21:25:45 tcfmail dovecot: auth(default): client in: CONT#0111#011AGRlc2lnbgBkb250bG9vaw==
Oct  7 21:25:45 tcfmail dovecot: auth-worker(default): pam(user,192.168.1.1): lookup service=mail
Oct  7 21:25:45 tcfmail dovecot: auth-worker(default): pam(user,192.168.1.1): pam_authenticate() failed: Authentication failure (password mismatch?) (given password: password)
Oct  7 21:25:46 tcfmail dovecot: auth(default): new auth connection: pid=16112
Oct  7 21:25:47 tcfmail dovecot: auth(default): client out: FAIL#0111#011user=user

Last edited by evok; 8th October 2010 at 08:02.
Reply With Quote
  #5  
Old 8th October 2010, 10:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,034
Thanks: 826
Thanked 5,383 Times in 4,230 Posts
Default

The postfix configuration is not correct as it uses sasl authentication instead of dovecot and dovecot uses pam instead of mysql.

Which tutorial did you use to install your server?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 8th October 2010, 16:27
evok evok is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Thank you

Thank you Till for responding.. I used this tutorial..

The Perfect Server - Fedora 13 x86_64 [ISPConfig 3]
http://www.howtoforge.com/perfect-se...64-ispconfig-3

I have i386 installed, and changed a couple folders accordingly but other than that I followed everything pretty much to the letter..
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email Could not send and receive piseth Installation/Configuration 16 17th July 2010 18:27
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33
CGI and FormMail Cracklefish Installation/Configuration 17 13th October 2009 13:40
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
Mail server attack princebenin Server Operation 1 19th November 2007 14:02


All times are GMT +2. The time now is 05:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.