Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th September 2010, 22:22
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Exclamation some nasty behaviour of ISPConfig 3.0.2.2.

Hi Till,
Today i dicovered some nasty behaviour of ISPConfig 3.0.2.2.
I try to tell you what i found out:

In ISPConfig3 on the master server, i added the new (additional) IP-addess 12.34.56.222 for an existing slave server.
Before i did that the slave server had the following content within /etc/network/interfaces:


Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 12.34.56.111
        netmask 255.255.255.0
        network 12.34.56.0
        broadcast 12.34.56.255
        gateway 12.34.56.129
After adding the additional IP-address on the master server, the content of /etc/network/interfaces on the slave changed into:

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 12.34.56.222
        netmask 255.255.255.0
        network 12.34.56.0
        broadcast 12.34.56.255
        gateway 12.34.56.129

auto eth0:0
iface eth0:0 inet static
        address 12.34.56.111
        netmask 255.255.255.0
        network 12.34.56.0
        broadcast 12.34.56.255
        gateway 12.34.56.129
This is a problem, because of this automatic modification the slave server can not connect to the master anymore, because only root@12.34.56.111 is valid to connect to the master server, NOT root@12.34.56.222
So ISPConfig3 should not move 12.34.56.111 to eth0:0. but the new IP 12.34.56.222 instead!

So the right file content of /etc/networking/interfaces should be:

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 12.34.56.111
        netmask 255.255.255.0
        network 12.34.56.0
        broadcast 12.34.56.255
        gateway 12.34.56.129

auto eth0:0
iface eth0:0 inet static
        address 12.34.56.222
        netmask 255.255.255.0
        network 12.34.56.0
        broadcast 12.34.56.255
        gateway 12.34.56.129
It would be nice if this behaviour can be changed in the next release of ISPConfig3.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005

Last edited by Hans; 27th September 2010 at 23:49.
Reply With Quote
Sponsored Links
  #2  
Old 27th September 2010, 22:29
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
Default

Today I locked myself out by doing something like you did.
I can not access my server anymore, and as it's a test server in Alphen a/d Rijn (grafix) I need to go there tomorrow and rewrite the file interfaces (add the correct info).

I'm using eth6 an eth7 in it, and ISPconfig changed it to eth0 and 0:0
(for some reason eth0 till eth5 do not work on my system).

Long car drive tomorrow :-(
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #3  
Old 27th September 2010, 22:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,333 Times in 4,184 Posts
Default

@Hans: Please post it to the bugtracker so that we can check it.

@edge: I'am sorry that you have these problems. Thats the reason why the network configuration support is disabled by default. It can only be used for standard setups that use eth0. Other setups or network card names are not supported.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 27th September 2010, 23:25
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

@Till,
I did that now.

@Edge, i feel sorry for you.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005

Last edited by Hans; 27th September 2010 at 23:41.
Reply With Quote
The Following User Says Thank You to Hans For This Useful Post:
edge (28th September 2010)
  #5  
Old 28th September 2010, 15:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,333 Times in 4,184 Posts
Default

@edge. I've added a warning text to tthe network settings option to explain when it can not be used.

@hans: thanks for the bugtracker entry. Will fix that until 3.0.3 final.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following 2 Users Say Thank You to till For This Useful Post:
edge (28th September 2010), Hans (28th September 2010)
  #6  
Old 28th September 2010, 15:45
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
Default

Thank you both.

After a +2 hr car drive I managed to fix the server again! (normally it only takes 50 minutes, but I got stuck in a 11 KM traffic jam)

On the way back I took a quick lunch at the Mcdonalds (the only fun part about the trip today).

I'm now talking to the DC about getting KVM over IP.

PS. I've seen a lot of DC's here in the Netherlands, and for sure the girl behind the desk at the DC where I was today is the best looking one!
Damn she was cute...
__________________
Never execute code written on a Friday or a Monday.

Last edited by edge; 28th September 2010 at 15:48.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig certificate expired, followed instructions, now can't access ISPConfig DennyCrane General 1 22nd November 2009 18:34
Install a Comodo InstantSSL Certificate for ISPconfig Apache, Postfix, Imap & Pop gwa7 Tips/Tricks/Mods 1 30th September 2009 18:08
Resources/additions for ISPConfig 3 khayjake General 3 2nd May 2009 09:40
Install a Comodo InstantSSL Certificate for ISPconfig Apache, Postfix, Imap & Pop gwa7 Installation/Configuration 0 10th April 2009 04:54
ISPConfig 3.0.0.7 Beta released till General 78 24th December 2008 11:47


All times are GMT +2. The time now is 20:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.