Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th September 2010, 12:34
vmos vmos is offline
Member
 
Join Date: Nov 2008
Posts: 57
Thanks: 1
Thanked 0 Times in 0 Posts
Default amavis config breaks // moving from debian sarge to lenny

Good morning, I upgraded one of our anti-spam servers from debian sarge to etch and then lenny (long overdue, I know)

This has had the effect of scuppering the amavis installation as between sarge and etch, amavis moved from using a monolithic config file to using a config directory.

I had to uninstall amavis and put it back again. I've got the old config saved but I'm having trouble wrapping my head around it.

Does anyone have any advice or can anyone point me to a guide on how to translate the old config file into the new format?
Reply With Quote
Sponsored Links
  #2  
Old 18th September 2010, 13:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

The format hasn't changed; only the big amavisd configuration file was split up in multiple smaller files, so the configuration is still the same, but you have to modify multiple files.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 19th September 2010, 18:59
vmos vmos is offline
Member
 
Join Date: Nov 2008
Posts: 57
Thanks: 1
Thanked 0 Times in 0 Posts
Default

that's what I'm trying to figure out, what bits go in what files? does it matter? can I make up my own?

specifically, I'm concentrating on the whitelisting and blacklisting per domain (IE, ted@jimbo.com doesn't want any mail from hotmail.com tagged as spam but bob@waldo.com doesn't want anything from hotmail and so forth)

I think the setup we have is a bit wierd, all the googling I've done suggests that this sort of thing is usually done by spamassassin, these servers have spamassassin installed but it seems to be disabled and all the black/whitelisting is in the amavisd.conf
Reply With Quote
  #4  
Old 20th September 2010, 16:04
vmos vmos is offline
Member
 
Join Date: Nov 2008
Posts: 57
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I created seperate files for the whitelist and blacklist and it seems to be working, I'm not quite sure where I was going wrong previously

thanks
Reply With Quote
Reply

Bookmarks

Tags
amavis, config, etch, sarge

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[debian 5 + ispconfig 3] Unable to send mail tanakskool HOWTO-Related Questions 6 4th November 2009 18:20
Spamsnake - Problem with spamassassin, FuzzyOcr and MySQL debuguser HOWTO-Related Questions 6 16th September 2008 18:37
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46
spamassasin/clamAV not working Daisy Installation/Configuration 32 15th February 2007 00:09
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48


All times are GMT +2. The time now is 18:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.