#1  
Old 18th August 2010, 02:53
holykim holykim is offline
Member
 
Join Date: Jan 2009
Posts: 53
Thanks: 15
Thanked 3 Times in 2 Posts
Default Postfix hostname changes

Hi All

I have multiple IP addresses on my server and want to send emails from my mail server (mail.ibsp.co.nz) with it's IP address.

my server's hostname is ibsp.co.nz and IP is 202.89.33.167
my mail server is mail.ibsp.co.nz and IP is 202.89.33.168
IP block owner set the PTR record for my mail server

I changed the hostname in main.cf to mail.ibsp.co.nz (it was ibsp.co.nz) and sent a test email to gmail account but the client-ip is still 202.89.33.167 and the email contained "Received: from mail.ibsp.co.nz (www.ibsp.co.nz [202.89.33.167])".

Currently ISPConfig 2 and postfix are installed with CentOS5.
(I have ISPConfig 3 server with postfix and it has the same problem.....)

Could you please advise how to change the mail server in Postfix?

Thanks in advance.

Harry
Reply With Quote
Sponsored Links
  #2  
Old 18th August 2010, 10:11
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Code:
"Received: from mail.ibsp.co.nz (www.ibsp.co.nz [202.89.33.167])"
That's because postfix still mails through that interface, and most MTA's do a reversed lookup on the ip, to grab the hostname ..

seth eth0 to .168 and eth0:0 to .167
Reply With Quote
The Following User Says Thank You to Mark_NL For This Useful Post:
holykim (18th August 2010)
  #3  
Old 18th August 2010, 10:58
holykim holykim is offline
Member
 
Join Date: Jan 2009
Posts: 53
Thanks: 15
Thanked 3 Times in 2 Posts
Default

Thanks Mark

Doesn't it affect to any other services? I am running APM, DNS, and etc on the same server. Please advise.

Cheers

Harry
Reply With Quote
  #4  
Old 18th August 2010, 11:32
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

nah if you keep both ip's up it shouldn't be any problem. but remember that the default external ip for your server will become .168 then .. so keep in mind of firewalls etc ..
Reply With Quote
The Following User Says Thank You to Mark_NL For This Useful Post:
holykim (18th August 2010)
  #5  
Old 18th August 2010, 11:51
holykim holykim is offline
Member
 
Join Date: Jan 2009
Posts: 53
Thanks: 15
Thanked 3 Times in 2 Posts
Default

Hi Mark

It works great! email send through .168. Thanks again.

I have another problem with DKIM with amavisd-new. I put the below code into amavisd.conf and tested Ok.

$enable_dkim_verification = 1;
$enable_dkim_signing = 1;
dkim_key('netcafe24.net', 'mail', '/var/db/dkim/netcafe24.key.pem');
@dkim_signature_options_bysender_maps = (
{ '.' => { ttl => 21*24*3600, c => 'relaxed/simple' } } );
@mynetworks = qw(0.0.0.0/8 127.0.0.0/8);

amavisd testkeys
TESTING#1: mail._domainkey.mail.netcafe24.net => pass

I made a TXT record as below
Hostname : mail._domainkey.mail.netcafe24.net with the
Text : v=DKIM1; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDSMM8gWgE1 nmvrZ0s7myIA52Ykemqkc6ICzlCPMOpgflNmoVcvIkYUh0KLZf 2mEJt362/qLZxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

I sent an email to gmail account but I can not find DKIM signature. My mail server is mail.netcafe24.net. Can you please advise what's wrong?

Cheers
Harry
Reply With Quote
  #6  
Old 18th August 2010, 12:03
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Your mail server is mail.netcafe24.net .. but your domain is netcafe24.net ..

I'd rather set the key on mail._domainkey.netcafe24.net .. but it's not required (it's just cleaner imho

anyway, could you post the complete headers from the mail you send to gmail?
Reply With Quote
Reply

Bookmarks

Tags
hostname, postfix

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36


All times are GMT +2. The time now is 02:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.