#1  
Old 19th July 2010, 03:06
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default Error with suexec enabled

Hello all,

In ISPConfig I have suexec enabled for my server and everything is working perfect.
However, I have two statistic - pages in /usr/share/* and they give with suexec enabled "error 500". With suexec disabled there are no errors.

The first page is located in /usr/share/mailgraph and is called in a browser with http://www.domain.nu/mailgraph
For this I use the attached mailgraph.conf wich is located in /etc/htpd/conf.d

The second page is located in /usr/share/awstats/* and is called in a browser with http://www.domain.nu/awstats/awstats...=www.domain.nu
Awstats adjusted the httpd.conf file during config ( see attached httpd.conf file )

Is there a way that suexec makes an exception for those two pages (directories) ? I prefer suexec enabled for my server.
Or do I have to change ownership to apache:apache ?

Help would be appreciated ....
Attached Files
File Type: txt httpd.conf.txt (498 Bytes, 158 views)
File Type: txt mailgraph.conf.txt (290 Bytes, 155 views)
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb

Last edited by robertlouwen; 19th July 2010 at 13:22.
Reply With Quote
Sponsored Links
  #2  
Old 19th July 2010, 13:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Any errors in Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 19th July 2010, 14:17
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default

Hello Falko,

Attached some error log ...

location is included in file name i.e. var-log-httpd-error_log = /var/log/httpd/error_log

Have a nice day
Attached Files
File Type: txt var-log-httpd-error_log.txt (26.9 KB, 193 views)
File Type: txt var-log-httpd-suexec.log.txt (5.9 KB, 386 views)
File Type: txt var-log-ispconfig-httpd-domain.nu-error.log.txt (95.2 KB, 360 views)
File Type: txt var-log-ispconfig-httpd-domain.org-error.log.txt (3.6 KB, 258 views)
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
  #4  
Old 20th July 2010, 14:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
[2010-07-19 13:31:19]: command not in docroot (/usr/share/mailgraph/mailgraph.cgi)
The problem is that mailgrpah is outside the document root.

Run
Code:
/usr/sbin/suexec -V
and you should see that suExec's docroot is /var/www:

Code:
[root@server1 ~]# /usr/sbin/suexec -V
 -D AP_DOC_ROOT="/var/www"
 -D AP_GID_MIN=100
 -D AP_HTTPD_USER="apache"
 -D AP_LOG_EXEC="/var/log/httpd/suexec.log"
 -D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
 -D AP_UID_MIN=500
 -D AP_USERDIR_SUFFIX="public_html"
[root@server1 ~]#
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd July 2010, 08:32
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default

Hello Falko,
Code:
/usr/sbin/suexec -V
gives excactly what you said, so I moved mailgraph.cgi and mailgraph.css to /var/www
Also I changed /etc/httpd/conf.d/mailgraph.conf and restarted httpd.
Still I get errors; error 500 or error 403.

The error change when I change owner/group properties and when I change file permissions

How important is it to have suexec enabled for my websites ?
Attached Files
File Type: txt mailgraph.conf.txt (280 Bytes, 141 views)
File Type: txt error.txt (1.5 KB, 162 views)
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
  #6  
Old 24th July 2010, 12:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

I think you must move the scripts inside your web site because otherwise they are outside of your vhost user's home directory.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
fedora 13, ispconfig 3.0.2.2, suphp

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"Call to undefined function mysql_connect()" - Help! dannyg Server Operation 6 10th January 2010 02:06
Broken php5-mysql dclardy Installation/Configuration 8 9th October 2009 09:49
server Installation Configuration deco5003 Installation/Configuration 12 5th August 2009 12:00
Uploads timing out Gaartok Server Operation 3 10th May 2009 18:04
The classic MySQL connect error swggy Installation/Configuration 13 10th April 2008 21:45


All times are GMT +2. The time now is 07:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.