Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Kernel Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th June 2006, 03:04
Rock Rock is offline
Junior Member
 
Join Date: May 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default Kernel Panic - Not Syncing : Attempt to kill init!

Hi,

I followed the perfect setup for CentOS and upon yum update (right at the beginning after OS installed) and doing a reboot I got this error message.

Unable to find volume group "VolGroup00"
ERROR: /bin/lvm exited abnormally (pid 213)
mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount: /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!

I got a P4 32bit machine running and adaptec 1420 SATA2 raid controller card. Use automatic disk partitioning with LVM and 2000MB of swap space.

This is the third time I got the error after 3 reinstallations. Strange thing is that during one of my earlier installation, it was okie. Not sure if I selected any different options or package or did a step differently.

Anyone can shed a little light to this? Thanks in advance.

linux rocks!
Reply With Quote
Sponsored Links
  #2  
Old 6th June 2006, 10:12
Rock Rock is offline
Junior Member
 
Join Date: May 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just to give a bit more details, adaptec 1420 SATA2 Raid is not supported by CentOS by default, I have compiled and driver disk.

While running yum update, I notice there are a couple of kernel related updates. (Not sure if the kernel I have in my cd is the latest since I download it 5-6 weeks ago.) I wonder if the Raid driver died because of the kernel update?

How can I tell? How do I troubleshoot this issue?
I am a newbie, thus any suggestions and advice will be appreciated.

rock
Reply With Quote
  #3  
Old 6th June 2006, 12:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by Rock
I wonder if the Raid driver died because of the kernel update?
That might be. Do you use a ramdisk? Is the RAID driver included in there?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 6th June 2006, 13:30
Rock Rock is offline
Junior Member
 
Join Date: May 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Pardon me, but what is a Ramdisk? Where is it suppose to be located? How can I check it now that CentOS cannot boot up?
Reply With Quote
  #5  
Old 7th June 2006, 15:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

A RAMdisk is a kind of image of your kernel that includes file system drivers etc. needed at boot time that would normally be loaded too late (it's akind of botstrapping problem).
What's the output of
Code:
ls -la /boot
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 8th June 2006, 05:48
Rock Rock is offline
Junior Member
 
Join Date: May 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

While troubleshooting, chance upon this site which I thought might be useful for anyone facing the same issue. It has the steps to recompile kernel.

http://www.digitalhermit.com/linux/K...FIGURATION-2-6

Back to my problem, tried re-running everything all over again. This is the output of the yum update.

Quote:
Transaction Summary
================================================== ===========================
Install 3 Package(s)
Update 2 Package(s)
Remove 0 Package(s)
Total download size: 31 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): kernel-hugemem-dev 100% |=========================| 3.7 MB 01:19
(2/5): kernel-2.6.9-34.0. 100% |=========================| 10 MB 02:03
(3/5): kernel-devel-2.6.9 100% |=========================| 3.7 MB 01:38
(4/5): kernel-smp-devel-2 100% |=========================| 3.7 MB 00:33
(5/5): kernel-smp-2.6.9-3 100% |=========================| 9.9 MB 03:11
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: kernel-smp ######################### [1/7]
WARNING: No module aar81xx found for kernel 2.6.9-34.0.1.ELsmp, continuing anyway
Updating : kernel-hugemem-devel ######################### [2/7]
Installing: kernel ######################### [3/7]
WARNING: No module aar81xx found for kernel 2.6.9-34.0.1.EL, continuing anyway
Installing: kernel-devel ######################### [4/7]
Updating : kernel-smp-devel ######################### [5/7]
Cleanup : kernel-hugemem-devel ######################### [6/7]
Cleanup : kernel-smp-devel ######################### [7/7]

Installed: kernel.i686 0:2.6.9-34.0.1.EL kernel-devel.i686 0:2.6.9-34.0.1.EL kernel-smp.i686 0:2.6.9-34.0.1.EL
Updated: kernel-hugemem-devel.i686 0:2.6.9-34.0.1.EL kernel-smp-devel.i686 0:2.6.9-34.0.1.EL
Complete!
How should I go about tackling this problem?
1. exculde kernel packages in all updates?
2. rebuild kernel with the driver each time I update?
3. others?

Is there any ways to solve the issue permanently?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
xen not booting qiu HOWTO-Related Questions 11 2nd May 2006 11:20
sargeDebian GNU/Linux, kernel 2.6.8-3-686 and Debian kernel 2.6.8 386- qiu Kernel Questions 23 25th April 2006 16:53
Problems installing NForce4 sound drivers Wraithfire Installation/Configuration 21 16th April 2006 18:30
KErnel not showing all my memory Jorem Kernel Questions 8 13th April 2006 13:59
Questions about ubuntu ISP-Server Setup badgerbox76 HOWTO-Related Questions 15 5th March 2006 15:41


All times are GMT +2. The time now is 13:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.