Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd July 2010, 23:05
davebamford davebamford is offline
Junior Member
 
Join Date: Jul 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Pure Ftpd MySQL authorisation problem

Hi
Please excuse me if this has been answered but I have searched the forums and cannot fix this problem.
I have installed ispconfig3 on Debian Squeeze running on a virtual machine using KVM and everything seems to work except for pureftp. I have tried various fixes suggested her but cannot get a user to authorise with sql. Unix users can log in,
Auth is set as follows
30mysql 65unix 70pam
Dontresolve is set to yes
PAMauthentication I have changed to No
and in the mysql.conf file I have tried 127.0.0.1 and localhost as the sql server
also I have changed the encryption from crypt to any

I can access the table ftp_user and see the username and an encrypted password
and the database username and password in the mysql.conf file work OK.

Please help I am now totally stuck.

Thanks

Dave
Reply With Quote
Sponsored Links
  #2  
Old 3rd July 2010, 12:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Any errors in your logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd July 2010, 13:54
davebamford davebamford is offline
Junior Member
 
Join Date: Jul 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default logs

Here is an extract from the logs when I try to locally log in with pureftp.
I only just noticed that there is a message about the SQL server being down, yet I can
manually connect to the sql database using mysql -p xxx
>use dbispconfig
>select * from ftp_user;
this displays the table

Why is pureftp trying to log in as root, the mysql.conf specifies ispconfig as the user?



Jul 3 12:46:15 maggie pure-ftpd: (?@localhost) [INFO] New connection from localhost
Jul 3 12:46:25 maggie pure-ftpd: (?@localhost) [ERROR] The SQL server seems to be down [Access denied for user 'root'@'localhost' (using password: YES)]
Jul 3 12:46:25 maggie pure-ftpd: (?@localhost) [INFO] PAM_RHOST enabled. Getting the peer address
Jul 3 12:46:33 maggie pure-ftpd: (?@localhost) [WARNING] Authentication failed for user [testdave]
Jul 3 12:46:35 maggie pure-ftpd: (?@localhost) [INFO] Logout.
Reply With Quote
  #4  
Old 3rd July 2010, 14:31
davebamford davebamford is offline
Junior Member
 
Join Date: Jul 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just an update
Pureftp does not seem to be reading the mysql.conf file

here is the contents of auth

root@maggie:/etc/pure-ftpd/auth# ls
30mysql 65unix 70pam
root@maggie:/etc/pure-ftpd/auth# more 30mysql
/etc/pure-ftpd/db/mysql.conf
root@maggie:/etc/pure-ftpd/auth#

could it be a permissions problem? I tried chmod 777 mysql.conf

and here are the contents of conf
root@maggie:/etc/pure-ftpd/conf# more *
::::::::::::::
AltLog
::::::::::::::
clf:/var/log/pure-ftpd/transfer.log
::::::::::::::
BrokenClientsCompatibility
::::::::::::::
yes
::::::::::::::
ChrootEveryone
::::::::::::::
yes
::::::::::::::
DontResolve
::::::::::::::
yes
::::::::::::::
FSCharset
::::::::::::::
UTF-8
::::::::::::::
MinUID
::::::::::::::
1000
::::::::::::::
MySQLConfigFile
::::::::::::::
/etc/pure-ftpd/db/mysql.conf
::::::::::::::
NoAnonymous
::::::::::::::
yes
::::::::::::::
PAMAuthentication
::::::::::::::
no
::::::::::::::
PureDB
::::::::::::::
/etc/pure-ftpd/pureftpd.pdb
::::::::::::::
UnixAuthentication
::::::::::::::
no
root@maggie:/etc/pure-ftpd/conf#
Reply With Quote
  #5  
Old 3rd July 2010, 16:19
davebamford davebamford is offline
Junior Member
 
Join Date: Jul 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Solved!!!

Still not sure what I did to fix it, but a compete uninstall of pure-ftp-mysql and
pure-ftp-common then a reinstall and put the conf files back from a copy and its
working.
Phew!
Reply With Quote
  #6  
Old 27th October 2010, 20:22
astuto astuto is offline
Junior Member
 
Join Date: Oct 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi

I've tried everything but still not working. The log:
[ERROR] The SQL server seems to be down [Access denied for user 'root'@'localhost' (usi
ng password: YES)]

And yes, mysql is working. pure-ftpd tries to access database with 'root' user, while it should be using 'ispconfig'?

I don't know what else to do, reinstalling doesn't seems to change anything.

Please help,

Thanks!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
Problem installing MySQL on suse 10.3 Txchaser Installation/Configuration 20 18th April 2008 01:05
Problem Installing Apache 2.2.8, MySQL 5.0 Client and PHP 5.2.5 On Fedora 8 (64-Bit) asyadiqin Installation/Configuration 5 10th April 2008 18:40
mysql connect problem again Danielss89 Installation/Configuration 3 15th January 2007 21:02
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37


All times are GMT +2. The time now is 00:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.