#1  
Old 17th June 2010, 23:40
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 41 Times in 34 Posts
Default Urgent help please

!!! NO LONGER URGENT !!! THANKS

Apache is having problems starting....

I enabled ssl on a site and minutes later everything came to a halt.

I have tried restarting apache but this is the result I get:
Code:
badbuntu:~# /etc/init.d/apache2 restart
Restarting web server: apache2[Thu Jun 17 21:36:50 2010] [warn] _default_ Virtua              lHost overlap on port 443, the first has precedence
[Thu Jun 17 21:36:50 2010] [warn] _default_ VirtualHost overlap on port 443, the               first has precedence
 failed!
badbuntu:~#
Can someone help me resolve this urgently please. All my sites are down..

Last edited by Toucan; 18th June 2010 at 01:23. Reason: remove urgency
Reply With Quote
Sponsored Links
  #2  
Old 18th June 2010, 00:01
itsnedkeren itsnedkeren is offline
Senior Member
 
Join Date: May 2009
Location: Denmark
Posts: 128
Thanks: 32
Thanked 10 Times in 10 Posts
Default

/etc/apache2/ports.conf

Uncomment this line:

Listen 443

Restart apache server
Reply With Quote
  #3  
Old 18th June 2010, 00:19
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 41 Times in 34 Posts
Default

That line was already uncommmented

It looks like this:
Code:
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
 Listen 443
</IfModule>
apache won't let me do anything:
Code:
badbuntu:/etc/apache2# /etc/init.d/apache2 stop
Stopping web server: apache2[Thu Jun 17 22:19:32 2010] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
.
Reply With Quote
  #4  
Old 18th June 2010, 00:50
itsnedkeren itsnedkeren is offline
Senior Member
 
Join Date: May 2009
Location: Denmark
Posts: 128
Thanks: 32
Thanked 10 Times in 10 Posts
Default

Code:
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
 #Listen 443
</IfModule>
Uncomment the line, as above and restart apache.
Reply With Quote
The Following User Says Thank You to itsnedkeren For This Useful Post:
Toucan (18th June 2010)
  #5  
Old 18th June 2010, 00:55
ivomendonca ivomendonca is offline
Banned
 
Join Date: Sep 2009
Posts: 132
Thanks: 10
Thanked 14 Times in 8 Posts
Default Same error as reported before.

Quote:
Originally Posted by Toucan View Post
Apache is having problems starting....

I enabled ssl on a site and minutes later everything came to a halt.

I have tried restarting apache but this is the result I get:
Code:
badbuntu:~# /etc/init.d/apache2 restart
Restarting web server: apache2[Thu Jun 17 21:36:50 2010] [warn] _default_ Virtua              lHost overlap on port 443, the first has precedence
[Thu Jun 17 21:36:50 2010] [warn] _default_ VirtualHost overlap on port 443, the               first has precedence
 failed!
badbuntu:~#
Can someone help me resolve this urgently please. All my sites are down..
Delete your SSL files and remove from vhost manualy, then when all is working again just add the ssl file the right way. (you can makeit from 2 ways using the interface, one will work)
Before maybe you shoud disable ssl in all sites using ssl and add a ip just for that domain.

Last edited by ivomendonca; 18th June 2010 at 00:57.
Reply With Quote
The Following User Says Thank You to ivomendonca For This Useful Post:
Toucan (18th June 2010)
  #6  
Old 18th June 2010, 01:02
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 41 Times in 34 Posts
Default

Solved the problem.. probably the wrong way but solved never the less!

I manually removed the vhost files for the website that caused the problems, restarted apache successfully.

I then could log into the control panel, remove the offending site from there. I then readded the site and restored the content from a backup.

What is the way that works to enable ssl on a site?

Thanks both for your help.
Reply With Quote
  #7  
Old 18th June 2010, 01:10
ivomendonca ivomendonca is offline
Banned
 
Join Date: Sep 2009
Posts: 132
Thanks: 10
Thanked 14 Times in 8 Posts
Default

Quote:
Originally Posted by Toucan View Post
Solved the problem.. probably the wrong way but solved never the less!

I manually removed the vhost files for the website that caused the problems, restarted apache successfully.

I then could log into the control panel, remove the offending site from there. I then readded the site and restored the content from a backup.

What is the way that works to enable ssl on a site?

Thanks both for your help.
You dont need to delete the vhost files, just the lines related to ssl.
Is like you did last time, the problem is when you select the domain (www) or the (*.), one of those will kill apache and one will work, remember you need a ip just to that site. not a shared ip.
When trying u need to kill problematic apache process before starting again.(dont reboot , that is only on ruindows)

Last edited by ivomendonca; 18th June 2010 at 01:15.
Reply With Quote
  #8  
Old 18th June 2010, 01:30
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 41 Times in 34 Posts
Default

I did actually try commenting out the lines that I thought related to ssl but that didn't seem to work.. so i took the hard route!

I didn't realise you couldn't have more than one SSL on a shared IP between virtual hosts... I won't forget that in a hurry. Sadly my ISP will only give one IP and I'm getting ready to prepare one day for a change of ISP!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Urgent problem misterm Installation/Configuration 1 3rd November 2009 12:26
Urgent urgent ihamouda Installation/Configuration 1 18th February 2009 20:28
Urgent Helpp kamismart Programming/Scripts 5 19th November 2007 17:41
urgent help plis Compadre Installation/Configuration 2 10th April 2007 23:32
Urgent! SMTP/SASL problem after Kernel update teves Installation/Configuration 17 27th March 2007 12:24


All times are GMT +2. The time now is 07:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.