Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th June 2010, 23:55
Happy Happy is offline
Member
 
Join Date: Jun 2007
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Default Setting up Software Raid1 on a system running lvm system

I am following the how to on setting up software raid1 on a running lvm system. However, I ran tinto an error when doing install for mdadm

Here is the line I copyied in
aptitude install initramfs-tools mdadm
I never got the following prompt
MD arrays needed for the root file system: <-- all

I did get the following error on the install
Generating array device nodes... /var/lib/dpkg/info/mdadm.postinst: line 27: /dev/MAKEDEV: No such file or directory
failed
I tried reinstalling and here is the output of the install

aptitude reinstall initramfs-tools mdadm
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages will be REINSTALLED:
initramfs-tools mdadm
0 packages upgraded, 0 newly installed, 2 reinstalled, 0 to remove and 14 not upgraded.
Need to get 88.5kB/325kB of archives. After unpacking 0B will be used.
Writing extended state information... Done
Get:1 http://us.archive.ubuntu.com/ubuntu/ lucid/main initramfs-tools 0.92bubuntu78 [88.5kB]
Fetched 88.5kB in 0s (90.4kB/s)
Preconfiguring packages ...
(Reading database ... 67691 files and directories currently installed.)
Preparing to replace initramfs-tools 0.92bubuntu78 (using .../initramfs-tools_0.92bubuntu78_all.deb) ...
Unpacking replacement initramfs-tools ...
Preparing to replace mdadm 2.6.7.1-1ubuntu15 (using .../mdadm_2.6.7.1-1ubuntu15_i386.deb) ...
* Stopping MD monitoring service mdadm --monitor [ OK ]
Unpacking replacement mdadm ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Setting up initramfs-tools (0.92bubuntu78) ...
update-initramfs: deferring update (trigger activated)

Setting up mdadm (2.6.7.1-1ubuntu15) ...
Generating array device nodes... /var/lib/dpkg/info/mdadm.postinst: line 27: /dev/MAKEDEV: No such file or directory
failed.
Removing any system startup links for /etc/init.d/mdadm-raid ...
update-initramfs: deferring update (trigger activated)
update-rc.d: warning: mdadm start runlevel arguments (2 3 4 5) do not match LSB Default-Start values (S)
update-rc.d: warning: mdadm stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (0 6)
* Starting MD monitoring service mdadm --monitor [ OK ]

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-22-generic-pae
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

Loading one of the modules
modprobe md
FATAL: Module md not found.


From looking at it it looks like drive sdb is being used and one of the many time I rebuilt the server before getting it right I loaded sda So right now only 1 disk sdb is being used and sda has an old setup partition on it(I think). Not sure if this is related to the error?

Last edited by Happy; 13th June 2010 at 00:27.
Reply With Quote
Sponsored Links
  #2  
Old 13th June 2010, 00:22
Happy Happy is offline
Member
 
Join Date: Jun 2007
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Default

fdisk -l
Disk /dev/sda: 160.0 GB, 160000000000 bytes
255 heads, 63 sectors/track, 19452 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc796c701

Device Boot Start End Blocks Id System
/dev/sda1 * 1 19421 155999151 8e Linux LVM
/dev/sda2 19422 19452 249007+ 5 Extended
/dev/sda5 19422 19452 248976 83 Linux

Disk /dev/sdb: 160.0 GB, 160000000000 bytes
255 heads, 63 sectors/track, 19452 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0003ca4d

Device Boot Start End Blocks Id System
/dev/sdb1 1 32 248832 83 Linux
Partition 1 does not end on cylinder boundary.
/dev/sdb2 32 19453 155998209 5 Extended
/dev/sdb5 32 19453 155998208 8e Linux LVM

vgdisplay
--- Volume group ---
VG Name mail
System ID
Format lvm2
Metadata Areas 1
Metadata Sequence No 3
VG Access read/write
VG Status resizable
MAX LV 0
Cur LV 2
Open LV 2
Max PV 0
Cur PV 1
Act PV 1
VG Size 148.77 GiB
PE Size 4.00 MiB
Total PE 38085
Alloc PE / Size 23841 / 93.13 GiB
Free PE / Size 14244 / 55.64 GiB
VG UUID F5nrg3-93xk-4UKa-751l-0OY5-ClFF-M4Xi19
Reply With Quote
  #3  
Old 13th June 2010, 18:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Which distribution do you use? Which tutorial (URL) did you follow?

Is this a physical system or a virtual machine?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 14th June 2010, 17:33
Happy Happy is offline
Member
 
Join Date: Jun 2007
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Default

http://www.howtoforge.com/perfect-se...nx-ispconfig-2

I used the above configuration that you suggested since I only needed system users. The server is a physical machine.
Reply With Quote
  #5  
Old 15th June 2010, 14:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

I mean which tutorial (URL) did you use to set up software RAID1?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 15th June 2010, 15:03
Happy Happy is offline
Member
 
Join Date: Jun 2007
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Default

http://www.howtoforge.com/how-to-set...n-debian-lenny


The above url I followed
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Proftpd + MySQL virtual users, can't connect geekman HOWTO-Related Questions 28 27th September 2010 18:03
How To Set Up Software RAID 1 On A Running LVM System (Incl. GRUB Configuration) GenePoole HOWTO-Related Questions 2 18th May 2010 17:09
Converting a running system to RAID 1 AndyB78 HOWTO-Related Questions 6 13th February 2010 01:42
Fedora 4 TPS mail problem Hagforce HOWTO-Related Questions 13 10th February 2010 18:23
Software RAID1 + LVM on FC5 Daisy Installation/Configuration 3 6th February 2007 13:47


All times are GMT +2. The time now is 13:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.