#1  
Old 26th May 2006, 23:49
heygazeebo heygazeebo is offline
Junior Member
 
Join Date: May 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default SpamAssassin stops working

Hi Everyone,

I followed falko's guide to setting up postfix / mysql etc. on debian, and then followed the guide to add mailfiltering to it. After just a bit of tinkering it mostly worked properly, until i noticed that at some point SpamAssassin had stopped scanning my emails. As best i can figure it was when i added in the mailfiltering portion of the setup. Virus detection is still working, but not Spam. Anybody have any suggestions?
Reply With Quote
Sponsored Links
  #2  
Old 27th May 2006, 13:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Are there any errors in your log files?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th May 2006, 05:40
heygazeebo heygazeebo is offline
Junior Member
 
Join Date: May 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No, the only mention i see of anything related to spam in the log files is when it tagged somthing as spam.

It does say this when i start amavisd...

Quote:
May 28 03:24:11 localhost amavis[16093]: Module Mail::SpamAssassin 3.000003
It says that among the list of modules....

I checked syslog and mail.log and mail.err, the only error i am seeing is this one:

Quote:
localhost dccproc[16115]: socket(UDP): Address family not supported by protocol
Im not sure what that one means though..

Thanks,
Reply With Quote
  #4  
Old 28th May 2006, 22:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

You could try to update to the latest SpamAssassin version. Hopefully that solves the problem...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 30th May 2006, 05:10
heygazeebo heygazeebo is offline
Junior Member
 
Join Date: May 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can you tell me how to find out what version of spamassassin i am running?

I did this:
Code:
/usr/bin/spamassassin -V
SpamAssassin version 3.0.3
  running on Perl version 5.8.4
But i do not think that is the correct?

I did apt-get upgrade spamassassin and it upgraded a lot of stuff, but that version stayed the same

Code:
apt-get upgrade spamassassin
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be upgraded:
  libmysqlclient12 lynx mysql-client mysql-common mysql-server postfix
  postfix-mysql postfix-tls
8 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
I am seeing this in my headers to my email, but nothing to mention Spam anymore..

Code:
X-Virus-Scanned: by amavisd-new-20030616-p10 (Debian) at localhost
Reply With Quote
  #6  
Old 30th May 2006, 16:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by heygazeebo
Can you tell me how to find out what version of spamassassin i am running?

I did this:
Code:
/usr/bin/spamassassin -V
SpamAssassin version 3.0.3
  running on Perl version 5.8.4
But i do not think that is the correct?
That is the correct way to find out.

Quote:
I did apt-get upgrade spamassassin and it upgraded a lot of stuff, but that version stayed the same
The packages are not always up to date. If you want the newest version, you must compile it yourself.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Server name change stops webmail working shajazzi Installation/Configuration 3 16th May 2006 16:00
Installation stops in SpamAssassin aarocha Installation/Configuration 5 28th April 2006 00:37
amavis-new, spamassassin and virtual users - Logs amilcar HOWTO-Related Questions 1 14th February 2006 20:30
Daemonized version of Spamassassin ddelbia General 1 6th January 2006 16:09
Spamassassin configuration DarkBen Installation/Configuration 1 4th January 2006 10:58


All times are GMT +2. The time now is 07:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.