Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th March 2010, 19:37
KZeeSoft KZeeSoft is offline
Member
 
Join Date: Mar 2010
Posts: 43
Thanks: 2
Thanked 1 Time in 1 Post
Default [SOLVED] getmail.sh Cron job fails?

I get this information from my ISPC-Log and wonder what the problem is? Is this normal?

I noticed a problem where my php scripts will not send mail to the server, can this be related somehow?


Code:
/bin/sh: /usr/local/ispconfig/server/scripts/run-getmail.sh: Permission denied
/bin/sh: /usr/local/ispconfig/server/scripts/run-getmail.sh: Permission denied
/bin/sh: /usr/local/ispconfig/server/scripts/run-getmail.sh: Permission denied
ln: creating symbolic link `/var/www/clients/client1/sufuku.net': No such file or directory
chmod: cannot access `/var/www/clients/client0/web1/*': No such file or directory
__________________
Registed Linux User: #506818
Web Hosting and Design - http://www.sufuku.net
Debian Lenny 5.0.4
Mac OSX 10.5
"There are 10 kinds of people in this world - those who understand binary, and those who don't"

Last edited by KZeeSoft; 29th March 2010 at 15:29.
Reply With Quote
Sponsored Links
  #2  
Old 29th March 2010, 15:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th March 2010, 15:27
KZeeSoft KZeeSoft is offline
Member
 
Join Date: Mar 2010
Posts: 43
Thanks: 2
Thanked 1 Time in 1 Post
Default

Hey Falko!

Good to hear from ya =)

Actually, I just figured this issue out:

-I had email forward rules set in my ISP Config 3 panel, and were working fine.
-I upgraded to the new ISP Config 3 last week, and didnt think about the forwarding.
-I was testing my new php scripts (contact forms) and saw they were not working, and couldn't figure out why, until I noticed my mail wasn't working either!
-I did some more digging, and found out that email forwarding is not working properly.

SO! The issue was email forwarding was setup, and the PHP scripts were actually fine, just that the email was being "digitally lost" because of the upgrade to the newest ISP Config.
__________________
Registed Linux User: #506818
Web Hosting and Design - http://www.sufuku.net
Debian Lenny 5.0.4
Mac OSX 10.5
"There are 10 kinds of people in this world - those who understand binary, and those who don't"
Reply With Quote
Reply

Bookmarks

Tags
cron, denied, getmail.sh, php

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cron job question autogun General 2 22nd December 2009 11:54
webalizer cron job not running bolero Installation/Configuration 2 2nd June 2009 13:09
How to create a Cron job for ISPconfig AngelDrago HOWTO-Related Questions 1 13th January 2009 14:30
Cron job failure report torusturtle General 5 18th July 2008 14:13
cron job modified after upgrading V 2.2.5 jfruano Installation/Configuration 1 21st July 2006 12:31


All times are GMT +2. The time now is 14:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.