Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th March 2010, 16:38
ruadog ruadog is offline
Junior Member
 
Join Date: Mar 2010
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Default SpamSnake SpamAssassin Scoring Stops

I have been running the fantastic SpamSnake on Ubuntu 8.04 (http://www.howtoforge.com/the-perfec...ke-ubuntu-8.04) for about a year and a half now with no problems.

Recently, I tweaked a lot of settings in an attempt to fix a long-standing problem with releasing messages from quarantine. I fixed that problem, but somewhere in there I caused a problem with the SpamAssassin scoring.

Every day around midnight, messages stop receiving a SA score, so nothing is marked as spam. Looking in MalWatch at the spam report for each message, it shows "Disabled due to 20 consecutive timeouts". If I reboot the SpamSnake everything starts working and messages are scored properly until midnight when the problem starts all over again.

I am assuming it has something to do with the db_clean.php script, since I see that in the cron it is set to run every night around midnight.

Code:
58 23 * * * /usr/bin/db_clean.php &> /dev/null
The only modification I made to the script was to change the path to functions.php.

Any ideas how to solve this? I know just enough Linux to be dangerous so I probably messed up something very simple.

Thanks.
Peter
Reply With Quote
Sponsored Links
  #2  
Old 28th March 2010, 22:26
ruadog ruadog is offline
Junior Member
 
Join Date: Mar 2010
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Default

I discovered it's not the db_clean.php script. It stopped scoring last night at midnight. This morning I changed the cron to run db_clean.php at 8:00 AM and rebooted the machine. Checking it after 8 it was still scoring the messages appropriately and not timing out.

There must be some other task that is running at midnight that is causing this.

If it makes any difference, I discovered that Bind is not running. However, I have no idea if it was running or not before this problem started.

Any help would be appreciated.
Thanks.

Last edited by ruadog; 28th March 2010 at 22:29.
Reply With Quote
  #3  
Old 29th March 2010, 00:07
ruadog ruadog is offline
Junior Member
 
Join Date: Mar 2010
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Default

I discovered the source of the problem. It's the sa-learn script that runs at 1:30 every morning.
Code:
30 01 * * * /path/to/sa-learn --force-expire --sync -p /etc/MailScanner/spam.assassin.prefs.conf
I was a real Linux newbie when I originally built the Spamsnake and I entered the line into my cron just as you see it, not realizing that I needed to change "/path/to/sa-learn" to the actual path. I changed it to
Code:
30 01 * * * /usr/bin/sa-learn --force-expire --sync -p /etc/MailScanner/spam.assassin.prefs.conf
Now if I run that sa-learn script manually, it creates the Spamassassin scoring problem. The script itself has now been running for more than 15 minutes and is still running.

Any help would be appreciated.
Thanks.
Reply With Quote
  #4  
Old 30th March 2010, 16:49
ruadog ruadog is offline
Junior Member
 
Join Date: Mar 2010
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Default SpamSnake SpamAssassin Scoring Stops - SOLVED

I think I finally figured out what was happening.
Since I hadn't set up the sa-learn script properly when I originally built the Spamsnake, I hadn't actually run a force-expire or sync in about 18 months. When I fixed the script so it would actually run, there were hundreds of thousands of tokens to sync and it was just too many for the system to handle, causing it to timeout.

I ended up running a --clean on the db and starting over. After doing that, sa-learn would actually finish and messages continue to be scored.
Reply With Quote
The Following User Says Thank You to ruadog For This Useful Post:
falko (31st March 2010)
Reply

Bookmarks

Tags
mailwatch, spamassassin, spamsnake

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MailWatch Error: no rows retrieved from database sergio.arnaldo Server Operation 25 21st March 2011 07:05
MailScanner trouble with DBD-MYSQL sergio.arnaldo Server Operation 11 26th August 2009 19:08
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 14:06
Ubuntu 8.04 Spamsnake - all SA scores 0.00 Thomas_Powers HOWTO-Related Questions 23 24th June 2008 18:37
Question on Clamscan and SpamAssassin AZMel Installation/Configuration 3 11th January 2007 20:56


All times are GMT +2. The time now is 15:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.