Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th March 2010, 00:49
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default Vhosts...conf not synced to changes

Any changes made in the ISPCONFIG Administration area are not syncing to the Vhosts_ispconfig.conf file.

1) I removed a lot of directives from a domain on ISPCONFIG. The CONF still has those entries.
2) I added new entries for another domain. The CONF does not show those entries.
3) I disabled and re-enabled WEBALIZER because /stats/ aren't working on any websites. No changes were made to the CONF document.

How can I get ISPCONFIG to sync with the HTTPD configuration files once again?
Reply With Quote
Sponsored Links
  #2  
Old 26th March 2010, 14:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What are the outputs of
Code:
ls -la /root/ispconfig/
and
Code:
ps aux | grep wconf
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 26th March 2010, 15:09
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

Pastes below:

Code:
total 108
drwxr-xr-x 10 root root  4096 Mar 25 19:45 .
drwxr-x---  8 root root  4096 Mar 24 12:33 ..
-rwxr-xr-x  1 root root 33082 Mar 24 12:33 cronolog
-rwxr-xr-x  1 root root  9673 Mar 24 12:33 cronosplit
drwxr-xr-x 12 root root  4096 Mar 24 10:59 httpd
drwxr-xr-x 16 root root  4096 Mar 24 12:33 isp
-rw-r--r--  1 root root     0 Mar 25 20:00 .ispconfig_lock
drwxr-xr-x  7 root root  4096 Mar 24 11:02 libmcrypt
-rw-r--r--  1 root root     8 Mar 25 20:00 .old_path_httpd_root
drwxr-xr-x  6 root root  4096 Mar 24 10:58 openssl
drwxr-xr-x  6 root root  4096 Mar 24 11:17 php
drwxr-xr-x  4 root root  4096 Mar 24 12:33 scripts
drwxr-xr-x  4 root root  4096 Mar 24 12:33 standard_cgis
drwxr-xr-x  2 root root  4096 Mar 24 12:33 sv
-rwx------  1 root root  9389 Mar 24 12:33 uninstall

Code:
root      2414  0.0  0.1   5400  1120 ?        S    Mar25   0:04 /bin/bash /root/ispconfig/sv/ispconfig_wconf
root     32184  0.0  0.0   4784   664 pts/0    R+   10:08   0:00 grep wconf

Last edited by crypted; 26th March 2010 at 15:11.
Reply With Quote
  #4  
Old 26th March 2010, 19:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

Please check if this applies to your problem:

http://www.howtoforge.com/forums/showthread.php?t=7719
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 26th March 2010, 22:28
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

I looked at that thread and did your proposed steps:
Code:
dingle@its:/etc/httpd/conf/vhosts# /usr/sbin/httpd -t
Syntax error on line 187 of /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf:
Invalid command '...', perhaps misspelled or defined by a module not included in the server configuration
dingle@its:/etc/httpd/conf/vhosts#
Code:
<Directory "/var/www/web3/web/egroupware">
   AllowOverride FileInfo       
   ...
</Directory>
However, the latest VHOST file doesn't have that anymore. It has the full egroupware directive. BUT, I deleted egroupware from the ISPCONFIG Apache Directives two weeks ago. It never updated to the Vhost configuration file.

Basically, ISPCONFIG is not doing three notable things:
1) It is not updating the Vhost config file.
2) It is not changing user's passwords.
3) It is not changing mail settings.

Nothing was altered setting-wise on the machine. It just stopped letting us modify stuff sometime this past month.
Reply With Quote
  #6  
Old 27th March 2010, 12:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Please run
Code:
rm -f /root/ispconfig/.ispconfig_lock
/root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
Do you get any errors then?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Updates manarak General 17 15th August 2009 18:33
Since this morning SMTP Server OFFLINE qriz Installation/Configuration 14 28th July 2009 15:05
Webalizer 2.01 conf from old bug problem stefanos Installation/Configuration 3 6th April 2009 09:33
can't access the admin interface, apache lost the conf? Esuk Installation/Configuration 7 24th July 2006 11:35
drupal setup with several vhosts scherpenzeel Installation/Configuration 4 2nd June 2006 12:13


All times are GMT +2. The time now is 04:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.