Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th May 2006, 23:26
Jubalint Jubalint is offline
Junior Member
 
Join Date: Apr 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems with Apache and Updating

Hi, could use a little help. I'm pretty new at all this server stuff so bear with me please.

I installed ISPConfig 2.2.2 on my Debian 3.1 box. Worked great, only thing that was unusual about the setup is I use a remote dns (afraid.org if your wondering), but my sites and such were fine. Logged into ISPConfig and set up my sites and such no problem. No problems for about two weeks. However, recently my websites stopped working. Checking my serv it turns out Apache hadn't turned on. I attempted to manually start it, but no luck. I don't get any errors, but it just doesn't start up. Anyway, I decided maybe if I upgraded to the new dev version (serv just hosts some personal sites, nothing mission critical) it might hopefully just overright whatever messed up setting there is. Unfortunetly, the setup stopped at the configuring extentions part. Here's that portion, I'm pasting the whole part for completeness sake.
Quote:
Configuring extensions
checking whether to enable LIBXML support... yes
checking libxml2 install dir... no
checking for xml2-config path...
configure: error: xml2-config not found. Please check your libxml2 installation.
ERROR: Could not configure PHP
cd: could not get current directory: getcwd: cannot access parent directories: N o such file or directory
cd: could not get current directory: getcwd: cannot access parent directories: N o such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
mv: cannot stat `binaries/aps.tar.gz': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
mv: cannot stat `binaries/cronolog': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
mv: cannot stat `binaries/cronosplit': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
mv: cannot stat `binaries/zip': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
mv: cannot stat `binaries/unzip': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
tar: spamassassin.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
mv: cannot stat `spamassassin': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
tar: uudeview.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
mv: cannot stat `uudeview': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
tar: clamav.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
mv: cannot stat `clamav': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
tar: aps.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
./setup2: line 794: ispconfig_tmp/php/bin/php: No such file or directory
ERROR: The PHP binary coming with ISPConfig does not work properly on your syste m! The installation routine stops here!
job-working-directory: could not get current directory: getcwd: cannot access pa rent directories: No such file or directory
So I'm guessing something's wrong with my PHP setup, and I'm wondering what I should go about fixing it with. I don't have any weird setup on my system and am wondering if I just fully remove and re-install PHP if that would maybe be enough? Or maybe uninstall and reinstall ISPConfig? Thanks for your time.
Reply With Quote
Sponsored Links
  #2  
Old 21st May 2006, 13:50
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,484
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

The dev version has other system requirements then the 2.2.2 version. This is the reason why we do not recommend upgrades from 2.2.2 to 2.3.1-dev at the momemnt.

To install ISPConfig 2.3.1-dev, you must have the libxml2-dev package from your linux distribution installed.

Please check if you have files like this in your /tmp folder:

home_admispconfig_05_19_2006__13_17_20.tar.gz
root_ispconfig_05_19_2006__13_17_20.tar.gz

The names may vary depending on the date and time you run the ISPCOnfig installers. Copy these files to / and unpack them. This will restore your old ISPConfig installation. Then install libxml2-dev from your linux distribution and run the setup of ISPConfig-2.3.1-dev again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st May 2006, 19:50
Jubalint Jubalint is offline
Junior Member
 
Join Date: Apr 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Alright, thanks for the help. Got it working .
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 2 - DNS Not updating jackaltx Installation/Configuration 21 24th November 2008 13:06
UI Problem with additonal Apache directives tstich General 3 3rd November 2005 14:11


All times are GMT +2. The time now is 15:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.