Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th May 2006, 14:45
22hn 22hn is offline
Junior Member
 
Join Date: May 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default virtusertable not getting updated

Hi!

I'm quite new to both Linux, Postfix and ISPConfig and have a couple of questions for you...

If I add a site in ispconfig and then add an email user to that site, shouldn't the virtusertable and local-host-names files be updated then?

The only way I can get something to happen, is by manually running the command '/root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php' (found in another thread).

Then my virtusertable file gets updated with these 3 lines:
www.domain1.com VIRTUALDOMAIN
mike@www.domain1.com web8_mike
web8_mike@www.domain1.com web8_mike

But still no change in local-host-names...

Why is the www-part included in the email address? When editing the email user in ispconfig, it's not...

Another thing... The autogenerated 'web8_'-prefix, can that be changed?
Reply With Quote
Sponsored Links
  #2  
Old 20th May 2006, 16:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,982 Times in 3,903 Posts
Default

Quote:
If I add a site in ispconfig and then add an email user to that site, shouldn't the virtusertable and local-host-names files be updated then?

The only way I can get something to happen, is by manually running the command '/root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php' (found in another thread).
Maybe the server daemon thread has died. Please restart ISPConfig:

/etc/init.d/ispconfig_server restart

Quote:
Then my virtusertable file gets updated with these 3 lines:
www.domain1.com VIRTUALDOMAIN
mike@www.domain1.com web8_mike
web8_mike@www.domain1.com web8_mike

But still no change in local-host-names...

Why is the www-part included in the email address? When editing the email user in ispconfig, it's not...
local-host-names changes only if you add an new website or co-domain.
In you case the co-domain domain1.com (with empty host field) is missing in the website www.domain1.com.

Quote:
Originally Posted by 22hn
Another thing... The autogenerated 'web8_'-prefix, can that be changed?
http://www.howtoforge.com/faq/14_47_en.html
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 22nd May 2006, 13:26
trueshanti trueshanti is offline
Member
 
Join Date: May 2006
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i didnt like the www-part either .. makes nasty aliases in roundcubemail with auto-created users

so i fixed some libs
Code:
root#:>/root/ispconfig.bak/scripts/lib/classes# diff ispconfig_postfix.lib.php ispconfig_postfix.lib.php.orig
203c203
<             if(!empty($web["web_host"]) and trim($web["web_host"]) != www and trim($web["web_web_domain"]) != "somesubdomain"){
---
>             if(!empty($web["web_host"])){
303,308c303,307
<
<           if(trim($web["web_host"]) != "" and trim($web["web_host"]) != www ){
<                $virtualdomain = $web["web_host"].".".$web["web_domain"];
<                 } else {
<                $virtualdomain = $web["web_domain"];
<               }
---
>           if(trim($web["web_host"]) != ""){
>             $virtualdomain = $web["web_host"].".".$web["web_domain"];
>           } else {
>             $virtualdomain = $web["web_domain"];
>           }
339c338
<               if(trim($codomain["domain_host"]) != "" and trim($codomain["domain_host"]) != www){
---
>               if(trim($codomain["domain_host"]) != ""){
419c418
< ?>
---
> ?>
\ No newline at end of file
i also make some template-changes vor named and procmail but non for postfix

-c-
Reply With Quote
  #4  
Old 22nd May 2006, 21:51
22hn 22hn is offline
Junior Member
 
Join Date: May 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Using trueshanti's code change I got rid of the annoing extra codomain to get the alias file correct. Thanks trueshanti!

But I still have to run the writeconf script to change any file contents ... And the deamon is running...

I also got rid of the username prefix...!


I added a test account and was able to login to the web mail. I successfully sent an outgoing email that arrived at it's destination. So far so good!

I then sent an email to this test user from the internet. The email is accepted by postfix and the sending smtp server receives an OK!

But it newer reaches the users inbox...!

and the mail log is constanly repeating:
postfix/master[12474]: warning: /usr/lib/postfix/local: bad command startup -- throttling
postfix/local[12727]: fatal: open database /etc/postfix/virtusertable.db: Operation not permitted
postfix/master[12474]: warning: process /usr/lib/postfix/local pid 12727 exit status 1
postfix/master[12474]: warning: /usr/lib/postfix/local: bad command startup -- throttling

This "operation not permitted" is seen in both /var/log/mail and /var/log/mail.err.

I also get the same response when doing a 'postmap /var/postfix/virtusertable'

Any ideas on this 'operation not permitted' error?
Reply With Quote
  #5  
Old 22nd May 2006, 23:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by 22hn
postfix/local[12727]: fatal: open database /etc/postfix/virtusertable.db: Operation not permitted
Which distribution do you use? Fedora or SuSE? If you use Fedora, then disable SELinux, if you are on SuSE, disable AppArmor.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 23rd May 2006, 00:37
22hn 22hn is offline
Junior Member
 
Join Date: May 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Aaarrrghhhh... So obvious, but yet so hard to crack...!


Thanks a lot falko!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Zone files are not updated after deletion from web JAYDEE.U Installation/Configuration 1 1st January 2007 10:09
Webalizer not updated since 01 Jan 06? Zoon General 24 22nd March 2006 20:29
sasldb2 on Debian in chroot not updated.... andreaskorte Installation/Configuration 2 17th February 2006 00:22
turn off "PHP Scripts" problem after updated php k-dev4edv Installation/Configuration 2 7th February 2006 09:34
Debian GNU/Linux 3.1 Updated (r1) AdykOSu Installation/Configuration 4 22nd December 2005 20:26


All times are GMT +2. The time now is 22:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.