#1  
Old 1st March 2010, 21:23
cbelote cbelote is offline
Junior Member
 
Join Date: Nov 2009
Location: Colorado Springs, CO
Posts: 7
Thanks: 1
Thanked 1 Time in 1 Post
Exclamation mail server not working

Hi,
I followed the tutorial: The Perfect Server - Ubuntu 9.10 [ISPConfig 3]. I have setup a mail account in ISPConfig, forwarded IMAP, POP3, and SMTP ports to my server, white listed email addresses, ensured my ISP is not blocking any of my ports and ensured my MX records point to my server. I am not receiving emails to or from the new email address and have not received any non-delivery messages! ISPConfig is showing no traffic on the new account either.



I am not sure what to do next as I have exhausted my technical knowledge here any help is much appreciated in advance!
Reply With Quote
Sponsored Links
  #2  
Old 2nd March 2010, 01:39
cbelote cbelote is offline
Junior Member
 
Join Date: Nov 2009
Location: Colorado Springs, CO
Posts: 7
Thanks: 1
Thanked 1 Time in 1 Post
Default

Ok, to update on my issue: I have gotten a delivery fail message from my mail server saying "unknown user: admin" My domain is cpb3.com by the way. Now for the wierd part: I am getting every other email message (2 out of 4) sent to this admin account in my /var/mail/ directory.
Reply With Quote
  #3  
Old 2nd March 2010, 16:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Any errors in your mail log? What's in /etc/postfix/main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
cbelote (3rd March 2010)
  #4  
Old 3rd March 2010, 04:22
cbelote cbelote is offline
Junior Member
 
Join Date: Nov 2009
Location: Colorado Springs, CO
Posts: 7
Thanks: 1
Thanked 1 Time in 1 Post
Default Re: mail server not working

First, thank's falko for the help. You're a genius when it comes to this stuff
Here are the errors I see in my mail warn log:

Code:
Mar 2 17:44:23 cpb3 postfix/smtpd[19551]: warning: 209.191.85.12: hostname smtp125 verification failed: Name or service not known
Mar 2 17:44:24 cpb3 postfix/trivial-rewrite[19554]: warning: do not list domain cpb3.com in BOTH mydestination and virtual_mailbox_domains
Here is what seems to be repeated every few minuites in my mail log:

Code:
Mar 2 20:05:01 cpb3 pop3d: Connection, ip=[::ffff:127.0.0.1]
Mar 2 20:05:01 cpb3 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
Mar 2 20:05:01 cpb3 imapd: Connection, ip=[::ffff:127.0.0.1]
Mar 2 20:05:01 cpb3 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
Mar 2 20:05:01 cpb3 postfix/smtpd[21183]: connect from localhost.localdomain[127.0.0.1]
Mar 2 20:05:01 cpb3 postfix/smtpd[21183]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Mar 2 20:05:01 cpb3 postfix/smtpd[21183]: disconnect from localhost.localdomain[127.0.0.1]
Here's my main.cf:

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = cpb3.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = cpb3.com, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_tls_security_level = may
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
virtual_create_maildirsize = yes
virtual_maildir_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
message_size_limit = 0
Reply With Quote
  #5  
Old 3rd March 2010, 10:50
cbelote cbelote is offline
Junior Member
 
Join Date: Nov 2009
Location: Colorado Springs, CO
Posts: 7
Thanks: 1
Thanked 1 Time in 1 Post
Talking

I might have resolved my issue:

#1. My IP was, for some strange reason, on a Spamhaus black list. I had it removed (which is ironic because I run a spam bot honey pot on my site lol)

#2. I solved the duplicate domain name issue in mydestination and virtual_mailbox_domain by removing it from the mydestination line in /etc/postfix/main.cf and restarting Postfix.

Thanks falko for the guidance! I'll subscribe once I get the money to do so
Reply With Quote
The Following User Says Thank You to cbelote For This Useful Post:
falko (4th March 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How cai remove amavis from postfix ? gabrix Server Operation 16 2nd October 2012 09:58
Sending emails with custom FROM email address merisor Installation/Configuration 4 8th February 2010 16:27
Need help get mail to work (can't recieve and apperently can't send) omega13a Installation/Configuration 19 20th August 2009 21:06
Help configure Postfix to use alt port 465 or 587 BoloMarkIII Installation/Configuration 10 16th March 2009 17:57
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 15:44


All times are GMT +2. The time now is 13:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.