#1  
Old 14th January 2010, 19:38
sruedat sruedat is offline
Junior Member
 
Join Date: Dec 2009
Posts: 23
Thanks: 3
Thanked 2 Times in 2 Posts
Default pear and change_sqlpass plugin

Hello, I have tried to install the squirrelmail plugin change_sqlpass, so my clients can change they own password... but when I active the plugin this happen:

http://img694.imageshack.us/img694/3...uirrelmail.jpg


What happen?

I'm on suse 11.1

pear -V said:
PEAR Version: 1.5.0
PHP Version: 5.2.11
Zend Engine Version: 2.2.0

and pear install DB said:
pear install DB
Channel pear.php.net does not support xml-rpc method package.getDownloadURL
Cannot initialize 'DB', invalid or missing package file
Package "DB" is not valid
install failed

thanks for your help.
Reply With Quote
Sponsored Links
  #2  
Old 15th January 2010, 11:29
sruedat sruedat is offline
Junior Member
 
Join Date: Dec 2009
Posts: 23
Thanks: 3
Thanked 2 Times in 2 Posts
Default

it was my fault, i have a problem in the config.php file.... i'm forggot "<?php", i'm i idiot...sorry.

But now in the webmail adress only appears a blank page... I'm doing somethin wrong.

Thanks.
Reply With Quote
  #3  
Old 15th January 2010, 14:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Please make sure you introduced no PHP syntax error when you modified the config.php file of the change_sqlpass plugin.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 16th January 2010, 09:50
sruedat sruedat is offline
Junior Member
 
Join Date: Dec 2009
Posts: 23
Thanks: 3
Thanked 2 Times in 2 Posts
Default thanks

I had followed this tutorial...and I had used this code.

http://www.howtoforge.com/how-to-con...onfig-3-server

Now I have used the config.php.sample... and the problem is solved;

But I think that I have problems with pear because when I try to change the pass this happen: "Could not find Pear DB library".

If I do pear list I get this:
Installed packages, channel pear.php.net:
=========================================
Package Version State
Console_Getopt 1.2.3 stable
DB 1.7.13 stable
PEAR 1.9.0 stable
Structures_Graph 1.0.3 stable
XML_Parser 1.3.2 stable
XML_Util 1.2.1 stable



Thanks for your infinite patient.

Last edited by sruedat; 16th January 2010 at 10:21.
Reply With Quote
  #5  
Old 16th January 2010, 16:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Try this:
Code:
aptitude install php-pear

pear install DB
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 16th January 2010, 17:02
sruedat sruedat is offline
Junior Member
 
Join Date: Dec 2009
Posts: 23
Thanks: 3
Thanked 2 Times in 2 Posts
Default

I had done it yet...
I have done it again, but I have the same problem...: "Could not find Pear DB library"

I works in opensuse 11.1_X64: "yast -i php-pear php-pear-db"
in fact if you see the pear list the DB package appears.
thanks.

Last edited by sruedat; 17th January 2010 at 13:21.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 07:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.