Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Technical

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st January 2010, 21:29
kaza kaza is offline
Junior Member
 
Join Date: Jul 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default tar backup (multivolume) error message

Hello,

I attempted to perform a full backup using "tar" and a SCSI tape drive.
The command issued (as a root) was:

tar -cvMPf /dev/st0 --volno-file /root/backup/backup_vol_nums /*

It started OK but after some time (I guess, when the first tape had
been filled up) I've got the error message:

tar: /dev/st0: Cannot close: Input/output error
Prepare volume #2 for `/dev/st0' and hit return:

I attempted to replace the tape and got the error message:

tar: /dev/st0: Warning: Cannot open: No such device or address
Prepare volume #2 for `/dev/st0' and hit return:

From that point and on, the device "/dev/st0" behaved busy
and even the "shutdown" didn't worked - apparently
the system waited until everything had been properly closed
while this device remained opened so I finally had to brutally
power down the system. Reading about SCSI tape device names
I saw that there are few names for the same tape:

/dev/st0 for mode 0
/dev/st0l for mode 1
/dev/st0m for mode 2
/dev/st0a for mode 3

Did I used the correct device name for multi-volume backup with tar?
What is the difference between different modes of accessing the SCSI tape?
Any ideas as to what causes the error message?


TIA,
kaza.
Reply With Quote
Sponsored Links
  #2  
Old 15th January 2010, 15:16
kaza kaza is offline
Junior Member
 
Join Date: Jul 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anyone has/had such problem?
Reply With Quote
  #3  
Old 16th January 2010, 16:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Unfortunately I have no experience with tape drives...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Online Backup : What do you use and how do you setup it ? XZed Technical 5 4th January 2010 19:02
ISPConfig Installation error linuxuser1 Installation/Configuration 4 26th February 2008 07:38
ERROR: Could not make ClamAV chua_jose Installation/Configuration 1 3rd January 2008 17:47
ISPConfig Instalations problems ggarcia24 Installation/Configuration 12 13th November 2007 01:07
Error on install igbe Installation/Configuration 7 28th February 2007 23:55


All times are GMT +2. The time now is 21:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.