Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st January 2010, 12:53
kresser kresser is offline
Junior Member
 
Join Date: Jan 2010
Posts: 23
Thanks: 0
Thanked 4 Times in 4 Posts
Default Courier, Postfix, Squirrelmail Mysql How-To

Ok, i followed this tutorial to the "T", http://www.howtoforge.com/virtual-us...l-debian-lenny. I am not able to login to the mailboxes with squirrelmail, it says "connection dropped by imap server" I used the whole address as a login just like it said to do. I can sucessfully authenticate with outlook express but it throws an error that say's arealreason.com/support, no such file or directory. i can telnet into it remotely but when i type ehlo messiah.arealreason.com it just keeps showing all the 250 lines and wont let me generate a message. from what i saw on the comments on the tutorial and googling there are many other people with this problem, however i found no solutions. This is fresh work and i have not touched any config files since finishing the tutorial, so if anyone has this solution it would be greatly appreciated. This server needs to go into production in a few days so let me know. Thx -Rick
Reply With Quote
Sponsored Links
  #2  
Old 1st January 2010, 14:10
kresser kresser is offline
Junior Member
 
Join Date: Jan 2010
Posts: 23
Thanks: 0
Thanked 4 Times in 4 Posts
Default Also...

This is also coming up in mail logs.

Jan 1 07:33:17 messiah postfix/smtp[46100]: 9331B6E68D87: to=<jim@arealreason.com>, relay=none, delay=0.16, delays=0.15/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

Jan 1 07:33:47 messiah imapd: Connection, ip=[::ffff:99.196.176.7]
Jan 1 07:33:51 messiah imapd: chdir arealreason.com/support/: No such file or directory

Jan 1 07:39:04 messiah postfix/smtp[55258]: 879876E68D82: to=<root@arealreason.com>, orig_to=<root>, relay=none, delay=4739, delays=4739/0.28/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

Jan 1 08:02:24 messiah postfix/scache[28585]: statistics: start interval Jan 1 07:59:04
Jan 1 08:02:24 messiah postfix/scache[28585]: statistics: domain lookup hits=0 miss=1 success=0%
Jan 1 08:02:24 messiah postfix/scache[28585]: statistics: address lookup hits=0 miss=1 success=0%
Reply With Quote
  #3  
Old 2nd January 2010, 06:13
kresser kresser is offline
Junior Member
 
Join Date: Jan 2010
Posts: 23
Thanks: 0
Thanked 4 Times in 4 Posts
Default Some updates...

I saw where several other people were having this issue and one person went in and manually created his domain folder like /home/vmail/domain/username. I did this the same and it got both of us one step farther. I finally figured out this is a mail folder and permission issue. I can successfuly connect and authenticate with the server with squirrelmail and outlook, squirrelmail gives the imap connection dropped after authenticating and oe says mydomain/account is not there. well i manually created the domain and account folder chowned with vmail properties and i get one step farther but still more folder errors. squirrelmail now shows the 2 frames after login but this error shows in each frame:

ERROR:
ERROR: Could not complete request.
Query: SELECT "INBOX"
Reason Given: Unable to open this mailbox.

I know alot of people had this problem and i would be so grateful if someone could help me fix the folder problems and direct me in the right direction as to fix them being automatically created. the sending an email to the box didnt work.
Reply With Quote
  #4  
Old 2nd January 2010, 15:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by kresser View Post
This is also coming up in mail logs.

Jan 1 07:33:17 messiah postfix/smtp[46100]: 9331B6E68D87: to=<jim@arealreason.com>, relay=none, delay=0.16, delays=0.15/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
It seems as if amavisd isn't running. Please restart it and send the welcome mail again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 3rd January 2010, 00:41
kresser kresser is offline
Junior Member
 
Join Date: Jan 2010
Posts: 23
Thanks: 0
Thanked 4 Times in 4 Posts
Default you were right about amavis, still wont start...

Ran this:

messiah:~# /etc/init.d/amavis start
Starting amavisd: amavisd-new.
messiah:~#

Didn't know if there was supposed to be more information on loading than what it gave.

Also even after i give it the start sig, if i send restart it says this:

messiah:~# /etc/init.d/amavis restart
Stopping amavisd: (not running).
Starting amavisd: amavisd-new.

Still says "connection refused" in logs.

I need some guidance on where to start looking for the problem...

Thx in advance.
Reply With Quote
  #6  
Old 3rd January 2010, 03:14
kresser kresser is offline
Junior Member
 
Join Date: Jan 2010
Posts: 23
Thanks: 0
Thanked 4 Times in 4 Posts
Default ok need help.

I googled amavis wont start, and found out it does that right out of the box now. I guess a package problem.

So... i decided to just try without it. I commented out the lines that was added to main.cf and master.cf. Restarted the server, now when i send an email i get this error msg:

Jan 3 04:56:20 messiah postfix/virtual[14245]: ECDA26E68DE0: to=<support@arealreason.com>, relay=virtual, delay=0.18, delays=0.1/0/0/0.08, dsn=5.1.1, status=bounced (unknown user: "support@arealreason.com")

and for the first time i am getting messages back from from my mail server saying message undeliverable....

hmm.
Reply With Quote
  #7  
Old 3rd January 2010, 17:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Does support@arealreason.com exist in your database?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
courier, mysql, postfix, quota, squirrelmail

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 9.10) keyslapper HOWTO-Related Questions 4 20th April 2010 15:46
Postfix not responding to telnet CarbonCopy Server Operation 6 8th May 2009 05:39
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36


All times are GMT +2. The time now is 23:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.