#1  
Old 19th December 2009, 15:07
untg untg is offline
HowtoForge Supporter
 
Join Date: Dec 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Groups totally gone.

I've installed a new server and it seems to be working ok, until I has a look at /etc/group and there is only one listing,
client1:x:100:www-data
Is that normal for ispconfig3, I would have thought /etc/group had more listings?

I just installed apt-get install ubuntu-desktop so I don't know if that would have anything to do with it.

Is someone able to sent me their newly installed ISPConfig3's group file? I'm sure mine has something seriously wrong with (I only installed the server two days ago).

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 20th December 2009, 14:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Do you have a backup of /etc/group? What's the output of
Code:
ls -l /etc/group*
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 21st December 2009, 00:45
untg untg is offline
HowtoForge Supporter
 
Join Date: Dec 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Cool

I've reinstalled since then but i'll remember to backup the groups file and passwd file.
Just wondering if there is any reason why that would happen or just a freak accident of some package.
Reply With Quote
  #4  
Old 21st December 2009, 05:08
untg untg is offline
HowtoForge Supporter
 
Join Date: Dec 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just in case anyone else has this problem, I just noticed that it looks like backups are kept in /var/backups/ automatically by debian/ubuntu.

So I could have probably just restored /etc/group from /var/backups.

oh well, next time
Reply With Quote
  #5  
Old 21st December 2009, 09:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

ISPConfig 3 does not manage the /etc/group file directly, it uses only the groupadd command from ubuntu to add groups, so its very unlikely that this has been caused by ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
/etc/group, group, group missing, groups, ispconfig3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 17:54
Ubuntu Hardy server + OpenLDAP + Samba PDC. Simple question about groups. awe HOWTO-Related Questions 3 3rd September 2009 13:20
RE: Centos 5.3 - Installing Package groups justinj HOWTO-Related Questions 2 11th June 2009 19:58
Virtual Users And Domains With Postfix, Courier And MySQL - Email groups Maxum HOWTO-Related Questions 2 11th May 2007 18:03
Gnome -> Users and Groups crash after ISPConfig install MrLight Installation/Configuration 1 9th April 2007 18:27


All times are GMT +2. The time now is 14:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.