Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > MyDNSConfig > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th May 2006, 20:47
MooktaKiNG MooktaKiNG is offline
Junior Member
 
Join Date: May 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default BIND as a slave for MyDNS master

I would like to setup a slave with BIND. It should do nothing other then get all the dns data from MyDNS master.

How should i configure the slave BIND?
(i'm gonna use chrooted bind, which is simple enough)

This is becuase i want to install a slave without any burden, like mysql etc, just want a plain slave thats all. Also i don't want to share the same mysql database since that would defeat the purpose of having it in the first place. If master goes down so will slave.

If there is better way (lighter way ) please let me know.
Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 9th May 2006, 20:50
MooktaKiNG MooktaKiNG is offline
Junior Member
 
Join Date: May 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It would be even more amazing if i could run MyDNS using sqlite anyway just a thought.
Reply With Quote
  #3  
Old 9th May 2006, 22:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Have a look at this tutorial: http://www.howtoforge.com/traditional_dns_howto
The slave configuration is also explained there.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 24th May 2006, 19:04
ph00dz ph00dz is offline
Junior Member
 
Join Date: May 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do I need to do anything special to the mydns server to make it transfer correctly?
Reply With Quote
  #5  
Old 24th May 2006, 19:07
ph00dz ph00dz is offline
Junior Member
 
Join Date: May 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

oops... nevermind. figured it out.
Reply With Quote
  #6  
Old 31st October 2009, 15:28
mooseman mooseman is offline
Junior Member
 
Join Date: Dec 2006
Posts: 22
Thanks: 1
Thanked 2 Times in 1 Post
Default

Hi could you enlighten us on how you did it...

My current situation:

I attempted to create a "master" dns server in ISPconfig 3 using mydns and have it replicate to my ispconfig 2 bind dns. Both servers are being NATed behind respective firewalls.

I updated the mydns.conf with the following options:

allow-axfr = yes
allow-update = yes
notify-enabled = yes
notify-source = (public NATed IP of mydns master)

I created the zone on the master ispconfig 3 server (mydns) and created a slave zone on the ispconfig 2 (bind 9) server pointing to the master.

The initial axfr goes through but any updates to the zone are not transferred with the following error in the log:

I receive the following in the syslog of the ispconfig 2 bind server:

Oct 31 10:03:30 (server) named[(PID)]: client (public.IP.of.mydns)#47075: received notify for zone '(domain).com'
Oct 31 10:03:30 (server) named[(PID)]: zone .com/IN: Transfer started.
Oct 31 10:03:30 (server) named[(PID)]: transfer of '(domain).com/IN' from (public.IP.of.mydns)#53: connected using (private.IP.of.bind)#35684
Oct 31 10:03:30 (server) named[(PID)]: transfer of '(domain).com/IN' from (public.IP.of.mydns)#53: failed while receiving responses: end of file
Oct 31 10:03:30 (server) named[(PID)]: transfer of '(domain).com/IN' from (public.IP.of.mydns)#53: end of transfer


Is the "failed while receiving responses: end of file" occurring because of the private ip being sent?? is "notify-source = " config option of mydns supposed to fix that?

Any help would be appreciated.

Thanks,

Last edited by mooseman; 31st October 2009 at 18:45.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Slave DNS issues wadoo99 Installation/Configuration 6 24th October 2007 21:11
Pri & Slave DNS HOWTO (FC4) ppettigrew Suggest HOWTO 0 1st April 2006 15:35
Bind-Chroot-Howto (Debian) spaz HOWTO-Related Questions 5 9th March 2006 14:50
Bind stops and cannot be restarted after a slave domain is added jason Installation/Configuration 20 19th August 2005 08:16


All times are GMT +2. The time now is 06:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.