#1  
Old 22nd November 2009, 01:27
richardson richardson is offline
Junior Member
 
Join Date: Nov 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default email problem

I have ispconfig3 on suse 11.2
I have some problems with my mailserver. When is send a mail to example@mydomain.com i had this in the error log:
Code:
Nov 22 01:18:02 core postfix/smtpd[5395]: connect from unknown[127.0.0.1]
Nov 22 01:18:02 core postfix/smtpd[5395]: AFB142AD4D: client=unknown[127.0.0.1]
Nov 22 01:18:02 core postfix/cleanup[5351]: AFB142AD4D: message-id=<20091122001758.DE9D92AD4E@core.mydomain.com>
Nov 22 01:18:02 core postfix/smtpd[5395]: disconnect from unknown[127.0.0.1]
Nov 22 01:18:02 core postfix/qmgr[11523]: AFB142AD4D: from=, size=2422, nrcpt=1 (queue active)
Nov 22 01:18:02 core amavis[20545]: (20545-05) Passed BAD-HEADER, -> , quarantine: badh-yeDbPnR8zdZO, Message-ID: <20091122001758.DE9D92AD4E@core.mydomain.com>, mail_id: yeDbPnR8zdZO, Hits: 0.233, size: 573, queued_as: AFB142AD4D, 3801 ms
Nov 22 01:18:02 core maildrop[5401]: Cannot set my user or group id.
Nov 22 01:18:02 core postfix/smtp[5355]: DE9D92AD4E: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=3.9, delays=0.04/0.01/0/3.8, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=20545-05, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as AFB142AD4D)
Nov 22 01:18:02 core postfix/qmgr[11523]: DE9D92AD4E: removed
Nov 22 01:18:02 core postfix/pipe[5400]: AFB142AD4D: to=, relay=maildrop, delay=0.05, delays=0.02/0.01/0/0.01, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Cannot set my user or group id. )
in var/vmail i have this:
Code:
core:/var/vmail # ls -l
total 12
-rw------- 1 vmail vmail 1382 Nov 18 20:20 .mailfilter
-rw-r--r-- 1 root  root  1382 Nov 18 20:20 .mailfilter~
drwxr-xr-x 4 root  root  4096 Nov 21 15:42 mailfilters
Reply With Quote
Sponsored Links
  #2  
Old 22nd November 2009, 11:34
richardson richardson is offline
Junior Member
 
Join Date: Nov 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i send email to an exesting account, and i had this reply from the server:

Code:
This is the mail system at host core.domain.com.

####################################################################
# THIS IS A WARNING ONLY.  YOU DO NOT NEED TO RESEND YOUR MESSAGE. #
####################################################################

Your message could not be delivered for more than 1 hour(s).
It will be retried until it is 5 day(s) old.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                  The mail system

<mail@domain.com>: temporary failure. Command output:
   /usr/bin/maildrop: Cannot set my user or group id.

Final-Recipient: rfc822; mail@domain.com
Original-Recipient: rfc822;mail@domain.com
Action: delayed
Status: 4.3.0
Diagnostic-Code: x-unix; /usr/bin/maildrop: Cannot set my user or group id.
Will-Retry-Until: Fri, 27 Nov 2009 01:24:11 +0100 (CET)
I hope Till you can help me.
Reply With Quote
  #3  
Old 22nd November 2009, 14:10
richardson richardson is offline
Junior Member
 
Join Date: Nov 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default more

I think i know the problem.
My maildrop doent make the maildir.

Code:
core:/var/vmail # maildrop -V 3 -d sysadm@domain.com
maildrop: authlib: groupid=5000
maildrop: authlib: userid=5000
maildrop: authlib: logname=sysadm@domain.com, home=/var/vmail, mail=/var/vmail/domain.com/sysadm
maildrop: Changing to /var/vmail
maildrop: Home directory owned by wrong user.
the problem is that here is my /var/vmail:
Code:
core:/var/vmail # ls -l
total 12
-rwx------ 1 vmail vmail 1382 Nov 22 11:24 .mailfilter
-rw-r--r-- 1 root  root  1382 Nov 22 11:24 .mailfilter~
drwxr-xr-x 4 root  root  4096 Nov 21 15:42 mailfilters
And the directory:
Code:
core:/var/vmail # ls -ld
drwxr-xr-x 3 vmail vmail 4096 Nov 22 14:01 .
What shoud i do?
Reply With Quote
  #4  
Old 22nd November 2009, 14:43
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,183
Thanks: 829
Thanked 5,415 Times in 4,258 Posts
Default

The maildir is made by ispconfig and not maildrop. Please take a look in the ispconfog monitor and post the error message that you get there in the system log.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 22nd November 2009, 15:15
richardson richardson is offline
Junior Member
 
Join Date: Nov 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
Nov 22 15:01:01 core /usr/sbin/cron[20346]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Nov 22 15:02:01 core /usr/sbin/cron[20374]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Nov 22 15:03:01 core /usr/sbin/cron[20404]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Nov 22 15:04:01 core /usr/sbin/cron[20432]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Nov 22 15:05:01 core /usr/sbin/cron[20460]: Permission denied
Nov 22 15:05:01 core /usr/sbin/cron[20462]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Nov 22 15:05:01 core pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Nov 22 15:05:01 core pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Permission denied? mybe there is the problem
Reply With Quote
  #6  
Old 23rd November 2009, 14:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
crontab -l
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Email Problem Darren996 General 3 5th October 2008 12:43
problem at email admin user nasir Installation/Configuration 1 26th February 2008 18:51
Postmaster Email Problem Alam General 8 19th February 2008 14:49
email problem, one client only chancer Installation/Configuration 35 13th February 2008 12:34


All times are GMT +2. The time now is 12:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.